aboutsummaryrefslogtreecommitdiff
path: root/devel/linux-sdl12/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-17 02:12:55 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-17 02:12:55 +0000
commit203a7b96e5c7c68d7472093721977e3d0275fdf4 (patch)
tree5c86553566bcf095d215c6aef7713ab4f6c46415 /devel/linux-sdl12/Makefile
parentfccb6415b8be5a8e2a441673f77d7dec57070f04 (diff)
downloadports-203a7b96e5c7c68d7472093721977e3d0275fdf4.tar.gz
ports-203a7b96e5c7c68d7472093721977e3d0275fdf4.zip
Notes
Diffstat (limited to 'devel/linux-sdl12/Makefile')
-rw-r--r--devel/linux-sdl12/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/linux-sdl12/Makefile b/devel/linux-sdl12/Makefile
new file mode 100644
index 000000000000..abe32c4bb0e4
--- /dev/null
+++ b/devel/linux-sdl12/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: linux-gtk
+# Date created: 8 October 2001
+# Whom: Martin Matuska <matuska@wu-wien.ac.at>
+# Based on: emulators/linux_base by marcel@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl
+PORTVERSION= 1.2.2.1
+CATEGORIES= devel linux
+MASTER_SITES= http://www.libsdl.org/release/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME:U}-${PORTVERSION:S/.1$/-1/}.${MACHINE_ARCH}
+EXTRACT_SUFX= .rpm
+EXTRACT_ONLY=
+
+MAINTAINER= matuska@wu-wien.ac.at
+
+BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+
+USE_LINUX_PREFIX= yes
+LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
+
+ONLY_FOR_ARCHS= i386 alpha
+DIST_SUBDIR= rpm
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+
+DBPATH= /var/lib/rpm
+RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
+ --nodeps --replacepkgs
+RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+
+do-install:
+ @${LOCALBASE}/bin/rpm -U ${RPMFLAGS} ${RPMDIR}/${DISTFILES}
+ @${LDCONFIG_LINUX}
+
+.include <bsd.port.mk>