aboutsummaryrefslogtreecommitdiff
path: root/devel/linux_kdump/Makefile
diff options
context:
space:
mode:
authorAlexander Kabaev <kan@FreeBSD.org>2006-01-02 23:02:11 +0000
committerAlexander Kabaev <kan@FreeBSD.org>2006-01-02 23:02:11 +0000
commitaf6298430c8c7b4fde7b175d329826e775339573 (patch)
tree4e364a0796d453270e2ee821bd8dae09ded0ac61 /devel/linux_kdump/Makefile
parent7fcf09287fc0f54d2236c93fc76de64ab3a69f5c (diff)
downloadports-af6298430c8c7b4fde7b175d329826e775339573.tar.gz
ports-af6298430c8c7b4fde7b175d329826e775339573.zip
Notes
Diffstat (limited to 'devel/linux_kdump/Makefile')
-rw-r--r--devel/linux_kdump/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/linux_kdump/Makefile b/devel/linux_kdump/Makefile
new file mode 100644
index 000000000000..cf4ee40d96f3
--- /dev/null
+++ b/devel/linux_kdump/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: linux_kdump
+# Date created: Nov 26 1997
+# Whom: msmith@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux_kdump
+PORTVERSION= 1.5
+PORTREVISION= 1
+CATEGORIES= devel linux
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= marcel
+
+MAINTAINER= marcel@FreeBSD.org
+COMMENT= Linux-compatability ktrace.out processor
+
+BUILD_DEPENDS= /compat/linux/usr/bin/gcc:${PORTSDIR}/devel/linux_devtools-8
+
+ONLY_FOR_ARCHS= i386
+MAN1= linux_kdump.1
+PLIST_FILES= bin/linux_kdump
+
+.include <bsd.port.pre.mk>
+
+.ifndef(SRCDIR)
+SRCDIR= /usr/src
+pre-everything::
+ @${ECHO_MSG} '===> Using the FreeBSD source tree under /usr/src'
+ @${ECHO_MSG} '===> Set SRCDIR to use an alternate source tree'
+.endif
+
+.if !exists(${SRCDIR}/sys/i386/linux/syscalls.master)
+IGNORE= "requires kernel source present in ${SRCDIR}/sys"
+.endif
+.if !exists(${SRCDIR}/usr.bin/ktrace/subr.c)
+IGNORE= "requires ktrace source present in ${SRCDIR}/usr.bin/ktrace"
+.endif
+
+.include <bsd.port.post.mk>