aboutsummaryrefslogtreecommitdiff
path: root/devel/linuxthreads/Makefile
diff options
context:
space:
mode:
authorJason Evans <jasone@FreeBSD.org>2000-11-06 19:43:33 +0000
committerJason Evans <jasone@FreeBSD.org>2000-11-06 19:43:33 +0000
commit06bce9d9d7476f71f6017c14ac2bc6b0c6d8ec4a (patch)
treec16384e6ebcd6e96a6ee0cfd0bea6bab2dc4464c /devel/linuxthreads/Makefile
parent65c8663f357b3526eadd5d1c9528ff0ecb048274 (diff)
Notes
Diffstat (limited to 'devel/linuxthreads/Makefile')
-rw-r--r--devel/linuxthreads/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/linuxthreads/Makefile b/devel/linuxthreads/Makefile
index e2f0d6bbe351..b45044c658bd 100644
--- a/devel/linuxthreads/Makefile
+++ b/devel/linuxthreads/Makefile
@@ -7,10 +7,11 @@
PORTNAME= linuxthreads
PORTVERSION= 2.1.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= glibc
-DISTFILES= glibc-linuxthreads-${PORTVERSION}.tar.gz
+DISTNAME= glibc-linuxthreads-${PORTVERSION}
MAINTAINER= jasone@freebsd.org
@@ -27,12 +28,13 @@ threads_files := README.FreeBSD clone.S clone.h freebsd-compat.h getgr_r.c \
gethostby_r.c getnetby_r.c getprotoby_r.c getpw_r.c getservby_r.c \
lclone.c libc_calls.c libc_thread.c sched.c uthread_file.c
+WRKSRC= ${WRKDIR}/${PKGNAME}
SRC_BASE= /usr/src
LIBSRC_BASE= ${SRC_BASE}/lib
post-extract:
- @mv ${WRKDIR}/linuxthreads ${WRKDIR}/${PKGNAME}
- @mv ${WRKDIR}/linuxthreads_db ${WRKDIR}/${PKGNAME}
+ @mv ${WRKDIR}/linuxthreads ${WRKSRC}
+ @mv ${WRKDIR}/linuxthreads_db ${WRKSRC}
.for src in lockfile.c no-tsd.c oldsemaphore.c weaks.c \
sysdeps/pthread/semaphore.h
@mv ${WRKSRC}/$(src) ${WRKSRC}/$(src).unused