aboutsummaryrefslogtreecommitdiff
path: root/devel/linuxthreads
diff options
context:
space:
mode:
authorTor Egge <tegge@FreeBSD.org>2002-03-10 01:24:23 +0000
committerTor Egge <tegge@FreeBSD.org>2002-03-10 01:24:23 +0000
commit1f3d93cdba0153be51d4b52d63688f8c870e72af (patch)
tree5669af4a9a67ff689cf5a65bda5041d99d75feeb /devel/linuxthreads
parent0bfaa61d953efb77704649dda865771bec05f759 (diff)
downloadports-1f3d93cdba0153be51d4b52d63688f8c870e72af.tar.gz
ports-1f3d93cdba0153be51d4b52d63688f8c870e72af.zip
Notes
Diffstat (limited to 'devel/linuxthreads')
-rw-r--r--devel/linuxthreads/Makefile12
-rw-r--r--devel/linuxthreads/files/clone.S4
-rw-r--r--devel/linuxthreads/pkg-descr3
3 files changed, 17 insertions, 2 deletions
diff --git a/devel/linuxthreads/Makefile b/devel/linuxthreads/Makefile
index 9c341c54d04b..2f7afeaf5b0d 100644
--- a/devel/linuxthreads/Makefile
+++ b/devel/linuxthreads/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linuxthreads
PORTVERSION= 2.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= glibc
@@ -33,13 +33,21 @@ WRKSRC= ${WRKDIR}/${PKGNAME}
SRC_BASE= /usr/src
LIBSRC_BASE= ${SRC_BASE}/lib
-.if !defined(WITH_CONDWAIT_PATCH)
pre-fetch:
+.if !defined(WITH_CONDWAIT_PATCH)
@${ECHO}
@${ECHO} You can use an experimental patch to reduce the number of
@${ECHO} condition variable triggered context switches by defining
@${ECHO} WITH_CONDWAIT_PATCH
+ @${ECHO}
.endif
+ @if test -f /usr/src/gnu/lib/libgcc/Makefile; then \
+ : ; \
+ else \
+ ${ECHO_MSG} ">>The linuxthreads port needs source code for libgcc"; \
+ ${ECHO_MSG} ">>Please install FreeBSD source code in /usr/src"; \
+ false; \
+ fi
post-extract:
@mv ${WRKDIR}/linuxthreads ${WRKSRC}
diff --git a/devel/linuxthreads/files/clone.S b/devel/linuxthreads/files/clone.S
index 73d8d46467d9..0f1a9656e20c 100644
--- a/devel/linuxthreads/files/clone.S
+++ b/devel/linuxthreads/files/clone.S
@@ -1,6 +1,10 @@
.file "clone.S"
#include <sys/syscall.h>
+#ifdef __FreeBSD__ >= 5
+#include <machine/asm.h>
+#else
#include "DEFS.h"
+#endif
#include "SYS.h"
#define KERNEL
#define _KERNEL
diff --git a/devel/linuxthreads/pkg-descr b/devel/linuxthreads/pkg-descr
index f8f4b7d45bc9..889fdda33eae 100644
--- a/devel/linuxthreads/pkg-descr
+++ b/devel/linuxthreads/pkg-descr
@@ -9,3 +9,6 @@ LinuxThreads implementation see:
Note that LinuxThreads has been integrated with the GNU C library (glibc) since
version 2.0, so the above URL points to dated information.
+
+The FreeBSD source code should be installed in /usr/src before building
+linuxthreads.