aboutsummaryrefslogtreecommitdiff
path: root/devel/linuxthreads
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2008-04-25 10:11:07 +0000
committerMark Linimon <linimon@FreeBSD.org>2008-04-25 10:11:07 +0000
commitce6abbb25a1dfc7cdd5059e67c65f6fe4c704974 (patch)
treec5922bb20c41b7a939501558829e51f4ebf257d8 /devel/linuxthreads
parentc7a13d2dbfd4992265dbd8c110d50230640d62ab (diff)
downloadports-ce6abbb25a1dfc7cdd5059e67c65f6fe4c704974.tar.gz
ports-ce6abbb25a1dfc7cdd5059e67c65f6fe4c704974.zip
Notes
Diffstat (limited to 'devel/linuxthreads')
-rw-r--r--devel/linuxthreads/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/linuxthreads/Makefile b/devel/linuxthreads/Makefile
index 01536d536d71..e1b7a2397996 100644
--- a/devel/linuxthreads/Makefile
+++ b/devel/linuxthreads/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= glibc
DISTNAME= glibc-linuxthreads-${PORTVERSION}
-MAINTAINER= tegge@freebsd.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= POSIX pthreads implementation using rfork to generate kernel threads
.if defined(LINUXTHREADS_WRAP_API)
@@ -198,7 +198,7 @@ post-patch:
fi
.endif
.if defined(LINUXTHREADS_WRAP_API)
- perl -pi -e '$$func=$$1 if m/^extern\s+\S+\s+\*?(\S+)\s+\(/; $$alias="#ifdef COMPILING_WRAPUTHREAD\n\t__attribute__((weak, alias(\"_$$func\")))\n#endif\n"; $$wrap="#ifndef COMPILING_LINUXTHREADS\n\t__asm__(\"linuxthreads_$$func\")\n#endif\n"; $$alias="" if ( $$func =~ m/^(pthread_spin|_pthread_cleanup|pthread_rwlockattr_[gs]etkind_np|pthread_kill_other_threads_np)/ ); s=__THROW=\n$$wrap$$alias\t__THROW= unless m/^#/;' ${WRKSRC}/sysdeps/pthread/pthread.h ${WRKSRC}/sysdeps/unix/sysv/linux/bits/sigthread.h
+ {PERL} -pi -e '$$func=$$1 if m/^extern\s+\S+\s+\*?(\S+)\s+\(/; $$alias="#ifdef COMPILING_WRAPUTHREAD\n\t__attribute__((weak, alias(\"_$$func\")))\n#endif\n"; $$wrap="#ifndef COMPILING_LINUXTHREADS\n\t__asm__(\"linuxthreads_$$func\")\n#endif\n"; $$alias="" if ( $$func =~ m/^(pthread_spin|_pthread_cleanup|pthread_rwlockattr_[gs]etkind_np|pthread_kill_other_threads_np)/ ); s=__THROW=\n$$wrap$$alias\t__THROW= unless m/^#/;' ${WRKSRC}/sysdeps/pthread/pthread.h ${WRKSRC}/sysdeps/unix/sysv/linux/bits/sigthread.h
.endif
.endif