aboutsummaryrefslogtreecommitdiff
path: root/devel/linxt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-05 13:37:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-05 13:37:58 +0000
commit7064722c152d1207893ef4efcbb24344af16c05e (patch)
tree864b6a24aabaf05b5dfc260ff16fc9af5dadc464 /devel/linxt
parentcaaea3b9f218508d46b2e90dd3ba68af61a4961c (diff)
downloadports-7064722c152d1207893ef4efcbb24344af16c05e.tar.gz
ports-7064722c152d1207893ef4efcbb24344af16c05e.zip
Notes
Diffstat (limited to 'devel/linxt')
-rw-r--r--devel/linxt/Makefile29
-rw-r--r--devel/linxt/distinfo3
-rw-r--r--devel/linxt/pkg-descr6
-rw-r--r--devel/linxt/pkg-message5
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/linxt/Makefile b/devel/linxt/Makefile
new file mode 100644
index 000000000000..1fe45bd3d366
--- /dev/null
+++ b/devel/linxt/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: linxt
+# Date created: 2007-05-05
+# Whom: Jason Bacon <bacon@smithers.neuro.mcw.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linxt
+PORTVERSION= 0.1
+CATEGORIES= devel comms
+MASTER_SITES= SF \
+ http://personalpages.tds.net/~jwbacon/Ports/distfiles/
+
+MAINTAINER= bacon@smithers.neuro.mcw.edu
+COMMENT= Perl script for controlling Lego NXT brick
+
+RUN_DEPENDS= ${SITE_PERL}/mach/Device/USB.pm:${PORTSDIR}/devel/p5-usb
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/linxt ${PREFIX}/bin
+ @${ECHO_CMD}
+ @${CAT} pkg-message
+ @${ECHO_CMD}
+
+PLIST_FILES= bin/linxt
+
+.include <bsd.port.mk>
diff --git a/devel/linxt/distinfo b/devel/linxt/distinfo
new file mode 100644
index 000000000000..0b76bd460bab
--- /dev/null
+++ b/devel/linxt/distinfo
@@ -0,0 +1,3 @@
+MD5 (linxt-0.1.tar.gz) = 8c3567f1f385a91036c91fb23cd11114
+SHA256 (linxt-0.1.tar.gz) = 81a0e4db4f0dad65fb51ff36be8ee3933fd7af034eadca0b995f01a828182655
+SIZE (linxt-0.1.tar.gz) = 3225
diff --git a/devel/linxt/pkg-descr b/devel/linxt/pkg-descr
new file mode 100644
index 000000000000..60dfb680a759
--- /dev/null
+++ b/devel/linxt/pkg-descr
@@ -0,0 +1,6 @@
+The linxt Perl script is a Unix command line tool for communicating
+with the Lego Mindstorms Robotics NXT brick. It can be used to
+query the brick for information like firmware version, battery
+level, etc. and also to upload robotics programs compiled with
+NBC/NXC.
+
diff --git a/devel/linxt/pkg-message b/devel/linxt/pkg-message
new file mode 100644
index 000000000000..57404054ae3b
--- /dev/null
+++ b/devel/linxt/pkg-message
@@ -0,0 +1,5 @@
+Users of linxt must have write permissions on the USB devices associated
+with the NXT brick (e.g. dev/usb0* and dev/ugen0*). Using chmod will
+only affect these devices until they are detached. See etc/devfs.rules
+and etc/usbd.conf (also "man devfs.rules" and "man usbd.conf") for
+controlling USB device permissions when they are attached.