aboutsummaryrefslogtreecommitdiff
path: root/devel/llnextgen
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-01-17 17:33:56 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-01-17 17:33:56 +0000
commitc8c88c889a6da91c9a59bee9b96e43a17b72a1a5 (patch)
tree0358001693c40f7b95be5c124f61bba27054ff3c /devel/llnextgen
parent5ab98479cdaa691ca954df81eda9df9abe22156e (diff)
Notes
Diffstat (limited to 'devel/llnextgen')
-rw-r--r--devel/llnextgen/Makefile30
-rw-r--r--devel/llnextgen/distinfo2
-rw-r--r--devel/llnextgen/pkg-descr11
-rw-r--r--devel/llnextgen/pkg-plist11
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/llnextgen/Makefile b/devel/llnextgen/Makefile
new file mode 100644
index 000000000000..7d2bb7dd2a1a
--- /dev/null
+++ b/devel/llnextgen/Makefile
@@ -0,0 +1,30 @@
+# Created by: Oleksii Tsai <oleksii.tsai@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= LLnextgen
+PORTVERSION= 0.5.5
+CATEGORIES= devel
+MASTER_SITES= http://os.ghalkes.nl/LLnextgen/releases/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= oleksii.tsai@googlemail.com
+COMMENT= Extended LL(1) parser generator
+
+LICENSE= GPLv3
+
+HAS_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/LLnextgen ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/doc/LLnextgen.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in README COPYING TODO Changelog doc/LLnextgen.pdf \
+ doc/LLnextgen.ps.gz doc/calculator.g doc/threadsafe.g
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/llnextgen/distinfo b/devel/llnextgen/distinfo
new file mode 100644
index 000000000000..c6b57eda47c5
--- /dev/null
+++ b/devel/llnextgen/distinfo
@@ -0,0 +1,2 @@
+SHA256 (LLnextgen-0.5.5.tgz) = 665f72db855eb104000a38b884bb96075a6ba542e4b863508374a4928f52c83a
+SIZE (LLnextgen-0.5.5.tgz) = 363140
diff --git a/devel/llnextgen/pkg-descr b/devel/llnextgen/pkg-descr
new file mode 100644
index 000000000000..444c21914021
--- /dev/null
+++ b/devel/llnextgen/pkg-descr
@@ -0,0 +1,11 @@
+LLnextgen is an Extended-LL(1) parser generator. It is a rewrite of the LLgen
+parser generator by D. Grune and C.J.H. Jacobs which is part of the Amsterdam
+Compiler Kit (ACK). Like all parser generators, LLnextgen takes the description
+of the grammar with associated actions as input, and generates a parser routine
+for use in compilers and other text processing programs.
+
+LLgen, and therefore LLnextgen, extends on the LL(1) class of parser generators
+by allowing FIRST/FIRST conflicts and FIRST/FOLLOW conflicts to be resolved with
+both static and dynamic conditions.
+
+WWW: http://os.ghalkes.nl/LLnextgen/index.html
diff --git a/devel/llnextgen/pkg-plist b/devel/llnextgen/pkg-plist
new file mode 100644
index 000000000000..25a8e9dfa47a
--- /dev/null
+++ b/devel/llnextgen/pkg-plist
@@ -0,0 +1,11 @@
+bin/LLnextgen
+man/man1/LLnextgen.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/LLnextgen.pdf
+%%PORTDOCS%%%%DOCSDIR%%/LLnextgen.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/calculator.g
+%%PORTDOCS%%%%DOCSDIR%%/threadsafe.g
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%