aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2011-02-24 21:54:36 +0000
committerBrooks Davis <brooks@FreeBSD.org>2011-02-24 21:54:36 +0000
commitd843069c0ee502f64b5d0d5b0a112ce637801441 (patch)
tree574aee4482e23407afd42afa5617c9f1c847cf76 /devel/llvm-devel
parentca858ffb67dbe767e6839a4eb980e9a2796e23eb (diff)
downloadports-d843069c0ee502f64b5d0d5b0a112ce637801441.tar.gz
ports-d843069c0ee502f64b5d0d5b0a112ce637801441.zip
Notes
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile10
-rw-r--r--devel/llvm-devel/Makefile.svn_rev2
-rw-r--r--devel/llvm-devel/distinfo4
-rw-r--r--devel/llvm-devel/pkg-plist29
4 files changed, 30 insertions, 15 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 56ac12900efa..9c9138f8d5e3 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -7,7 +7,6 @@
PORTNAME= llvm
DISTVERSION= 2.9.r${SVN_REV}
-PORTREVISION= 2
CATEGORIES= devel lang
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -60,12 +59,14 @@ MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 \
.include <bsd.port.pre.mk>
+.if !defined(SVN_REV)
.if defined(BOOTSTRAP)
LANG= "C"
SVN_REV!= svn info http://llvm.org/svn/llvm-project/ | ${GREP} Revision | cut -d' ' -f2
.else
.include "Makefile.svn_rev"
.endif
+.endif
.if ${ARCH} == "sparc64"
BROKEN= does not compile on sparc64
@@ -130,17 +131,18 @@ PLIST_FILE_LIST= bin/bugpoint \
bin/llc \
bin/lli \
bin/llvm* \
- bin/macho-dumpx \
+ bin/macho-dump \
bin/opt \
bin/tblgen \
- lib/libBugpointPasses.so \
+ lib/LLVMHello.so \
+ lib/BugpointPasses.so \
lib/libCompilerDriver.a \
lib/libEnhancedDisassembly.so \
lib/libEnhancedDisassembly.a \
lib/libLTO.* \
lib/libLLVM* \
lib/libUnitTestMain.a \
- lib/libprofile_rt.so
+ lib/profile_rt.so
PLIST_DIR_LIST= include/llvm-c \
include/llvm
build-plist:
diff --git a/devel/llvm-devel/Makefile.svn_rev b/devel/llvm-devel/Makefile.svn_rev
index de67b4ef6235..4949c1073c69 100644
--- a/devel/llvm-devel/Makefile.svn_rev
+++ b/devel/llvm-devel/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 121368
+SVN_REV= 126079
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 9ada8c0095e9..392acd113c15 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (llvm-2.9.r121368.tar.bz2) = 23fe92c65926cd55c6cb51fc5f2376a325bedf726d4fc1fe50e79a6ec12e74f9
-SIZE (llvm-2.9.r121368.tar.bz2) = 7268189
+SHA256 (llvm-2.9.r126079.tar.bz2) = 1aaaa9617a21a6ec1cb4b35fd0a019567331a03e470b44112dac909b55a482f1
+SIZE (llvm-2.9.r126079.tar.bz2) = 7531942
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index 396059dd4440..b10c01ade7c9 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -12,11 +12,12 @@ bin/llvm-ld
bin/llvm-link
bin/llvm-mc
bin/llvm-nm
+bin/llvm-objdump
bin/llvm-prof
bin/llvm-ranlib
bin/llvm-stub
bin/llvmc
-bin/macho-dumpx
+bin/macho-dump
bin/opt
bin/tblgen
include/llvm-c/Analysis.h
@@ -34,6 +35,7 @@ include/llvm-c/lto.h
include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
+include/llvm/ADT/ArrayRef.h
include/llvm/ADT/BitVector.h
include/llvm/ADT/DAGDeltaAlgorithm.h
include/llvm/ADT/DeltaAlgorithm.h
@@ -50,6 +52,7 @@ include/llvm/ADT/ImmutableMap.h
include/llvm/ADT/ImmutableSet.h
include/llvm/ADT/InMemoryStruct.h
include/llvm/ADT/IndexedMap.h
+include/llvm/ADT/IntEqClasses.h
include/llvm/ADT/IntervalMap.h
include/llvm/ADT/IntrusiveRefCntPtr.h
include/llvm/ADT/NullablePtr.h
@@ -97,6 +100,7 @@ include/llvm/Analysis/DIBuilder.h
include/llvm/Analysis/DOTGraphTraitsPass.h
include/llvm/Analysis/DebugInfo.h
include/llvm/Analysis/DomPrinter.h
+include/llvm/Analysis/DominanceFrontier.h
include/llvm/Analysis/DominatorInternals.h
include/llvm/Analysis/Dominators.h
include/llvm/Analysis/FindUsedTypes.h
@@ -119,6 +123,8 @@ include/llvm/Analysis/MemoryBuiltins.h
include/llvm/Analysis/MemoryDependenceAnalysis.h
include/llvm/Analysis/PHITransAddr.h
include/llvm/Analysis/Passes.h
+include/llvm/Analysis/PathNumbering.h
+include/llvm/Analysis/PathProfileInfo.h
include/llvm/Analysis/PostDominators.h
include/llvm/Analysis/ProfileInfo.h
include/llvm/Analysis/ProfileInfoLoader.h
@@ -157,6 +163,7 @@ include/llvm/CodeGen/AsmPrinter.h
include/llvm/CodeGen/BinaryObject.h
include/llvm/CodeGen/CalcSpillWeights.h
include/llvm/CodeGen/CallingConvLower.h
+include/llvm/CodeGen/EdgeBundles.h
include/llvm/CodeGen/FastISel.h
include/llvm/CodeGen/FunctionLoweringInfo.h
include/llvm/CodeGen/GCMetadata.h
@@ -188,6 +195,7 @@ include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLocation.h
include/llvm/CodeGen/MachineLoopInfo.h
+include/llvm/CodeGen/MachineLoopRanges.h
include/llvm/CodeGen/MachineMemOperand.h
include/llvm/CodeGen/MachineModuleInfo.h
include/llvm/CodeGen/MachineModuleInfoImpls.h
@@ -285,14 +293,16 @@ include/llvm/MC/MCContext.h
include/llvm/MC/MCDirectives.h
include/llvm/MC/MCDisassembler.h
include/llvm/MC/MCDwarf.h
+include/llvm/MC/MCELFObjectWriter.h
include/llvm/MC/MCELFSymbolFlags.h
include/llvm/MC/MCExpr.h
include/llvm/MC/MCFixup.h
+include/llvm/MC/MCFixupKindInfo.h
include/llvm/MC/MCInst.h
include/llvm/MC/MCInstPrinter.h
include/llvm/MC/MCLabel.h
include/llvm/MC/MCMachOSymbolFlags.h
-include/llvm/MC/MCObjectFormat.h
+include/llvm/MC/MCMachObjectWriter.h
include/llvm/MC/MCObjectStreamer.h
include/llvm/MC/MCObjectWriter.h
include/llvm/MC/MCParser/AsmCond.h
@@ -375,6 +385,7 @@ include/llvm/Support/NoFolder.h
include/llvm/Support/OutputBuffer.h
include/llvm/Support/PassNameParser.h
include/llvm/Support/Path.h
+include/llvm/Support/PathV1.h
include/llvm/Support/PathV2.h
include/llvm/Support/PatternMatch.h
include/llvm/Support/PluginLoader.h
@@ -393,7 +404,6 @@ include/llvm/Support/SMLoc.h
include/llvm/Support/Signals.h
include/llvm/Support/Solaris.h
include/llvm/Support/SourceMgr.h
-include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/StandardPasses.h
include/llvm/Support/StringPool.h
include/llvm/Support/SwapByteOrder.h
@@ -417,18 +427,20 @@ include/llvm/Target/Mangler.h
include/llvm/Target/SubtargetFeature.h
include/llvm/Target/Target.td
include/llvm/Target/TargetAsmBackend.h
+include/llvm/Target/TargetAsmInfo.h
include/llvm/Target/TargetAsmLexer.h
include/llvm/Target/TargetAsmParser.h
include/llvm/Target/TargetCallingConv.h
include/llvm/Target/TargetCallingConv.td
include/llvm/Target/TargetData.h
include/llvm/Target/TargetELFWriterInfo.h
-include/llvm/Target/TargetFrameInfo.h
+include/llvm/Target/TargetFrameLowering.h
include/llvm/Target/TargetInstrDesc.h
include/llvm/Target/TargetInstrInfo.h
include/llvm/Target/TargetInstrItineraries.h
include/llvm/Target/TargetIntrinsicInfo.h
include/llvm/Target/TargetJITInfo.h
+include/llvm/Target/TargetLibraryInfo.h
include/llvm/Target/TargetLowering.h
include/llvm/Target/TargetLoweringObjectFile.h
include/llvm/Target/TargetMachine.h
@@ -444,7 +456,6 @@ include/llvm/Target/TargetSubtarget.h
include/llvm/Transforms/IPO.h
include/llvm/Transforms/IPO/InlinerPass.h
include/llvm/Transforms/Instrumentation.h
-include/llvm/Transforms/RSProfiling.h
include/llvm/Transforms/Scalar.h
include/llvm/Transforms/Utils/AddrModeMatcher.h
include/llvm/Transforms/Utils/BasicBlockUtils.h
@@ -465,7 +476,8 @@ include/llvm/Use.h
include/llvm/User.h
include/llvm/Value.h
include/llvm/ValueSymbolTable.h
-lib/libBugpointPasses.so
+lib/BugpointPasses.so
+lib/LLVMHello.so
lib/libCompilerDriver.a
lib/libEnhancedDisassembly.a
lib/libEnhancedDisassembly.so
@@ -493,7 +505,6 @@ lib/libLLVMCore.a
lib/libLLVMCppBackend.a
lib/libLLVMCppBackendInfo.a
lib/libLLVMExecutionEngine.a
-lib/libLLVMHello.so
lib/libLLVMInstCombine.a
lib/libLLVMInstrumentation.a
lib/libLLVMInterpreter.a
@@ -533,6 +544,7 @@ lib/libLLVMX86AsmPrinter.a
lib/libLLVMX86CodeGen.a
lib/libLLVMX86Disassembler.a
lib/libLLVMX86Info.a
+lib/libLLVMX86Utils.a
lib/libLLVMXCoreCodeGen.a
lib/libLLVMXCoreInfo.a
lib/libLLVMipa.a
@@ -540,7 +552,7 @@ lib/libLLVMipo.a
lib/libLTO.a
lib/libLTO.so
lib/libUnitTestMain.a
-lib/libprofile_rt.so
+lib/profile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
%%PORTDOCS%%%%DOCSDIR%%/html/AliasAnalysis.html
%%PORTDOCS%%%%DOCSDIR%%/html/BitCodeFormat.html
@@ -629,6 +641,7 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl5.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl6.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl8.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/index.html
%%PORTDOCS%%%%DOCSDIR%%/ps/FileCheck.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/bugpoint.ps