aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-12-08 16:08:09 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-12-08 16:08:09 +0000
commitdd94d2885302a57565d502b3cac0e8f7e6736fd5 (patch)
tree13db8e8264f7d499a7a2877e54f1cdfe06b2a1f6 /devel/llvm-devel
parentc90ced8bc9e6fd5be43c2e110f3b135d1e0209f6 (diff)
downloadports-dd94d2885302a57565d502b3cac0e8f7e6736fd5.tar.gz
ports-dd94d2885302a57565d502b3cac0e8f7e6736fd5.zip
Notes
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile26
-rw-r--r--devel/llvm-devel/Makefile.svn_rev2
-rw-r--r--devel/llvm-devel/distinfo6
-rw-r--r--devel/llvm-devel/files/patch-tools_clang_tools_scan-build_scan-build (renamed from devel/llvm-devel/files/patch-tools_clang_utils_scan-build)8
-rw-r--r--devel/llvm-devel/pkg-plist50
5 files changed, 62 insertions, 30 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 2da612de2d42..95a9a1782f7d 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -41,6 +41,8 @@ CONFIGURE_ARGS+= --enable-optimized
CONFIGURE_ARGS+= --enable-bindings=none
+OPTIONS= NO_ASSERTS "Disable assertions (needed by graphics/opengtl) " off
+
MAN1= bugpoint.1 clang.1 lit.1 llc.1 lli.1 llvmc.1 llvm-ar.1 \
llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-db.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
@@ -61,6 +63,16 @@ BROKEN= does not compile
BROKEN= Does not compile on sparc64
.endif
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CONFIGURE_ARGS+= --enable-pic --with-pic
+.endif
+
+.ifdef(WITH_NO_ASSERTS)
+CONFIGURE_ARGS+= --disable-assertions
+.else
+CONFIGURE_ARGS+= --enable-assertions
+.endif
+
.if defined(BOOTSTRAP)
FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
@@ -84,19 +96,19 @@ post-patch:
${REINPLACE_CMD} -e 's,\(PROJ_mandir.*:=\).*$$,\1${MANPREFIX}/man,g' \
${WRKSRC}/Makefile.config.in
${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' \
- ${WRKSRC}/tools/clang/utils/scan-build
+ ${WRKSRC}/tools/clang/tools/scan-build/scan-build
${REINPLACE_CMD} -e 's|/usr/bin/env perl|${PERL}|' \
- ${WRKSRC}/tools/clang/utils/ccc-analyzer \
- ${WRKSRC}/tools/clang/utils/scan-build
+ ${WRKSRC}/tools/clang/tools/scan-build/ccc-analyzer \
+ ${WRKSRC}/tools/clang/tools/scan-build/scan-build
post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/utils/ccc-analyzer \
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/tools/scan-build/ccc-analyzer \
${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/utils/scan-build \
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/tools/scan-build/scan-build \
${PREFIX}/bin
@${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/tools/clang/utils/scanview.css ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/tools/clang/utils/sorttable.js ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/tools/clang/tools/scan-build/scanview.css ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/tools/clang/tools/scan-build/sorttable.js ${DATADIR}
TEST_CMD= '(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check)'
regression-test: ${BUILD_COOKIE}
diff --git a/devel/llvm-devel/Makefile.svn_rev b/devel/llvm-devel/Makefile.svn_rev
index 28f7915b7ce0..0300a9fb7e60 100644
--- a/devel/llvm-devel/Makefile.svn_rev
+++ b/devel/llvm-devel/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 86028
+SVN_REV= 90769
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index fc3eead7a9d4..8f998ad086c3 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-2.7.r86028.tar.bz2) = 2926fa1ddb908045219923abdedb8eb3
-SHA256 (llvm-2.7.r86028.tar.bz2) = 7091955b76096d44ec1a7c8dae794945ac27247503e996580283f9c753c968b7
-SIZE (llvm-2.7.r86028.tar.bz2) = 9756836
+MD5 (llvm-2.7.r90769.tar.bz2) = 0eb390f882e620f60b5523bd0c889239
+SHA256 (llvm-2.7.r90769.tar.bz2) = e0e3894e60f5df84df275132998349abcc79bce197b397fea3973e2c00266caf
+SIZE (llvm-2.7.r90769.tar.bz2) = 9934592
diff --git a/devel/llvm-devel/files/patch-tools_clang_utils_scan-build b/devel/llvm-devel/files/patch-tools_clang_tools_scan-build_scan-build
index 487b3bcc90fa..291eafdeb2fc 100644
--- a/devel/llvm-devel/files/patch-tools_clang_utils_scan-build
+++ b/devel/llvm-devel/files/patch-tools_clang_tools_scan-build_scan-build
@@ -1,9 +1,9 @@
$FreeBSD$
---- tools/clang/utils/scan-build.orig
-+++ tools/clang/utils/scan-build
-@@ -406,7 +406,7 @@
+--- tools/clang/tools/scan-build/scan-build.orig
++++ tools/clang/tools/scan-build/scan-build
+@@ -423,7 +423,7 @@
my $Dir = shift;
@@ -12,7 +12,7 @@ $FreeBSD$
DieDiag("Cannot find 'sorttable.js'.\n")
if (! -r $JS);
-@@ -410,7 +410,7 @@
+@@ -433,7 +433,7 @@
DieDiag("Could not copy 'sorttable.js' to '$Dir'.\n")
if (! -r "$Dir/sorttable.js");
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index bf9e053bcb2a..8e2fde3fa10b 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -1,6 +1,7 @@
bin/bugpoint
bin/ccc-analyzer
bin/clang
+bin/clang++
bin/llc
bin/lli
bin/llvm-ar
@@ -68,10 +69,10 @@ include/clang/Analysis/Analyses/LiveVariables.h
include/clang/Analysis/Analyses/UninitializedValues.h
include/clang/Analysis/AnalysisDiagnostic.h
include/clang/Analysis/CFG.h
-include/clang/Analysis/CallGraph.h
include/clang/Analysis/FlowSensitive/DataflowSolver.h
include/clang/Analysis/FlowSensitive/DataflowValues.h
include/clang/Analysis/LocalCheckers.h
+include/clang/Analysis/ManagerRegistry.h
include/clang/Analysis/PathDiagnostic.h
include/clang/Analysis/PathSensitive/AnalysisContext.h
include/clang/Analysis/PathSensitive/AnalysisManager.h
@@ -81,13 +82,7 @@ include/clang/Analysis/PathSensitive/BugType.h
include/clang/Analysis/PathSensitive/Checker.h
include/clang/Analysis/PathSensitive/CheckerVisitor.def
include/clang/Analysis/PathSensitive/CheckerVisitor.h
-include/clang/Analysis/PathSensitive/Checkers/AttrNonNullChecker.h
-include/clang/Analysis/PathSensitive/Checkers/BadCallChecker.h
include/clang/Analysis/PathSensitive/Checkers/DereferenceChecker.h
-include/clang/Analysis/PathSensitive/Checkers/DivZeroChecker.h
-include/clang/Analysis/PathSensitive/Checkers/UndefinedArgChecker.h
-include/clang/Analysis/PathSensitive/Checkers/UndefinedAssignmentChecker.h
-include/clang/Analysis/PathSensitive/Checkers/VLASizeChecker.h
include/clang/Analysis/PathSensitive/ConstraintManager.h
include/clang/Analysis/PathSensitive/Environment.h
include/clang/Analysis/PathSensitive/ExplodedGraph.h
@@ -116,7 +111,6 @@ include/clang/Analysis/Support/SaveAndRestore.h
include/clang/Analysis/Visitors/CFGRecStmtDeclVisitor.h
include/clang/Analysis/Visitors/CFGRecStmtVisitor.h
include/clang/Analysis/Visitors/CFGStmtVisitor.h
-include/clang/Analysis/Visitors/CFGVarDeclVisitor.h
include/clang/Basic/Builtins.def
include/clang/Basic/Builtins.h
include/clang/Basic/BuiltinsPPC.def
@@ -154,24 +148,32 @@ include/clang/Basic/SourceManager.h
include/clang/Basic/SourceManagerInternals.h
include/clang/Basic/TargetBuiltins.h
include/clang/Basic/TargetInfo.h
+include/clang/Basic/TargetOptions.h
include/clang/Basic/TemplateKinds.h
include/clang/Basic/TokenKinds.def
include/clang/Basic/TokenKinds.h
include/clang/Basic/TypeTraits.h
include/clang/Basic/Version.h
+include/clang/CodeGen/CodeGenOptions.h
include/clang/CodeGen/ModuleBuilder.h
include/clang/Driver/Action.h
include/clang/Driver/Arg.h
include/clang/Driver/ArgList.h
+include/clang/Driver/CC1Options.h
+include/clang/Driver/CC1Options.inc
include/clang/Driver/Compilation.h
include/clang/Driver/Driver.h
include/clang/Driver/DriverDiagnostic.h
include/clang/Driver/HostInfo.h
include/clang/Driver/Job.h
+include/clang/Driver/OptSpecifier.h
+include/clang/Driver/OptTable.h
include/clang/Driver/Option.h
-include/clang/Driver/Options.def
include/clang/Driver/Options.h
+include/clang/Driver/Options.inc
include/clang/Driver/Phases.h
+include/clang/Driver/Release/CC1Options.inc.tmp
+include/clang/Driver/Release/Options.inc.tmp
include/clang/Driver/Tool.h
include/clang/Driver/ToolChain.h
include/clang/Driver/Types.def
@@ -181,29 +183,40 @@ include/clang/Frontend/ASTConsumers.h
include/clang/Frontend/ASTUnit.h
include/clang/Frontend/Analyses.def
include/clang/Frontend/AnalysisConsumer.h
+include/clang/Frontend/ChainedDiagnosticClient.h
include/clang/Frontend/CommandLineSourceLoc.h
-include/clang/Frontend/CompileOptions.h
+include/clang/Frontend/CompilerInstance.h
+include/clang/Frontend/CompilerInvocation.h
include/clang/Frontend/DeclContextXML.def
include/clang/Frontend/DeclXML.def
+include/clang/Frontend/DependencyOutputOptions.h
include/clang/Frontend/DiagnosticOptions.h
include/clang/Frontend/DocumentXML.def
include/clang/Frontend/DocumentXML.h
include/clang/Frontend/FixItRewriter.h
+include/clang/Frontend/FrontendAction.h
+include/clang/Frontend/FrontendActions.h
include/clang/Frontend/FrontendDiagnostic.h
-include/clang/Frontend/InitHeaderSearch.h
-include/clang/Frontend/InitPreprocessor.h
-include/clang/Frontend/ManagerRegistry.h
+include/clang/Frontend/FrontendOptions.h
+include/clang/Frontend/FrontendPluginRegistry.h
+include/clang/Frontend/HeaderSearchOptions.h
+include/clang/Frontend/LangStandard.h
+include/clang/Frontend/LangStandards.def
include/clang/Frontend/PCHBitCodes.h
include/clang/Frontend/PCHReader.h
include/clang/Frontend/PCHWriter.h
include/clang/Frontend/PathDiagnosticClients.h
+include/clang/Frontend/PreprocessorOptions.h
+include/clang/Frontend/PreprocessorOutputOptions.h
include/clang/Frontend/StmtXML.def
include/clang/Frontend/TextDiagnosticBuffer.h
include/clang/Frontend/TextDiagnosticPrinter.h
include/clang/Frontend/TypeXML.def
include/clang/Frontend/Utils.h
+include/clang/Frontend/VerifyDiagnosticsClient.h
include/clang/Index/ASTLocation.h
include/clang/Index/Analyzer.h
+include/clang/Index/CallGraph.h
include/clang/Index/DeclReferenceMap.h
include/clang/Index/Entity.h
include/clang/Index/GlobalSelector.h
@@ -242,6 +255,7 @@ include/clang/Parse/Ownership.h
include/clang/Parse/ParseDiagnostic.h
include/clang/Parse/Parser.h
include/clang/Parse/Scope.h
+include/clang/Parse/Template.h
include/clang/Rewrite/DeltaTree.h
include/clang/Rewrite/HTMLRewrite.h
include/clang/Rewrite/RewriteRope.h
@@ -266,6 +280,7 @@ include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
include/llvm/ADT/BitVector.h
+include/llvm/ADT/DeltaAlgorithm.h
include/llvm/ADT/DenseMap.h
include/llvm/ADT/DenseMapInfo.h
include/llvm/ADT/DenseSet.h
@@ -322,9 +337,11 @@ include/llvm/Analysis/Dominators.h
include/llvm/Analysis/FindUsedTypes.h
include/llvm/Analysis/IVUsers.h
include/llvm/Analysis/InlineCost.h
+include/llvm/Analysis/InstructionSimplify.h
include/llvm/Analysis/Interval.h
include/llvm/Analysis/IntervalIterator.h
include/llvm/Analysis/IntervalPartition.h
+include/llvm/Analysis/LazyValueInfo.h
include/llvm/Analysis/LibCallAliasAnalysis.h
include/llvm/Analysis/LibCallSemantics.h
include/llvm/Analysis/LiveValues.h
@@ -333,6 +350,7 @@ include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopPass.h
include/llvm/Analysis/MemoryBuiltins.h
include/llvm/Analysis/MemoryDependenceAnalysis.h
+include/llvm/Analysis/PHITransAddr.h
include/llvm/Analysis/Passes.h
include/llvm/Analysis/PointerTracking.h
include/llvm/Analysis/PostDominators.h
@@ -411,6 +429,7 @@ include/llvm/CodeGen/MachineOperand.h
include/llvm/CodeGen/MachinePassRegistry.h
include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
+include/llvm/CodeGen/MachineSSAUpdater.h
include/llvm/CodeGen/ObjectCodeEmitter.h
include/llvm/CodeGen/Passes.h
include/llvm/CodeGen/ProcessImplicitDefs.h
@@ -440,6 +459,7 @@ include/llvm/CompilerDriver/Plugin.h
include/llvm/CompilerDriver/Tool.h
include/llvm/Config/AsmParsers.def
include/llvm/Config/AsmPrinters.def
+include/llvm/Config/Disassemblers.def
include/llvm/Config/Targets.def
include/llvm/Config/config.h
include/llvm/Config/config.h.cmake
@@ -702,6 +722,7 @@ lib/libLLVMTransformUtils.a
lib/libLLVMX86AsmParser.a
lib/libLLVMX86AsmPrinter.a
lib/libLLVMX86CodeGen.a
+lib/libLLVMX86Disassembler.a
lib/libLLVMX86Info.a
lib/libLLVMXCoreAsmPrinter.a
lib/libLLVMXCoreCodeGen.a
@@ -811,8 +832,6 @@ libexec/clang-cc
%%DOCSDIR%%/html/index.html
%%DOCSDIR%%/html/libIndex.html
%%DOCSDIR%%/html/llvm.css
-%%DOCSDIR%%/html/tutorial/JITTutorial1.html
-%%DOCSDIR%%/html/tutorial/JITTutorial2.html
%%DOCSDIR%%/html/tutorial/LangImpl1.html
%%DOCSDIR%%/html/tutorial/LangImpl2.html
%%DOCSDIR%%/html/tutorial/LangImpl3.html
@@ -879,6 +898,7 @@ libexec/clang-cc
@dirrm include/clang/Lex
@dirrm include/clang/Index
@dirrm include/clang/Frontend
+@dirrm include/clang/Driver/Release
@dirrm include/clang/Driver
@dirrm include/clang/CodeGen
@dirrm include/clang/Basic/Release