aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2013-06-12 16:20:51 +0000
committerBrooks Davis <brooks@FreeBSD.org>2013-06-12 16:20:51 +0000
commite9801a1fab261138b3aa152a7bb295260f0ac069 (patch)
treea2071803a67fda140b7651d4021d6b38fc5fdecd /devel/llvm-devel
parentfb7450560bbc3d3aea7987f55d45daccf2599e2c (diff)
Correct some WRKDIR relative paths in the cmake files so they actually
work. I've verified that libobjc2 builds with them installed. Remove the conflict with llvm-3.3 and later. Newer ports will not conflict.
Notes
Notes: svn path=/head/; revision=320704
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index ecf8f0e00f98..90a75116fd6d 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= llvm
DISTVERSION= 3.4.r${SVN_REV}
+PORTREVISION= 1
CATEGORIES= devel lang
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -20,7 +21,7 @@ BUILD_DEPENDS+= cmake:${PORTSDIR}/devel/cmake
BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
.endif
-CONFLICTS= llvm-[23]* llvm31-[3]*
+CONFLICTS= llvm-2* llvm-3.[012]* llvm31-[3]*
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -126,9 +127,12 @@ post-patch:
${REINPLACE_CMD} -e 's|\(PROJ_mandir.*:=\).*$$|\1${MANPREFIX}/man|g' \
${WRKSRC}/Makefile.config.in
-pre-configure:
+post-configure:
${MKDIR} ${WRKDIR}/cmake
cd ${WRKDIR}/cmake && cmake -G "Unix Makefiles" ${WRKSRC}
+ ${REINPLACE_CMD} -e 's|${WRKDIR}/cmake|${PREFIX}|' \
+ -e 's|${WRKSRC}|${DATADIR}|' \
+ ${WRKDIR}/cmake/share/llvm/cmake/LLVMConfig.cmake
post-build:
.if ${PORT_OPTIONS:MMANPAGES}