aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2010-06-17 17:35:57 +0000
committerBrooks Davis <brooks@FreeBSD.org>2010-06-17 17:35:57 +0000
commit15505eec889eceba15cb4809b034cf3eef144479 (patch)
tree23d5c24be4790032031b27e9eaebec58a04512e2 /devel/llvm-devel
parent4a1df865739c8ea2a5719dde8ce37e92ab1f7905 (diff)
downloadports-15505eec889eceba15cb4809b034cf3eef144479.tar.gz
ports-15505eec889eceba15cb4809b034cf3eef144479.zip
Notes
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile8
-rw-r--r--devel/llvm-devel/Makefile.svn_rev2
-rw-r--r--devel/llvm-devel/distinfo6
-rw-r--r--devel/llvm-devel/files/patch-tools_clang_include_clang_Makefile14
-rw-r--r--devel/llvm-devel/pkg-plist12
5 files changed, 17 insertions, 25 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 902f108c94ff..67a37dc9f037 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -7,7 +7,6 @@
PORTNAME= llvm
DISTVERSION= 2.8.r${SVN_REV}
-PORTREVISION= 1
CATEGORIES= devel lang
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -85,7 +84,7 @@ CONFIGURE_ARGS+= --disable-assertions
CONFIGURE_ARGS+= --enable-assertions
.endif
-.if defined(BOOTSTRAP)
+.if defined(BOOTSTRAP) || defined(SVN_FETCH)
FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
do-fetch:
@@ -141,6 +140,7 @@ PLIST_FILE_LIST= bin/bugpoint \
bin/opt \
bin/scan-build \
bin/tblgen \
+ lib/LLVMHello.so \
lib/libCompilerDriver.a \
lib/libEnhancedDisassembly.so \
lib/libEnhancedDisassembly.a \
@@ -149,7 +149,7 @@ PLIST_FILE_LIST= bin/bugpoint \
lib/libUnitTestMain.a \
lib/libclang* \
lib/libplugin_llvmc* \
- lib/libprofile_rt.so
+ lib/profile_rt.so
PLIST_DIR_LIST= include/clang \
include/clang-c \
include/llvm-c \
@@ -158,7 +158,7 @@ PLIST_DIR_LIST= include/clang \
build-plist:
${RM} -f ${PLIST}
cd ${PREFIX} && \
- (ls ${PLIST_FILE_LIST}; ${FIND} ${PLIST_DIR_LIST} -type f) | \
+ (ls ${PLIST_FILE_LIST} && ${FIND} ${PLIST_DIR_LIST} -type f) | \
${SORT} >> ${PLIST}
${FIND} ${DATADIR} ${DOCSDIR} -type f | \
${SED} -e 's|${DATADIR}|%%DATADIR%%|' \
diff --git a/devel/llvm-devel/Makefile.svn_rev b/devel/llvm-devel/Makefile.svn_rev
index fe4e52b79073..d6dae3eb1756 100644
--- a/devel/llvm-devel/Makefile.svn_rev
+++ b/devel/llvm-devel/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 103179
+SVN_REV= 104832
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 12bd3c0e5ebb..b08538e633e7 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-2.8.r103179.tar.bz2) = 4e5124a80d23b969cec0a531ad759626
-SHA256 (llvm-2.8.r103179.tar.bz2) = c45e4292756e64c5e80e6c3c88d8944a57e2c8dbbb944d026f38a1659259f7a9
-SIZE (llvm-2.8.r103179.tar.bz2) = 10960466
+MD5 (llvm-2.8.r104832.tar.bz2) = fb82e7f4710c467854d08197d181909b
+SHA256 (llvm-2.8.r104832.tar.bz2) = 9aa49a1d6d763c4cf9a0acb5095b365b05c961972e280e1a688938b6d11ae3f4
+SIZE (llvm-2.8.r104832.tar.bz2) = 11087554
diff --git a/devel/llvm-devel/files/patch-tools_clang_include_clang_Makefile b/devel/llvm-devel/files/patch-tools_clang_include_clang_Makefile
deleted file mode 100644
index dddc35b689fc..000000000000
--- a/devel/llvm-devel/files/patch-tools_clang_include_clang_Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- tools/clang/include/clang/Makefile.orig
-+++ tools/clang/include/clang/Makefile
-@@ -10,7 +10,7 @@
- cd $(PROJ_SRC_ROOT)/tools/clang/include && \
- for hdr in `find clang -type f '!' '(' -name '*~' \
- -o -name '.#*' -o -name '*.in' -o -name '*.txt' \
-- -o -name 'Makefile' -o -name '*.td' ')' -print \
-+ -o -name 'Makefile' -o -name '*.td' -o -name '*.orig' ')' -print \
- | grep -v CVS | grep -v .svn | grep -v .dir` ; do \
- instdir=$(DESTDIR)`dirname "$(PROJ_includedir)/$$hdr"` ; \
- if test \! -d "$$instdir" ; then \
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index 42c5fde85e22..ac832d8feddf 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -55,6 +55,7 @@ include/clang/AST/NestedNameSpecifier.h
include/clang/AST/ParentMap.h
include/clang/AST/PrettyPrinter.h
include/clang/AST/RecordLayout.h
+include/clang/AST/RecursiveASTVisitor.h
include/clang/AST/Redeclarable.h
include/clang/AST/Release/StmtNodes.inc.tmp
include/clang/AST/Stmt.h
@@ -177,6 +178,8 @@ include/clang/CodeGen/ModuleBuilder.h
include/clang/Driver/Action.h
include/clang/Driver/Arg.h
include/clang/Driver/ArgList.h
+include/clang/Driver/CC1AsOptions.h
+include/clang/Driver/CC1AsOptions.inc
include/clang/Driver/CC1Options.h
include/clang/Driver/CC1Options.inc
include/clang/Driver/Compilation.h
@@ -190,6 +193,7 @@ include/clang/Driver/Option.h
include/clang/Driver/Options.h
include/clang/Driver/Options.inc
include/clang/Driver/Phases.h
+include/clang/Driver/Release/CC1AsOptions.inc.tmp
include/clang/Driver/Release/CC1Options.inc.tmp
include/clang/Driver/Release/Options.inc.tmp
include/clang/Driver/Tool.h
@@ -413,7 +417,6 @@ include/llvm/CodeGen/AsmPrinter.h
include/llvm/CodeGen/BinaryObject.h
include/llvm/CodeGen/CalcSpillWeights.h
include/llvm/CodeGen/CallingConvLower.h
-include/llvm/CodeGen/ELFRelocation.h
include/llvm/CodeGen/FastISel.h
include/llvm/CodeGen/GCMetadata.h
include/llvm/CodeGen/GCMetadataPrinter.h
@@ -533,6 +536,8 @@ include/llvm/MC/MCExpr.h
include/llvm/MC/MCFixup.h
include/llvm/MC/MCInst.h
include/llvm/MC/MCInstPrinter.h
+include/llvm/MC/MCLabel.h
+include/llvm/MC/MCMachOSymbolFlags.h
include/llvm/MC/MCObjectWriter.h
include/llvm/MC/MCParser/AsmCond.h
include/llvm/MC/MCParser/AsmLexer.h
@@ -541,6 +546,7 @@ include/llvm/MC/MCParser/MCAsmLexer.h
include/llvm/MC/MCParser/MCAsmParser.h
include/llvm/MC/MCParser/MCParsedAsmOperand.h
include/llvm/MC/MCSection.h
+include/llvm/MC/MCSectionCOFF.h
include/llvm/MC/MCSectionELF.h
include/llvm/MC/MCSectionMachO.h
include/llvm/MC/MCStreamer.h
@@ -693,6 +699,7 @@ include/llvm/Use.h
include/llvm/User.h
include/llvm/Value.h
include/llvm/ValueSymbolTable.h
+lib/LLVMHello.so
lib/clang/2.0/include/emmintrin.h
lib/clang/2.0/include/mm_malloc.h
lib/clang/2.0/include/mmintrin.h
@@ -732,7 +739,6 @@ lib/libLLVMCore.a
lib/libLLVMCppBackend.a
lib/libLLVMCppBackendInfo.a
lib/libLLVMExecutionEngine.a
-lib/libLLVMHello.so
lib/libLLVMInstCombine.a
lib/libLLVMInstrumentation.a
lib/libLLVMInterpreter.a
@@ -799,7 +805,7 @@ lib/libclangRewrite.a
lib/libclangSema.a
lib/libplugin_llvmc_Base.a
lib/libplugin_llvmc_Clang.a
-lib/libprofile_rt.so
+lib/profile_rt.so
%%DATADIR%%/scanview.css
%%DATADIR%%/sorttable.js
%%DOCSDIR%%/html.tar.gz