aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm29
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2007-01-03 19:43:35 +0000
committerErwin Lansing <erwin@FreeBSD.org>2007-01-03 19:43:35 +0000
commit5e40ba1e276fd7080749e23804e9dbdbda7aea1e (patch)
treedfd7faa3435756bfe9d1e51d6eda258b5c3ce24a /devel/llvm29
parent5a821ecb4b86cb4ccacc862ba8824c54edf543b2 (diff)
downloadports-5e40ba1e276fd7080749e23804e9dbdbda7aea1e.tar.gz
ports-5e40ba1e276fd7080749e23804e9dbdbda7aea1e.zip
Notes
Diffstat (limited to 'devel/llvm29')
-rw-r--r--devel/llvm29/Makefile12
-rw-r--r--devel/llvm29/distinfo6
-rw-r--r--devel/llvm29/pkg-plist23
3 files changed, 23 insertions, 18 deletions
diff --git a/devel/llvm29/Makefile b/devel/llvm29/Makefile
index 35054e0fb36c..d647de008cb3 100644
--- a/devel/llvm29/Makefile
+++ b/devel/llvm29/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= llvm
-PORTVERSION= 1.8a
+PORTVERSION= 1.9
CATEGORIES= devel lang
-MASTER_SITES= http://llvm.org/releases/${PORTVERSION:S/a//}/
+MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
MAINTAINER= perky@FreeBSD.org
COMMENT= Low Level Virtual Machine
@@ -18,11 +18,10 @@ USE_BISON= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_GCC= 3.3+
-MAKE_ENV= ENABLE_OPTIMIZED=1 # strips binaries
-WRKSRC= ${WRKDIR}/llvm
+CONFIGURE_FLAGS+= --enable-optimized
-MAN1= analyze.1 bugpoint.1 gccas.1 gccld.1 llc.1 lli.1 llvm-ar.1 \
+MAN1= bugpoint.1 gccas.1 gccld.1 llc.1 lli.1 llvm-ar.1 \
llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-db.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
llvm-prof.1 llvm-ranlib.1 llvm2cpp.1 llvmc.1 llvmgcc.1 \
@@ -35,11 +34,8 @@ BROKEN= does not compile with perl ${PERL_VERSION}
.endif
post-patch:
- ${REINPLACE_CMD} -e 's,\(OPTIONAL_DIRS.*\)examples,\1,g' \
- ${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's,\(PROJ_docsdir.*:=\).*$$,\1${DOCSDIR},g' \
${WRKSRC}/Makefile.config.in
- ${RM} -rf ${WRKSRC}/projects/sample
post-install:
${RM} -f ${PREFIX}/bin/.dir ${PREFIX}/lib/.dir
diff --git a/devel/llvm29/distinfo b/devel/llvm29/distinfo
index f7e64839b36f..5d39a6e9fddb 100644
--- a/devel/llvm29/distinfo
+++ b/devel/llvm29/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-1.8a.tar.gz) = 1bc2c81bd25480db1e4f9749fe7312e8
-SHA256 (llvm-1.8a.tar.gz) = 58aa805cf8565156fba30dd24b233b58459485f43f58a68db510d547cce1b50e
-SIZE (llvm-1.8a.tar.gz) = 4467489
+MD5 (llvm-1.9.tar.gz) = 866ba97420f5ce978b6a6b1cb4338890
+SHA256 (llvm-1.9.tar.gz) = 17b82323151925ff5a7ad09a21781a0fa50ead4b87a339cee262271e4ededa13
+SIZE (llvm-1.9.tar.gz) = 4835549
diff --git a/devel/llvm29/pkg-plist b/devel/llvm29/pkg-plist
index 3101ed7aefbf..ccea2d99cd19 100644
--- a/devel/llvm29/pkg-plist
+++ b/devel/llvm29/pkg-plist
@@ -1,4 +1,3 @@
-bin/analyze
bin/bugpoint
bin/gccas
bin/gccld
@@ -27,9 +26,11 @@ etc/llvm/cpp
etc/llvm/cxx
etc/llvm/ll
include/llvm/ADT/BitSetVector.h
+include/llvm/ADT/CStringMap.h
include/llvm/ADT/DenseMap.h
include/llvm/ADT/DepthFirstIterator.h
include/llvm/ADT/EquivalenceClasses.h
+include/llvm/ADT/FoldingSet.h
include/llvm/ADT/GraphTraits.h
include/llvm/ADT/HashExtras.h
include/llvm/ADT/PostOrderIterator.h
@@ -37,6 +38,7 @@ include/llvm/ADT/SCCIterator.h
include/llvm/ADT/STLExtras.h
include/llvm/ADT/SetOperations.h
include/llvm/ADT/SetVector.h
+include/llvm/ADT/SmallString.h
include/llvm/ADT/SmallVector.h
include/llvm/ADT/Statistic.h
include/llvm/ADT/StringExtras.h
@@ -66,7 +68,6 @@ include/llvm/Analysis/FindUsedTypes.h
include/llvm/Analysis/Interval.h
include/llvm/Analysis/IntervalIterator.h
include/llvm/Analysis/IntervalPartition.h
-include/llvm/Analysis/LinkAllAnalyses.h
include/llvm/Analysis/LoadValueNumbering.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/Passes.h
@@ -102,9 +103,11 @@ include/llvm/CodeGen/DwarfWriter.h
include/llvm/CodeGen/ELFWriter.h
include/llvm/CodeGen/InstrScheduling.h
include/llvm/CodeGen/IntrinsicLowering.h
+include/llvm/CodeGen/LinkAllCodegenComponents.h
include/llvm/CodeGen/LiveInterval.h
include/llvm/CodeGen/LiveIntervalAnalysis.h
include/llvm/CodeGen/LiveVariables.h
+include/llvm/CodeGen/MachOWriter.h
include/llvm/CodeGen/MachineBasicBlock.h
include/llvm/CodeGen/MachineCodeEmitter.h
include/llvm/CodeGen/MachineConstantPool.h
@@ -116,15 +119,17 @@ include/llvm/CodeGen/MachineInstr.h
include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLocation.h
+include/llvm/CodeGen/MachinePassRegistry.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/Passes.h
+include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/SSARegMap.h
include/llvm/CodeGen/SchedGraphCommon.h
include/llvm/CodeGen/ScheduleDAG.h
+include/llvm/CodeGen/SchedulerRegistry.h
include/llvm/CodeGen/SelectionDAG.h
include/llvm/CodeGen/SelectionDAGISel.h
include/llvm/CodeGen/SelectionDAGNodes.h
-include/llvm/CodeGen/ValueSet.h
include/llvm/CodeGen/ValueTypes.h
include/llvm/CodeGen/ValueTypes.td
include/llvm/Config/alloca.h
@@ -156,7 +161,9 @@ include/llvm/Intrinsics.h
include/llvm/Intrinsics.td
include/llvm/IntrinsicsPowerPC.td
include/llvm/IntrinsicsX86.td
+include/llvm/LinkAllPasses.h
include/llvm/LinkAllVMCore.h
+include/llvm/LinkTimeOptimizer.h
include/llvm/Linker.h
include/llvm/Module.h
include/llvm/Module.h.orig
@@ -166,11 +173,13 @@ include/llvm/PassAnalysisSupport.h
include/llvm/PassManager.h
include/llvm/PassSupport.h
include/llvm/Support/AIXDataTypesFix.h
+include/llvm/Support/Allocator.h
include/llvm/Support/Annotation.h
include/llvm/Support/CFG.h
include/llvm/Support/CallSite.h
include/llvm/Support/Casting.h
include/llvm/Support/CommandLine.h
+include/llvm/Support/Compiler.h
include/llvm/Support/Compressor.h
include/llvm/Support/ConstantRange.h
include/llvm/Support/DOTGraphTraits.h
@@ -185,6 +194,7 @@ include/llvm/Support/GraphWriter.h
include/llvm/Support/InstIterator.h
include/llvm/Support/InstVisitor.h
include/llvm/Support/LeakDetector.h
+include/llvm/Support/ManagedStatic.h
include/llvm/Support/Mangler.h
include/llvm/Support/MathExtras.h
include/llvm/Support/MutexGuard.h
@@ -196,7 +206,6 @@ include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/SystemUtils.h
include/llvm/Support/Timer.h
include/llvm/Support/TypeInfo.h
-include/llvm/Support/Visibility.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTable.h
include/llvm/SymbolTableListTraits.h
@@ -214,6 +223,7 @@ include/llvm/System/Signals.h
include/llvm/System/TimeValue.h
include/llvm/Target/MRegisterInfo.h
include/llvm/Target/SubtargetFeature.h
+include/llvm/Target/TargetAsmInfo.h
include/llvm/Target/TargetData.h
include/llvm/Target/TargetFrameInfo.h
include/llvm/Target/TargetInstrInfo.h
@@ -226,7 +236,6 @@ include/llvm/Target/TargetOptions.h
include/llvm/Target/TargetSubtarget.h
include/llvm/Transforms/IPO.h
include/llvm/Transforms/Instrumentation.h
-include/llvm/Transforms/LinkAllPasses.h
include/llvm/Transforms/RSProfiling.h
include/llvm/Transforms/Scalar.h
include/llvm/Transforms/Utils/BasicBlockUtils.h
@@ -279,7 +288,6 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/CFEBuildInstrs.html
%%DOCSDIR%%/html/CodeGenerator.html
%%DOCSDIR%%/html/CodingStandards.html
-%%DOCSDIR%%/html/CommandGuide/analyze.html
%%DOCSDIR%%/html/CommandGuide/bugpoint.html
%%DOCSDIR%%/html/CommandGuide/gccas.html
%%DOCSDIR%%/html/CommandGuide/gccld.html
@@ -312,12 +320,14 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/ExtendingLLVM.html
%%DOCSDIR%%/html/FAQ.html
%%DOCSDIR%%/html/GarbageCollection.html
+%%DOCSDIR%%/html/GetElementPtr.html
%%DOCSDIR%%/html/GettingStarted.html
%%DOCSDIR%%/html/GettingStartedVS.html
%%DOCSDIR%%/html/HowToReleaseLLVM.html
%%DOCSDIR%%/html/HowToSubmitABug.html
%%DOCSDIR%%/html/LangRef.html
%%DOCSDIR%%/html/Lexicon.html
+%%DOCSDIR%%/html/LinkTimeOptimization.html
%%DOCSDIR%%/html/MakefileGuide.html
%%DOCSDIR%%/html/ProgrammersManual.html
%%DOCSDIR%%/html/Projects.html
@@ -338,7 +348,6 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/img/venusflytrap.jpg
%%DOCSDIR%%/html/index.html
%%DOCSDIR%%/html/llvm.css
-%%DOCSDIR%%/ps/analyze.ps
%%DOCSDIR%%/ps/bugpoint.ps
%%DOCSDIR%%/ps/gccas.ps
%%DOCSDIR%%/ps/gccld.ps