aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm29
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2011-04-29 15:04:30 +0000
committerBrooks Davis <brooks@FreeBSD.org>2011-04-29 15:04:30 +0000
commit67a685856f2e834cb9774126a29f926d92cfe827 (patch)
treef3651b6346ae785cf5848f99e712a3db9f7f9171 /devel/llvm29
parentea1558e3ac4c96c10e7b0d171d03bf82ece0e130 (diff)
downloadports-67a685856f2e834cb9774126a29f926d92cfe827.tar.gz
ports-67a685856f2e834cb9774126a29f926d92cfe827.zip
Notes
Diffstat (limited to 'devel/llvm29')
-rw-r--r--devel/llvm29/Makefile16
-rw-r--r--devel/llvm29/distinfo4
-rw-r--r--devel/llvm29/files/patch-Makefile11
-rw-r--r--devel/llvm29/files/patch-lib_Target_X86_X86ISelLowering.cpp27
-rw-r--r--devel/llvm29/pkg-plist129
5 files changed, 85 insertions, 102 deletions
diff --git a/devel/llvm29/Makefile b/devel/llvm29/Makefile
index e0b0ff3f3d1c..c30e8bc10297 100644
--- a/devel/llvm29/Makefile
+++ b/devel/llvm29/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= llvm
-PORTVERSION= 2.8
-PORTREVISION= 3
+PORTVERSION= 2.9
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
EXTRACT_SUFX= .tgz
@@ -43,9 +42,7 @@ CONFIGURE_ARGS+= --enable-bindings=none
OPTIONS= ASSERTS "Enable assertions (thread unsafe)" off
.if defined(NOPORTDOCS)
-DOCSRCDIR=
-.else
-DOCSRCDIR= docs
+CONFIGURE_ARGS+= --disable-docs
.endif
MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 \
@@ -79,8 +76,6 @@ post-patch:
${WRKSRC}/Makefile.config.in
${REINPLACE_CMD} -e 's|\(PROJ_mandir.*:=\).*$$|\1${MANPREFIX}/man|g' \
${WRKSRC}/Makefile.config.in
- ${REINPLACE_CMD} -e 's|%%DOCSRCDIR%%|${DOCSRCDIR}|' \
- ${WRKSRC}/Makefile
.if defined(NOPORTDOCS)
post-build:
@@ -106,16 +101,17 @@ PLIST_FILE_LIST= bin/bugpoint \
bin/llc \
bin/lli \
bin/llvm* \
+ bin/macho-dump \
bin/opt \
bin/tblgen \
- lib/libBugpointPasses.so \
+ lib/BugpointPasses.so \
lib/libCompilerDriver.a \
lib/libEnhancedDisassembly.so \
lib/libEnhancedDisassembly.a \
+ lib/LLVMHello.so \
lib/libLTO.* \
lib/libLLVM* \
- lib/libUnitTestMain.a \
- lib/libprofile_rt.so
+ lib/profile_rt.so
PLIST_DIR_LIST= include/llvm-c \
include/llvm
build-plist:
diff --git a/devel/llvm29/distinfo b/devel/llvm29/distinfo
index 4d8a8661e393..324c661a74d9 100644
--- a/devel/llvm29/distinfo
+++ b/devel/llvm29/distinfo
@@ -1,2 +1,2 @@
-SHA256 (llvm-2.8.tgz) = 25addb742f1c6cc12877ed0ee924dda962d848368ee095be8e48342ae613d43b
-SIZE (llvm-2.8.tgz) = 9112527
+SHA256 (llvm-2.9.tgz) = 661236cfa17428b48cfa9cbb9909f7569c64b8ecd219fd91dbc00e3b557b3779
+SIZE (llvm-2.9.tgz) = 9574781
diff --git a/devel/llvm29/files/patch-Makefile b/devel/llvm29/files/patch-Makefile
deleted file mode 100644
index cb94b0f8e06a..000000000000
--- a/devel/llvm29/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2010-02-25 07:34:33.000000000 +0100
-+++ Makefile 2010-04-27 11:16:37.007130964 +0200
-@@ -31,7 +31,7 @@
- OPTIONAL_DIRS :=
- else
- DIRS := lib/System lib/Support utils lib/VMCore lib tools/llvm-shlib \
-- tools/llvm-config tools runtime docs unittests
-+ tools/llvm-config tools runtime %%DOCSRCDIR%% unittests
- OPTIONAL_DIRS := projects bindings
- endif
-
diff --git a/devel/llvm29/files/patch-lib_Target_X86_X86ISelLowering.cpp b/devel/llvm29/files/patch-lib_Target_X86_X86ISelLowering.cpp
deleted file mode 100644
index 1b18d8007d66..000000000000
--- a/devel/llvm29/files/patch-lib_Target_X86_X86ISelLowering.cpp
+++ /dev/null
@@ -1,27 +0,0 @@
-
-$FreeBSD$
-
---- lib/Target/X86/X86ISelLowering.cpp.orig
-+++ lib/Target/X86/X86ISelLowering.cpp
-@@ -5414,11 +5414,19 @@
- return getMOVL(DAG, dl, VT, V2, V1);
- }
-
-- if (X86::isUNPCKL_v_undef_Mask(SVOp) || X86::isUNPCKLMask(SVOp))
-+ if (X86::isUNPCKL_v_undef_Mask(SVOp))
-+ return (isMMX) ?
-+ Op : getTargetShuffleNode(getUNPCKLOpcode(VT), dl, VT, V1, V1, DAG);
-+
-+ if (X86::isUNPCKLMask(SVOp))
- return (isMMX) ?
- Op : getTargetShuffleNode(getUNPCKLOpcode(VT), dl, VT, V1, V2, DAG);
-
-- if (X86::isUNPCKH_v_undef_Mask(SVOp) || X86::isUNPCKHMask(SVOp))
-+ if (X86::isUNPCKH_v_undef_Mask(SVOp))
-+ return (isMMX) ?
-+ Op : getTargetShuffleNode(getUNPCKHOpcode(VT), dl, VT, V1, V1, DAG);
-+
-+ if (X86::isUNPCKHMask(SVOp))
- return (isMMX) ?
- Op : getTargetShuffleNode(getUNPCKHOpcode(VT), dl, VT, V1, V2, DAG);
-
diff --git a/devel/llvm29/pkg-plist b/devel/llvm29/pkg-plist
index 8e7c232f3bd2..fa8d3c179435 100644
--- a/devel/llvm29/pkg-plist
+++ b/devel/llvm29/pkg-plist
@@ -12,10 +12,12 @@ bin/llvm-ld
bin/llvm-link
bin/llvm-mc
bin/llvm-nm
+bin/llvm-objdump
bin/llvm-prof
bin/llvm-ranlib
bin/llvm-stub
bin/llvmc
+bin/macho-dump
bin/opt
bin/tblgen
include/llvm-c/Analysis.h
@@ -24,6 +26,7 @@ include/llvm-c/BitWriter.h
include/llvm-c/Core.h
include/llvm-c/EnhancedDisassembly.h
include/llvm-c/ExecutionEngine.h
+include/llvm-c/Initialization.h
include/llvm-c/LinkTimeOptimizer.h
include/llvm-c/Target.h
include/llvm-c/Transforms/IPO.h
@@ -32,6 +35,7 @@ include/llvm-c/lto.h
include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
+include/llvm/ADT/ArrayRef.h
include/llvm/ADT/BitVector.h
include/llvm/ADT/DAGDeltaAlgorithm.h
include/llvm/ADT/DeltaAlgorithm.h
@@ -46,7 +50,10 @@ include/llvm/ADT/ImmutableIntervalMap.h
include/llvm/ADT/ImmutableList.h
include/llvm/ADT/ImmutableMap.h
include/llvm/ADT/ImmutableSet.h
+include/llvm/ADT/InMemoryStruct.h
include/llvm/ADT/IndexedMap.h
+include/llvm/ADT/IntEqClasses.h
+include/llvm/ADT/IntervalMap.h
include/llvm/ADT/IntrusiveRefCntPtr.h
include/llvm/ADT/NullablePtr.h
include/llvm/ADT/Optional.h
@@ -89,9 +96,11 @@ include/llvm/Analysis/CaptureTracking.h
include/llvm/Analysis/CodeMetrics.h
include/llvm/Analysis/ConstantFolding.h
include/llvm/Analysis/ConstantsScanner.h
+include/llvm/Analysis/DIBuilder.h
include/llvm/Analysis/DOTGraphTraitsPass.h
include/llvm/Analysis/DebugInfo.h
include/llvm/Analysis/DomPrinter.h
+include/llvm/Analysis/DominanceFrontier.h
include/llvm/Analysis/DominatorInternals.h
include/llvm/Analysis/Dominators.h
include/llvm/Analysis/FindUsedTypes.h
@@ -105,7 +114,6 @@ include/llvm/Analysis/LazyValueInfo.h
include/llvm/Analysis/LibCallAliasAnalysis.h
include/llvm/Analysis/LibCallSemantics.h
include/llvm/Analysis/Lint.h
-include/llvm/Analysis/LiveValues.h
include/llvm/Analysis/Loads.h
include/llvm/Analysis/LoopDependenceAnalysis.h
include/llvm/Analysis/LoopInfo.h
@@ -114,13 +122,15 @@ include/llvm/Analysis/MemoryBuiltins.h
include/llvm/Analysis/MemoryDependenceAnalysis.h
include/llvm/Analysis/PHITransAddr.h
include/llvm/Analysis/Passes.h
-include/llvm/Analysis/PointerTracking.h
+include/llvm/Analysis/PathNumbering.h
+include/llvm/Analysis/PathProfileInfo.h
include/llvm/Analysis/PostDominators.h
include/llvm/Analysis/ProfileInfo.h
include/llvm/Analysis/ProfileInfoLoader.h
include/llvm/Analysis/ProfileInfoTypes.h
include/llvm/Analysis/RegionInfo.h
include/llvm/Analysis/RegionIterator.h
+include/llvm/Analysis/RegionPass.h
include/llvm/Analysis/RegionPrinter.h
include/llvm/Analysis/ScalarEvolution.h
include/llvm/Analysis/ScalarEvolutionExpander.h
@@ -144,7 +154,6 @@ include/llvm/Bitcode/BitstreamReader.h
include/llvm/Bitcode/BitstreamWriter.h
include/llvm/Bitcode/LLVMBitCodes.h
include/llvm/Bitcode/ReaderWriter.h
-include/llvm/CMakeLists.txt
include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/Analysis.h
@@ -152,6 +161,7 @@ include/llvm/CodeGen/AsmPrinter.h
include/llvm/CodeGen/BinaryObject.h
include/llvm/CodeGen/CalcSpillWeights.h
include/llvm/CodeGen/CallingConvLower.h
+include/llvm/CodeGen/EdgeBundles.h
include/llvm/CodeGen/FastISel.h
include/llvm/CodeGen/FunctionLoweringInfo.h
include/llvm/CodeGen/GCMetadata.h
@@ -183,6 +193,7 @@ include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLocation.h
include/llvm/CodeGen/MachineLoopInfo.h
+include/llvm/CodeGen/MachineLoopRanges.h
include/llvm/CodeGen/MachineMemOperand.h
include/llvm/CodeGen/MachineModuleInfo.h
include/llvm/CodeGen/MachineModuleInfoImpls.h
@@ -192,10 +203,16 @@ include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/MachineSSAUpdater.h
include/llvm/CodeGen/ObjectCodeEmitter.h
+include/llvm/CodeGen/PBQP/Graph.h
+include/llvm/CodeGen/PBQP/HeuristicBase.h
+include/llvm/CodeGen/PBQP/HeuristicSolver.h
+include/llvm/CodeGen/PBQP/Heuristics/Briggs.h
+include/llvm/CodeGen/PBQP/Math.h
+include/llvm/CodeGen/PBQP/Solution.h
include/llvm/CodeGen/Passes.h
-include/llvm/CodeGen/PostRAHazardRecognizer.h
include/llvm/CodeGen/ProcessImplicitDefs.h
include/llvm/CodeGen/PseudoSourceValue.h
+include/llvm/CodeGen/RegAllocPBQP.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterCoalescer.h
include/llvm/CodeGen/RegisterScavenging.h
@@ -203,6 +220,7 @@ include/llvm/CodeGen/RuntimeLibcalls.h
include/llvm/CodeGen/ScheduleDAG.h
include/llvm/CodeGen/ScheduleHazardRecognizer.h
include/llvm/CodeGen/SchedulerRegistry.h
+include/llvm/CodeGen/ScoreboardHazardRecognizer.h
include/llvm/CodeGen/SelectionDAG.h
include/llvm/CodeGen/SelectionDAGISel.h
include/llvm/CodeGen/SelectionDAGNodes.h
@@ -224,9 +242,7 @@ include/llvm/Config/AsmPrinters.def
include/llvm/Config/Disassemblers.def
include/llvm/Config/Targets.def
include/llvm/Config/config.h
-include/llvm/Config/config.h.cmake
include/llvm/Config/llvm-config.h
-include/llvm/Config/llvm-config.h.cmake
include/llvm/Constant.h
include/llvm/Constants.h
include/llvm/DerivedTypes.h
@@ -236,11 +252,13 @@ include/llvm/ExecutionEngine/Interpreter.h
include/llvm/ExecutionEngine/JIT.h
include/llvm/ExecutionEngine/JITEventListener.h
include/llvm/ExecutionEngine/JITMemoryManager.h
+include/llvm/ExecutionEngine/MCJIT.h
include/llvm/Function.h
include/llvm/GVMaterializer.h
include/llvm/GlobalAlias.h
include/llvm/GlobalValue.h
include/llvm/GlobalVariable.h
+include/llvm/InitializePasses.h
include/llvm/InlineAsm.h
include/llvm/InstrTypes.h
include/llvm/Instruction.def
@@ -253,6 +271,7 @@ include/llvm/Intrinsics.td
include/llvm/IntrinsicsARM.td
include/llvm/IntrinsicsAlpha.td
include/llvm/IntrinsicsCellSPU.td
+include/llvm/IntrinsicsPTX.td
include/llvm/IntrinsicsPowerPC.td
include/llvm/IntrinsicsX86.td
include/llvm/IntrinsicsXCore.td
@@ -261,7 +280,6 @@ include/llvm/LinkAllPasses.h
include/llvm/LinkAllVMCore.h
include/llvm/Linker.h
include/llvm/MC/EDInstInfo.h
-include/llvm/MC/ELFObjectWriter.h
include/llvm/MC/MCAsmInfo.h
include/llvm/MC/MCAsmInfoCOFF.h
include/llvm/MC/MCAsmInfoDarwin.h
@@ -272,13 +290,16 @@ include/llvm/MC/MCContext.h
include/llvm/MC/MCDirectives.h
include/llvm/MC/MCDisassembler.h
include/llvm/MC/MCDwarf.h
+include/llvm/MC/MCELFObjectWriter.h
include/llvm/MC/MCELFSymbolFlags.h
include/llvm/MC/MCExpr.h
include/llvm/MC/MCFixup.h
+include/llvm/MC/MCFixupKindInfo.h
include/llvm/MC/MCInst.h
include/llvm/MC/MCInstPrinter.h
include/llvm/MC/MCLabel.h
include/llvm/MC/MCMachOSymbolFlags.h
+include/llvm/MC/MCMachObjectWriter.h
include/llvm/MC/MCObjectStreamer.h
include/llvm/MC/MCObjectWriter.h
include/llvm/MC/MCParser/AsmCond.h
@@ -294,10 +315,12 @@ include/llvm/MC/MCSectionMachO.h
include/llvm/MC/MCStreamer.h
include/llvm/MC/MCSymbol.h
include/llvm/MC/MCValue.h
-include/llvm/MC/MachObjectWriter.h
include/llvm/MC/SectionKind.h
include/llvm/Metadata.h
include/llvm/Module.h
+include/llvm/Object/MachOFormat.h
+include/llvm/Object/MachOObject.h
+include/llvm/Object/ObjectFile.h
include/llvm/OperandTraits.h
include/llvm/Operator.h
include/llvm/Pass.h
@@ -306,8 +329,10 @@ include/llvm/PassManager.h
include/llvm/PassManagers.h
include/llvm/PassRegistry.h
include/llvm/PassSupport.h
+include/llvm/Support/AIXDataTypesFix.h
include/llvm/Support/AlignOf.h
include/llvm/Support/Allocator.h
+include/llvm/Support/Atomic.h
include/llvm/Support/CFG.h
include/llvm/Support/COFF.h
include/llvm/Support/CallSite.h
@@ -319,95 +344,99 @@ include/llvm/Support/ConstantRange.h
include/llvm/Support/CrashRecoveryContext.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataFlow.h
+include/llvm/Support/DataTypes.h
include/llvm/Support/Debug.h
include/llvm/Support/DebugLoc.h
+include/llvm/Support/Disassembler.h
include/llvm/Support/Dwarf.h
-include/llvm/Support/DynamicLinker.h
+include/llvm/Support/DynamicLibrary.h
include/llvm/Support/ELF.h
+include/llvm/Support/Endian.h
+include/llvm/Support/Errno.h
include/llvm/Support/ErrorHandling.h
+include/llvm/Support/FEnv.h
+include/llvm/Support/FileSystem.h
include/llvm/Support/FileUtilities.h
include/llvm/Support/Format.h
include/llvm/Support/FormattedStream.h
include/llvm/Support/GetElementPtrTypeIterator.h
include/llvm/Support/GraphWriter.h
+include/llvm/Support/Host.h
include/llvm/Support/IRBuilder.h
include/llvm/Support/IRReader.h
+include/llvm/Support/IncludeFile.h
include/llvm/Support/InstIterator.h
include/llvm/Support/InstVisitor.h
+include/llvm/Support/LICENSE.TXT
include/llvm/Support/LeakDetector.h
include/llvm/Support/MachO.h
include/llvm/Support/ManagedStatic.h
include/llvm/Support/MathExtras.h
+include/llvm/Support/Memory.h
include/llvm/Support/MemoryBuffer.h
include/llvm/Support/MemoryObject.h
+include/llvm/Support/Mutex.h
include/llvm/Support/MutexGuard.h
include/llvm/Support/NoFolder.h
include/llvm/Support/OutputBuffer.h
include/llvm/Support/PassNameParser.h
+include/llvm/Support/Path.h
+include/llvm/Support/PathV1.h
+include/llvm/Support/PathV2.h
include/llvm/Support/PatternMatch.h
include/llvm/Support/PluginLoader.h
include/llvm/Support/PointerLikeTypeTraits.h
include/llvm/Support/PredIteratorCache.h
include/llvm/Support/PrettyStackTrace.h
+include/llvm/Support/Process.h
+include/llvm/Support/Program.h
+include/llvm/Support/RWMutex.h
include/llvm/Support/Recycler.h
include/llvm/Support/RecyclingAllocator.h
include/llvm/Support/Regex.h
include/llvm/Support/Registry.h
include/llvm/Support/RegistryParser.h
include/llvm/Support/SMLoc.h
+include/llvm/Support/Signals.h
+include/llvm/Support/Solaris.h
include/llvm/Support/SourceMgr.h
-include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/StandardPasses.h
include/llvm/Support/StringPool.h
+include/llvm/Support/SwapByteOrder.h
include/llvm/Support/SystemUtils.h
include/llvm/Support/TargetFolder.h
+include/llvm/Support/ThreadLocal.h
+include/llvm/Support/Threading.h
+include/llvm/Support/TimeValue.h
include/llvm/Support/Timer.h
+include/llvm/Support/ToolOutputFile.h
include/llvm/Support/TypeBuilder.h
+include/llvm/Support/Valgrind.h
include/llvm/Support/ValueHandle.h
include/llvm/Support/circular_raw_ostream.h
include/llvm/Support/raw_os_ostream.h
include/llvm/Support/raw_ostream.h
+include/llvm/Support/system_error.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTableListTraits.h
-include/llvm/System/AIXDataTypesFix.h
-include/llvm/System/Alarm.h
-include/llvm/System/Atomic.h
-include/llvm/System/DataTypes.h
-include/llvm/System/DataTypes.h.cmake
-include/llvm/System/Disassembler.h
-include/llvm/System/DynamicLibrary.h
-include/llvm/System/Errno.h
-include/llvm/System/Host.h
-include/llvm/System/IncludeFile.h
-include/llvm/System/LICENSE.TXT
-include/llvm/System/Memory.h
-include/llvm/System/Mutex.h
-include/llvm/System/Path.h
-include/llvm/System/Process.h
-include/llvm/System/Program.h
-include/llvm/System/RWMutex.h
-include/llvm/System/Signals.h
-include/llvm/System/Solaris.h
-include/llvm/System/ThreadLocal.h
-include/llvm/System/Threading.h
-include/llvm/System/TimeValue.h
-include/llvm/System/Valgrind.h
include/llvm/Target/Mangler.h
include/llvm/Target/SubtargetFeature.h
include/llvm/Target/Target.td
include/llvm/Target/TargetAsmBackend.h
+include/llvm/Target/TargetAsmInfo.h
include/llvm/Target/TargetAsmLexer.h
include/llvm/Target/TargetAsmParser.h
include/llvm/Target/TargetCallingConv.h
include/llvm/Target/TargetCallingConv.td
include/llvm/Target/TargetData.h
include/llvm/Target/TargetELFWriterInfo.h
-include/llvm/Target/TargetFrameInfo.h
+include/llvm/Target/TargetFrameLowering.h
include/llvm/Target/TargetInstrDesc.h
include/llvm/Target/TargetInstrInfo.h
include/llvm/Target/TargetInstrItineraries.h
include/llvm/Target/TargetIntrinsicInfo.h
include/llvm/Target/TargetJITInfo.h
+include/llvm/Target/TargetLibraryInfo.h
include/llvm/Target/TargetLowering.h
include/llvm/Target/TargetLoweringObjectFile.h
include/llvm/Target/TargetMachine.h
@@ -423,7 +452,6 @@ include/llvm/Target/TargetSubtarget.h
include/llvm/Transforms/IPO.h
include/llvm/Transforms/IPO/InlinerPass.h
include/llvm/Transforms/Instrumentation.h
-include/llvm/Transforms/RSProfiling.h
include/llvm/Transforms/Scalar.h
include/llvm/Transforms/Utils/AddrModeMatcher.h
include/llvm/Transforms/Utils/BasicBlockUtils.h
@@ -444,7 +472,8 @@ include/llvm/Use.h
include/llvm/User.h
include/llvm/Value.h
include/llvm/ValueSymbolTable.h
-lib/libBugpointPasses.so
+lib/BugpointPasses.so
+lib/LLVMHello.so
lib/libCompilerDriver.a
lib/libEnhancedDisassembly.a
lib/libEnhancedDisassembly.so
@@ -453,7 +482,6 @@ lib/libLLVMARMAsmPrinter.a
lib/libLLVMARMCodeGen.a
lib/libLLVMARMDisassembler.a
lib/libLLVMARMInfo.a
-lib/libLLVMAlphaAsmPrinter.a
lib/libLLVMAlphaCodeGen.a
lib/libLLVMAlphaInfo.a
lib/libLLVMAnalysis.a
@@ -462,12 +490,10 @@ lib/libLLVMAsmParser.a
lib/libLLVMAsmPrinter.a
lib/libLLVMBitReader.a
lib/libLLVMBitWriter.a
-lib/libLLVMBlackfinAsmPrinter.a
lib/libLLVMBlackfinCodeGen.a
lib/libLLVMBlackfinInfo.a
lib/libLLVMCBackend.a
lib/libLLVMCBackendInfo.a
-lib/libLLVMCellSPUAsmPrinter.a
lib/libLLVMCellSPUCodeGen.a
lib/libLLVMCellSPUInfo.a
lib/libLLVMCodeGen.a
@@ -475,38 +501,36 @@ lib/libLLVMCore.a
lib/libLLVMCppBackend.a
lib/libLLVMCppBackendInfo.a
lib/libLLVMExecutionEngine.a
-lib/libLLVMHello.so
lib/libLLVMInstCombine.a
lib/libLLVMInstrumentation.a
lib/libLLVMInterpreter.a
lib/libLLVMJIT.a
lib/libLLVMLinker.a
+lib/libLLVMMBlazeAsmParser.a
lib/libLLVMMBlazeAsmPrinter.a
lib/libLLVMMBlazeCodeGen.a
+lib/libLLVMMBlazeDisassembler.a
lib/libLLVMMBlazeInfo.a
lib/libLLVMMC.a
lib/libLLVMMCDisassembler.a
+lib/libLLVMMCJIT.a
lib/libLLVMMCParser.a
lib/libLLVMMSP430AsmPrinter.a
lib/libLLVMMSP430CodeGen.a
lib/libLLVMMSP430Info.a
-lib/libLLVMMipsAsmPrinter.a
lib/libLLVMMipsCodeGen.a
lib/libLLVMMipsInfo.a
-lib/libLLVMPIC16AsmPrinter.a
-lib/libLLVMPIC16CodeGen.a
-lib/libLLVMPIC16Info.a
+lib/libLLVMObject.a
+lib/libLLVMPTXCodeGen.a
+lib/libLLVMPTXInfo.a
lib/libLLVMPowerPCAsmPrinter.a
lib/libLLVMPowerPCCodeGen.a
lib/libLLVMPowerPCInfo.a
lib/libLLVMScalarOpts.a
lib/libLLVMSelectionDAG.a
-lib/libLLVMSparcAsmPrinter.a
lib/libLLVMSparcCodeGen.a
lib/libLLVMSparcInfo.a
lib/libLLVMSupport.a
-lib/libLLVMSystem.a
-lib/libLLVMSystemZAsmPrinter.a
lib/libLLVMSystemZCodeGen.a
lib/libLLVMSystemZInfo.a
lib/libLLVMTarget.a
@@ -516,16 +540,14 @@ lib/libLLVMX86AsmPrinter.a
lib/libLLVMX86CodeGen.a
lib/libLLVMX86Disassembler.a
lib/libLLVMX86Info.a
-lib/libLLVMXCoreAsmPrinter.a
+lib/libLLVMX86Utils.a
lib/libLLVMXCoreCodeGen.a
lib/libLLVMXCoreInfo.a
lib/libLLVMipa.a
lib/libLLVMipo.a
-lib/libLLVMpic16passes.a
lib/libLTO.a
lib/libLTO.so
-lib/libUnitTestMain.a
-lib/libprofile_rt.so
+lib/profile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
%%PORTDOCS%%%%DOCSDIR%%/html/AliasAnalysis.html
%%PORTDOCS%%%%DOCSDIR%%/html/BitCodeFormat.html
@@ -614,6 +636,7 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl5.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl6.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl8.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/index.html
%%PORTDOCS%%%%DOCSDIR%%/ps/FileCheck.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/bugpoint.ps
@@ -641,13 +664,15 @@ lib/libprofile_rt.so
@dirrm include/llvm/Transforms/IPO
@dirrm include/llvm/Transforms
@dirrm include/llvm/Target
-@dirrm include/llvm/System
@dirrm include/llvm/Support
+@dirrm include/llvm/Object
@dirrm include/llvm/MC/MCParser
@dirrm include/llvm/MC
@dirrm include/llvm/ExecutionEngine
@dirrm include/llvm/Config
@dirrm include/llvm/CompilerDriver
+@dirrm include/llvm/CodeGen/PBQP/Heuristics
+@dirrm include/llvm/CodeGen/PBQP
@dirrm include/llvm/CodeGen
@dirrm include/llvm/Bitcode
@dirrm include/llvm/Assembly