aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm29
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2005-12-24 16:19:24 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2005-12-24 16:19:24 +0000
commit9dc294d9ec15cd0b65aa0ff1baedff3c572beb0e (patch)
tree79a5a4e254f790f0b1efd46e0497b57d1331bb7e /devel/llvm29
parent0b21f7682565f46009b1fc1ffdd31e43f1804cdc (diff)
downloadports-9dc294d9ec15cd0b65aa0ff1baedff3c572beb0e.tar.gz
ports-9dc294d9ec15cd0b65aa0ff1baedff3c572beb0e.zip
Notes
Diffstat (limited to 'devel/llvm29')
-rw-r--r--devel/llvm29/Makefile33
-rw-r--r--devel/llvm29/distinfo3
-rw-r--r--devel/llvm29/pkg-descr10
-rw-r--r--devel/llvm29/pkg-plist372
4 files changed, 418 insertions, 0 deletions
diff --git a/devel/llvm29/Makefile b/devel/llvm29/Makefile
new file mode 100644
index 000000000000..3152770a27ae
--- /dev/null
+++ b/devel/llvm29/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: llvm
+# Date created: 20 Nov 2005
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+#
+
+PORTNAME= llvm
+PORTVERSION= 1.6
+CATEGORIES= devel lang
+MASTER_SITES= http://llvm.cs.uiuc.edu/releases/${PORTVERSION}/
+
+MAINTAINER= perky@FreeBSD.org
+COMMENT= Low Level Virtual Machine
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+MAKE_ENV= ENABLE_OPTIMIZED=1 # strips binaries
+
+WRKSRC= ${WRKDIR}/llvm
+
+MAN1= analyze.1 bugpoint.1 gccas.1 gccld.1 llc.1 lli.1 llvm-ar.1 \
+ llvm-as.1 llvm-bcanalyzer.1 llvm-db.1 llvm-dis.1 \
+ llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 llvm-prof.1 \
+ llvm-ranlib.1 llvmc.1 llvmgcc.1 llvmgxx.1 opt.1 stkrc.1
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,\(OPTIONAL_DIRS.*\)examples,\1,g' \
+ ${WRKSRC}/Makefile
+ ${RM} -rf ${WRKSRC}/projects/sample
+
+.include <bsd.port.mk>
diff --git a/devel/llvm29/distinfo b/devel/llvm29/distinfo
new file mode 100644
index 000000000000..2bd188eda40f
--- /dev/null
+++ b/devel/llvm29/distinfo
@@ -0,0 +1,3 @@
+MD5 (llvm-1.6.tar.gz) = 68f41af7f4bae560ffb650da6f9f145d
+SHA256 (llvm-1.6.tar.gz) = 7f9ef39554a3b488d26eadea768b90900466eba887214c48737959c5f133ebc1
+SIZE (llvm-1.6.tar.gz) = 4238390
diff --git a/devel/llvm29/pkg-descr b/devel/llvm29/pkg-descr
new file mode 100644
index 000000000000..ba43ebf6c842
--- /dev/null
+++ b/devel/llvm29/pkg-descr
@@ -0,0 +1,10 @@
+Low Level Virtual Machine (LLVM) is:
+- A compilation strategy designed to enable effective program
+ optimization across the entire lifetime of a program.
+- A virtual instruction set.
+- A compiler infrastructure.
+- LLVM does not imply things that you would expect from a high-level
+ virtual machine. It does not require garbage collection or run-time
+ code generation.
+
+WWW: http://llvm.cs.uiuc.edu/
diff --git a/devel/llvm29/pkg-plist b/devel/llvm29/pkg-plist
new file mode 100644
index 000000000000..334d386a90d2
--- /dev/null
+++ b/devel/llvm29/pkg-plist
@@ -0,0 +1,372 @@
+bin/analyze
+bin/bugpoint
+bin/gccas
+bin/gccld
+bin/llc
+bin/lli
+bin/llvm-ar
+bin/llvm-as
+bin/llvm-bcanalyzer
+bin/llvm-db
+bin/llvm-dis
+bin/llvm-extract
+bin/llvm-ld
+bin/llvm-link
+bin/llvm-nm
+bin/llvm-prof
+bin/llvm-ranlib
+bin/llvm-stub
+bin/llvmc
+bin/opt
+bin/stkrc
+docs/llvm/html.tar.gz
+docs/llvm/html/AliasAnalysis.html
+docs/llvm/html/Bugpoint.html
+docs/llvm/html/BytecodeFormat.html
+docs/llvm/html/CFEBuildInstrs.html
+docs/llvm/html/CodeGenerator.html
+docs/llvm/html/CodingStandards.html
+docs/llvm/html/CommandGuide/analyze.html
+docs/llvm/html/CommandGuide/bugpoint.html
+docs/llvm/html/CommandGuide/gccas.html
+docs/llvm/html/CommandGuide/gccld.html
+docs/llvm/html/CommandGuide/index.html
+docs/llvm/html/CommandGuide/llc.html
+docs/llvm/html/CommandGuide/lli.html
+docs/llvm/html/CommandGuide/llvm-ar.html
+docs/llvm/html/CommandGuide/llvm-as.html
+docs/llvm/html/CommandGuide/llvm-bcanalyzer.html
+docs/llvm/html/CommandGuide/llvm-db.html
+docs/llvm/html/CommandGuide/llvm-dis.html
+docs/llvm/html/CommandGuide/llvm-extract.html
+docs/llvm/html/CommandGuide/llvm-ld.html
+docs/llvm/html/CommandGuide/llvm-link.html
+docs/llvm/html/CommandGuide/llvm-nm.html
+docs/llvm/html/CommandGuide/llvm-prof.html
+docs/llvm/html/CommandGuide/llvm-ranlib.html
+docs/llvm/html/CommandGuide/llvmc.html
+docs/llvm/html/CommandGuide/llvmgcc.html
+docs/llvm/html/CommandGuide/llvmgxx.html
+docs/llvm/html/CommandGuide/manpage.css
+docs/llvm/html/CommandGuide/opt.html
+docs/llvm/html/CommandGuide/stkrc.html
+docs/llvm/html/CommandLine.html
+docs/llvm/html/CompilerDriver.html
+docs/llvm/html/CompilerWriterInfo.html
+docs/llvm/html/ExtendingLLVM.html
+docs/llvm/html/FAQ.html
+docs/llvm/html/GarbageCollection.html
+docs/llvm/html/GettingStarted.html
+docs/llvm/html/GettingStartedVS.html
+docs/llvm/html/HowToSubmitABug.html
+docs/llvm/html/LLVMVsTheWorld.html
+docs/llvm/html/LangRef.html
+docs/llvm/html/Lexicon.html
+docs/llvm/html/MakefileGuide.html
+docs/llvm/html/ProgrammersManual.html
+docs/llvm/html/Projects.html
+docs/llvm/html/ReleaseNotes.html
+docs/llvm/html/SourceLevelDebugging.html
+docs/llvm/html/Stacker.html
+docs/llvm/html/SystemLibrary.html
+docs/llvm/html/TableGenFundamentals.html
+docs/llvm/html/TestingGuide.html
+docs/llvm/html/UsingLibraries.html
+docs/llvm/html/WritingAnLLVMBackend.html
+docs/llvm/html/WritingAnLLVMPass.html
+docs/llvm/html/doxygen.css
+docs/llvm/html/img/Debugging.gif
+docs/llvm/html/img/libdeps.gif
+docs/llvm/html/img/lines.gif
+docs/llvm/html/img/objdeps.gif
+docs/llvm/html/img/venusflytrap.jpg
+docs/llvm/html/index.html
+docs/llvm/html/llvm.css
+docs/llvm/ps/analyze.ps
+docs/llvm/ps/bugpoint.ps
+docs/llvm/ps/gccas.ps
+docs/llvm/ps/gccld.ps
+docs/llvm/ps/llc.ps
+docs/llvm/ps/lli.ps
+docs/llvm/ps/llvm-ar.ps
+docs/llvm/ps/llvm-as.ps
+docs/llvm/ps/llvm-bcanalyzer.ps
+docs/llvm/ps/llvm-db.ps
+docs/llvm/ps/llvm-dis.ps
+docs/llvm/ps/llvm-extract.ps
+docs/llvm/ps/llvm-ld.ps
+docs/llvm/ps/llvm-link.ps
+docs/llvm/ps/llvm-nm.ps
+docs/llvm/ps/llvm-prof.ps
+docs/llvm/ps/llvm-ranlib.ps
+docs/llvm/ps/llvmc.ps
+docs/llvm/ps/llvmgcc.ps
+docs/llvm/ps/llvmgxx.ps
+docs/llvm/ps/opt.ps
+docs/llvm/ps/stkrc.ps
+etc/llvm/.dir
+etc/llvm/C
+etc/llvm/c
+etc/llvm/c++
+etc/llvm/cc
+etc/llvm/cpp
+etc/llvm/cxx
+etc/llvm/ll
+etc/llvm/st
+include/llvm/ADT/.cvsignore
+include/llvm/ADT/BitSetVector.h
+include/llvm/ADT/DenseMap.h
+include/llvm/ADT/DepthFirstIterator.h
+include/llvm/ADT/EquivalenceClasses.h
+include/llvm/ADT/GraphTraits.h
+include/llvm/ADT/HashExtras.h
+include/llvm/ADT/PostOrderIterator.h
+include/llvm/ADT/SCCIterator.h
+include/llvm/ADT/STLExtras.h
+include/llvm/ADT/SetOperations.h
+include/llvm/ADT/SetVector.h
+include/llvm/ADT/Statistic.h
+include/llvm/ADT/StringExtras.h
+include/llvm/ADT/Tree.h
+include/llvm/ADT/VectorExtras.h
+include/llvm/ADT/hash_map
+include/llvm/ADT/hash_map.in
+include/llvm/ADT/hash_set
+include/llvm/ADT/hash_set.in
+include/llvm/ADT/ilist
+include/llvm/ADT/iterator
+include/llvm/ADT/iterator.in
+include/llvm/AbstractTypeUser.h
+include/llvm/Analysis/AliasAnalysis.h
+include/llvm/Analysis/AliasSetTracker.h
+include/llvm/Analysis/CFGPrinter.h
+include/llvm/Analysis/CallGraph.h
+include/llvm/Analysis/ConstantFolding.h
+include/llvm/Analysis/ConstantsScanner.h
+include/llvm/Analysis/DataStructure/DSGraph.h
+include/llvm/Analysis/DataStructure/DSGraphTraits.h
+include/llvm/Analysis/DataStructure/DSNode.h
+include/llvm/Analysis/DataStructure/DSSupport.h
+include/llvm/Analysis/DataStructure/DataStructure.h
+include/llvm/Analysis/Dominators.h
+include/llvm/Analysis/FindUsedTypes.h
+include/llvm/Analysis/Interval.h
+include/llvm/Analysis/IntervalIterator.h
+include/llvm/Analysis/IntervalPartition.h
+include/llvm/Analysis/LinkAllAnalyses.h
+include/llvm/Analysis/LoadValueNumbering.h
+include/llvm/Analysis/LoopInfo.h
+include/llvm/Analysis/Passes.h
+include/llvm/Analysis/PostDominators.h
+include/llvm/Analysis/ProfileInfo.h
+include/llvm/Analysis/ProfileInfoLoader.h
+include/llvm/Analysis/ProfileInfoTypes.h
+include/llvm/Analysis/ScalarEvolution.h
+include/llvm/Analysis/ScalarEvolutionExpander.h
+include/llvm/Analysis/ScalarEvolutionExpressions.h
+include/llvm/Analysis/Trace.h
+include/llvm/Analysis/ValueNumbering.h
+include/llvm/Analysis/Verifier.h
+include/llvm/Argument.h
+include/llvm/Assembly/AsmAnnotationWriter.h
+include/llvm/Assembly/CachedWriter.h
+include/llvm/Assembly/Parser.h
+include/llvm/Assembly/PrintModulePass.h
+include/llvm/Assembly/Writer.h
+include/llvm/BasicBlock.h
+include/llvm/Bytecode/Analyzer.h
+include/llvm/Bytecode/Archive.h
+include/llvm/Bytecode/BytecodeHandler.h
+include/llvm/Bytecode/Format.h
+include/llvm/Bytecode/Reader.h
+include/llvm/Bytecode/WriteBytecodePass.h
+include/llvm/Bytecode/Writer.h
+include/llvm/CallGraphSCCPass.h
+include/llvm/CallingConv.h
+include/llvm/CodeGen/AsmPrinter.h
+include/llvm/CodeGen/ELFWriter.h
+include/llvm/CodeGen/InstrScheduling.h
+include/llvm/CodeGen/IntrinsicLowering.h
+include/llvm/CodeGen/LiveInterval.h
+include/llvm/CodeGen/LiveIntervalAnalysis.h
+include/llvm/CodeGen/LiveVariables.h
+include/llvm/CodeGen/MachineBasicBlock.h
+include/llvm/CodeGen/MachineCodeEmitter.h
+include/llvm/CodeGen/MachineConstantPool.h
+include/llvm/CodeGen/MachineFrameInfo.h
+include/llvm/CodeGen/MachineFunction.h
+include/llvm/CodeGen/MachineFunctionPass.h
+include/llvm/CodeGen/MachineInstr.h
+include/llvm/CodeGen/MachineInstrBuilder.h
+include/llvm/CodeGen/MachineRelocation.h
+include/llvm/CodeGen/Passes.h
+include/llvm/CodeGen/SSARegMap.h
+include/llvm/CodeGen/SchedGraphCommon.h
+include/llvm/CodeGen/SelectionDAG.h
+include/llvm/CodeGen/SelectionDAGISel.h
+include/llvm/CodeGen/SelectionDAGNodes.h
+include/llvm/CodeGen/ValueSet.h
+include/llvm/CodeGen/ValueTypes.h
+include/llvm/Config/.cvsignore
+include/llvm/Config/alloca.h
+include/llvm/Config/config.h
+include/llvm/Config/config.h.in
+include/llvm/Constant.h
+include/llvm/Constants.h
+include/llvm/Debugger/Debugger.h
+include/llvm/Debugger/InferiorProcess.h
+include/llvm/Debugger/ProgramInfo.h
+include/llvm/Debugger/RuntimeInfo.h
+include/llvm/Debugger/SourceFile.h
+include/llvm/Debugger/SourceLanguage.h
+include/llvm/DerivedTypes.h
+include/llvm/ExecutionEngine/ExecutionEngine.h
+include/llvm/ExecutionEngine/GenericValue.h
+include/llvm/Function.h
+include/llvm/GlobalValue.h
+include/llvm/GlobalVariable.h
+include/llvm/InstrTypes.h
+include/llvm/Instruction.def
+include/llvm/Instruction.h
+include/llvm/Instructions.h
+include/llvm/IntrinsicInst.h
+include/llvm/Intrinsics.h
+include/llvm/Linker.h
+include/llvm/Module.h
+include/llvm/ModuleProvider.h
+include/llvm/Pass.h
+include/llvm/PassAnalysisSupport.h
+include/llvm/PassManager.h
+include/llvm/PassSupport.h
+include/llvm/Support/.cvsignore
+include/llvm/Support/AIXDataTypesFix.h
+include/llvm/Support/Annotation.h
+include/llvm/Support/CFG.h
+include/llvm/Support/CallSite.h
+include/llvm/Support/Casting.h
+include/llvm/Support/CommandLine.h
+include/llvm/Support/Compressor.h
+include/llvm/Support/ConstantRange.h
+include/llvm/Support/DOTGraphTraits.h
+include/llvm/Support/DataTypes.h
+include/llvm/Support/DataTypes.h.in
+include/llvm/Support/Debug.h
+include/llvm/Support/DynamicLinker.h
+include/llvm/Support/ELF.h
+include/llvm/Support/FileUtilities.h
+include/llvm/Support/GetElementPtrTypeIterator.h
+include/llvm/Support/GraphWriter.h
+include/llvm/Support/InstIterator.h
+include/llvm/Support/InstVisitor.h
+include/llvm/Support/LeakDetector.h
+include/llvm/Support/Mangler.h
+include/llvm/Support/MathExtras.h
+include/llvm/Support/MutexGuard.h
+include/llvm/Support/PassNameParser.h
+include/llvm/Support/PatternMatch.h
+include/llvm/Support/PluginLoader.h
+include/llvm/Support/SlowOperationInformer.h
+include/llvm/Support/StableBasicBlockNumbering.h
+include/llvm/Support/SystemUtils.h
+include/llvm/Support/Timer.h
+include/llvm/Support/ToolRunner.h
+include/llvm/Support/TypeInfo.h
+include/llvm/Support/type_traits.h
+include/llvm/SymbolTable.h
+include/llvm/SymbolTableListTraits.h
+include/llvm/System/DynamicLibrary.h
+include/llvm/System/LICENSE.TXT
+include/llvm/System/MappedFile.h
+include/llvm/System/Memory.h
+include/llvm/System/Mutex.h
+include/llvm/System/Path.h
+include/llvm/System/Process.h
+include/llvm/System/Program.h
+include/llvm/System/Signals.h
+include/llvm/System/TimeValue.h
+include/llvm/Target/MRegisterInfo.h
+include/llvm/Target/SubtargetFeature.h
+include/llvm/Target/TargetData.h
+include/llvm/Target/TargetFrameInfo.h
+include/llvm/Target/TargetInstrInfo.h
+include/llvm/Target/TargetInstrItineraries.h
+include/llvm/Target/TargetJITInfo.h
+include/llvm/Target/TargetLowering.h
+include/llvm/Target/TargetMachine.h
+include/llvm/Target/TargetMachineRegistry.h
+include/llvm/Target/TargetOptions.h
+include/llvm/Target/TargetSchedInfo.h
+include/llvm/Target/TargetSubtarget.h
+include/llvm/Transforms/IPO.h
+include/llvm/Transforms/Instrumentation.h
+include/llvm/Transforms/LinkAllPasses.h
+include/llvm/Transforms/Scalar.h
+include/llvm/Transforms/Utils/BasicBlockUtils.h
+include/llvm/Transforms/Utils/Cloning.h
+include/llvm/Transforms/Utils/FunctionUtils.h
+include/llvm/Transforms/Utils/Local.h
+include/llvm/Transforms/Utils/PromoteMemToReg.h
+include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
+include/llvm/Type.h
+include/llvm/Use.h
+include/llvm/User.h
+include/llvm/Value.h
+lib/LLVMAlpha.o
+lib/LLVMAsmParser.o
+lib/LLVMBCReader.o
+lib/LLVMBCWriter.o
+lib/LLVMCBackend.o
+lib/LLVMCodeGen.o
+lib/LLVMCore.o
+lib/LLVMDataStructure.o
+lib/LLVMDebugger.o
+lib/LLVMExecutionEngine.o
+lib/LLVMIA64.o
+lib/LLVMInterpreter.o
+lib/LLVMJIT.o
+lib/LLVMPowerPC.o
+lib/LLVMSelectionDAG.o
+lib/LLVMSkeleton.o
+lib/LLVMSparcV8.o
+lib/LLVMSparcV9.o
+lib/LLVMSparcV9InstrSched.o
+lib/LLVMSparcV9LiveVar.o
+lib/LLVMSparcV9ModuloSched.o
+lib/LLVMSparcV9RegAlloc.o
+lib/LLVMX86.o
+lib/LLVMbzip2.o
+lib/libLLVMAnalysis.a
+lib/libLLVMArchive.a
+lib/libLLVMInstrumentation.a
+lib/libLLVMLinker.a
+lib/libLLVMScalarOpts.a
+lib/libLLVMSupport.a
+lib/libLLVMSystem.a
+lib/libLLVMTarget.a
+lib/libLLVMTransformUtils.a
+lib/libLLVMTransforms.a
+lib/libLLVMipa.a
+lib/libLLVMipo.a
+lib/stkr_compiler.o
+@dirrm include/llvm/Transforms/Utils
+@dirrm include/llvm/Transforms
+@dirrm include/llvm/Target
+@dirrm include/llvm/System
+@dirrm include/llvm/Support
+@dirrm include/llvm/ExecutionEngine
+@dirrm include/llvm/Debugger
+@dirrm include/llvm/Config
+@dirrm include/llvm/CodeGen
+@dirrm include/llvm/Bytecode
+@dirrm include/llvm/Assembly
+@dirrm include/llvm/Analysis/DataStructure
+@dirrm include/llvm/Analysis
+@dirrm include/llvm/ADT
+@dirrm include/llvm
+@dirrm etc/llvm
+@dirrm docs/llvm/ps
+@dirrm docs/llvm/html/img
+@dirrm docs/llvm/html/CommandGuide
+@dirrm docs/llvm/html
+@dirrm docs/llvm
+@dirrm docs