aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2010-04-28 21:05:03 +0000
committerBrooks Davis <brooks@FreeBSD.org>2010-04-28 21:05:03 +0000
commitf3c8d79fc5fbd1631be25b7443626864163cb072 (patch)
tree5953dca376c8d922998e92feeaee21a91a8fdb44 /devel/llvm
parent342d3367f3b9cee463e18e91f1489ce01ec514bc (diff)
downloadports-f3c8d79fc5fbd1631be25b7443626864163cb072.tar.gz
ports-f3c8d79fc5fbd1631be25b7443626864163cb072.zip
Notes
Diffstat (limited to 'devel/llvm')
-rw-r--r--devel/llvm/Makefile23
-rw-r--r--devel/llvm/distinfo12
-rw-r--r--devel/llvm/files/patch-Makefile17
-rw-r--r--devel/llvm/pkg-plist111
4 files changed, 95 insertions, 68 deletions
diff --git a/devel/llvm/Makefile b/devel/llvm/Makefile
index 3e8b6cf88648..022404fc31b8 100644
--- a/devel/llvm/Makefile
+++ b/devel/llvm/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= llvm
-PORTVERSION= 2.6
-PORTREVISION= 2
+PORTVERSION= 2.7
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
+EXTRACT_SUFX= .tgz
MAINTAINER= brooks@FreeBSD.org
COMMENT= Low Level Virtual Machine
@@ -47,8 +47,8 @@ DOCSRCDIR= docs
.endif
.if !defined(NOPORTDOCS)
-MAN1= bugpoint.1 llc.1 lli.1 llvm-ar.1 \
- llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-db.1 \
+MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 \
+ llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
llvm-prof.1 llvm-ranlib.1 llvmc.1 llvmgcc.1 \
llvmgxx.1 opt.1 tblgen.1
@@ -56,14 +56,20 @@ MAN1= bugpoint.1 llc.1 lli.1 llvm-ar.1 \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64" || ${ARCH} =="ia64"
-BROKEN= Does not compile on ${ARCH}
+.if ${OSVERSION} < 700000 && ${ARCH} == "amd64"
+BROKEN= does not compile
+.elif ${ARCH} == "sparc64"
+BROKEN= does not compile on sparc64
.endif
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
CONFIGURE_ARGS+= --enable-pic --with-pic
.endif
+.if ${ARCH} == "i386"
+CONFIGURE_ARGS+= --with-optimize-option=-O2
+.endif
+
.ifdef(WITH_NO_ASSERTS)
CONFIGURE_ARGS+= --disable-assertions
.else
@@ -88,16 +94,17 @@ regression-test: ${BUILD_COOKIE}
fi
PLIST_FILE_LIST= bin/bugpoint \
- bin/gccas \
- bin/gccld \
bin/llc \
bin/lli \
bin/llvm* \
bin/opt \
bin/tblgen \
lib/libCompilerDriver.a \
+ lib/libEnhancedDisassembly.so \
+ lib/libEnhancedDisassembly.a \
lib/libLTO.* \
lib/libLLVM* \
+ lib/libUnitTestMain.a \
lib/libplugin_llvmc* \
lib/libprofile_rt.so
PLIST_DIR_LIST= include/llvm-c \
diff --git a/devel/llvm/distinfo b/devel/llvm/distinfo
index 2ca85665166e..2ed450d69cff 100644
--- a/devel/llvm/distinfo
+++ b/devel/llvm/distinfo
@@ -1,6 +1,6 @@
-MD5 (llvm-2.6.tar.gz) = 34a11e807add0f4555f691944e1a404a
-SHA256 (llvm-2.6.tar.gz) = 4cd9257350c5ff8b9b139d19497e2396c0604eef0e5d6504f5c1463b09bf2d84
-SIZE (llvm-2.6.tar.gz) = 7790380
-MD5 (clang-2.6.tar.gz) = 09d696bf23bb4a3cf6af3c7341cdd946
-SHA256 (clang-2.6.tar.gz) = 98e22f4f5877fb3c73abb9ddcb3065ba9c94a21146387da7f905e6fd559d39ea
-SIZE (clang-2.6.tar.gz) = 3857138
+MD5 (llvm-2.7.tgz) = ac322661f20e7d6c810b1869f886ad9b
+SHA256 (llvm-2.7.tgz) = 99664bdc8503a306038166af33f28eb426d99e297575a59d74a1a0dcbddbbca5
+SIZE (llvm-2.7.tgz) = 8374297
+MD5 (clang-2.7.tgz) = b83260aa8c13494adf8978b5f238bf1b
+SHA256 (clang-2.7.tgz) = fb349471947f155c1cda1c8a4a3bbc7fa437b86f6875d9978f86c915dfed623a
+SIZE (clang-2.7.tgz) = 4953739
diff --git a/devel/llvm/files/patch-Makefile b/devel/llvm/files/patch-Makefile
index 59fe73be2c8e..cb94b0f8e06a 100644
--- a/devel/llvm/files/patch-Makefile
+++ b/devel/llvm/files/patch-Makefile
@@ -1,14 +1,11 @@
-
-$FreeBSD$
-
---- Makefile.orig
-+++ Makefile
-@@ -24,7 +24,7 @@
+--- Makefile.orig 2010-02-25 07:34:33.000000000 +0100
++++ Makefile 2010-04-27 11:16:37.007130964 +0200
+@@ -31,7 +31,7 @@
OPTIONAL_DIRS :=
else
- DIRS := lib/System lib/Support utils lib/VMCore lib tools/llvm-config \
-- tools runtime docs
-+ tools runtime %%DOCSRCDIR%%
- OPTIONAL_DIRS := examples projects bindings
+ DIRS := lib/System lib/Support utils lib/VMCore lib tools/llvm-shlib \
+- tools/llvm-config tools runtime docs unittests
++ tools/llvm-config tools runtime %%DOCSRCDIR%% unittests
+ OPTIONAL_DIRS := projects bindings
endif
diff --git a/devel/llvm/pkg-plist b/devel/llvm/pkg-plist
index 42334cc7b087..f65c8f1a8cd4 100644
--- a/devel/llvm/pkg-plist
+++ b/devel/llvm/pkg-plist
@@ -1,13 +1,10 @@
bin/bugpoint
-bin/gccas
-bin/gccld
bin/llc
bin/lli
bin/llvm-ar
bin/llvm-as
bin/llvm-bcanalyzer
bin/llvm-config
-bin/llvm-db
bin/llvm-dis
bin/llvm-extract
bin/llvm-ld
@@ -23,6 +20,7 @@ include/llvm-c/Analysis.h
include/llvm-c/BitReader.h
include/llvm-c/BitWriter.h
include/llvm-c/Core.h
+include/llvm-c/EnhancedDisassembly.h
include/llvm-c/ExecutionEngine.h
include/llvm-c/LinkTimeOptimizer.h
include/llvm-c/Target.h
@@ -33,6 +31,7 @@ include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
include/llvm/ADT/BitVector.h
+include/llvm/ADT/DeltaAlgorithm.h
include/llvm/ADT/DenseMap.h
include/llvm/ADT/DenseMapInfo.h
include/llvm/ADT/DenseSet.h
@@ -40,7 +39,7 @@ include/llvm/ADT/DepthFirstIterator.h
include/llvm/ADT/EquivalenceClasses.h
include/llvm/ADT/FoldingSet.h
include/llvm/ADT/GraphTraits.h
-include/llvm/ADT/HashExtras.h
+include/llvm/ADT/ImmutableIntervalMap.h
include/llvm/ADT/ImmutableList.h
include/llvm/ADT/ImmutableMap.h
include/llvm/ADT/ImmutableSet.h
@@ -56,6 +55,7 @@ include/llvm/ADT/STLExtras.h
include/llvm/ADT/ScopedHashTable.h
include/llvm/ADT/SetOperations.h
include/llvm/ADT/SetVector.h
+include/llvm/ADT/SmallBitVector.h
include/llvm/ADT/SmallPtrSet.h
include/llvm/ADT/SmallSet.h
include/llvm/ADT/SmallString.h
@@ -66,15 +66,15 @@ include/llvm/ADT/StringExtras.h
include/llvm/ADT/StringMap.h
include/llvm/ADT/StringRef.h
include/llvm/ADT/StringSet.h
+include/llvm/ADT/StringSwitch.h
include/llvm/ADT/Trie.h
include/llvm/ADT/Triple.h
include/llvm/ADT/Twine.h
include/llvm/ADT/UniqueVector.h
+include/llvm/ADT/ValueMap.h
include/llvm/ADT/VectorExtras.h
include/llvm/ADT/ilist.h
include/llvm/ADT/ilist_node.h
-include/llvm/ADT/iterator.cmake
-include/llvm/ADT/iterator.h
include/llvm/AbstractTypeUser.h
include/llvm/Analysis/AliasAnalysis.h
include/llvm/Analysis/AliasSetTracker.h
@@ -83,22 +83,28 @@ include/llvm/Analysis/CallGraph.h
include/llvm/Analysis/CaptureTracking.h
include/llvm/Analysis/ConstantFolding.h
include/llvm/Analysis/ConstantsScanner.h
+include/llvm/Analysis/DOTGraphTraitsPass.h
include/llvm/Analysis/DebugInfo.h
+include/llvm/Analysis/DomPrinter.h
include/llvm/Analysis/DominatorInternals.h
include/llvm/Analysis/Dominators.h
include/llvm/Analysis/FindUsedTypes.h
include/llvm/Analysis/IVUsers.h
+include/llvm/Analysis/InlineCost.h
+include/llvm/Analysis/InstructionSimplify.h
include/llvm/Analysis/Interval.h
include/llvm/Analysis/IntervalIterator.h
include/llvm/Analysis/IntervalPartition.h
+include/llvm/Analysis/LazyValueInfo.h
include/llvm/Analysis/LibCallAliasAnalysis.h
include/llvm/Analysis/LibCallSemantics.h
include/llvm/Analysis/LiveValues.h
include/llvm/Analysis/LoopDependenceAnalysis.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopPass.h
-include/llvm/Analysis/LoopVR.h
+include/llvm/Analysis/MemoryBuiltins.h
include/llvm/Analysis/MemoryDependenceAnalysis.h
+include/llvm/Analysis/PHITransAddr.h
include/llvm/Analysis/Passes.h
include/llvm/Analysis/PointerTracking.h
include/llvm/Analysis/PostDominators.h
@@ -124,25 +130,18 @@ include/llvm/Bitcode/Archive.h
include/llvm/Bitcode/BitCodes.h
include/llvm/Bitcode/BitstreamReader.h
include/llvm/Bitcode/BitstreamWriter.h
-include/llvm/Bitcode/Deserialize.h
include/llvm/Bitcode/LLVMBitCodes.h
include/llvm/Bitcode/ReaderWriter.h
-include/llvm/Bitcode/Serialization.h
-include/llvm/Bitcode/SerializationFwd.h
-include/llvm/Bitcode/Serialize.h
include/llvm/CMakeLists.txt
include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/AsmPrinter.h
include/llvm/CodeGen/BinaryObject.h
-include/llvm/CodeGen/BreakCriticalMachineEdge.h
+include/llvm/CodeGen/CalcSpillWeights.h
include/llvm/CodeGen/CallingConvLower.h
-include/llvm/CodeGen/DAGISelHeader.h
-include/llvm/CodeGen/Dump.h
include/llvm/CodeGen/DwarfWriter.h
include/llvm/CodeGen/ELFRelocation.h
include/llvm/CodeGen/FastISel.h
-include/llvm/CodeGen/FileWriters.h
include/llvm/CodeGen/GCMetadata.h
include/llvm/CodeGen/GCMetadataPrinter.h
include/llvm/CodeGen/GCStrategy.h
@@ -150,7 +149,6 @@ include/llvm/CodeGen/GCs.h
include/llvm/CodeGen/IntrinsicLowering.h
include/llvm/CodeGen/JITCodeEmitter.h
include/llvm/CodeGen/LatencyPriorityQueue.h
-include/llvm/CodeGen/LazyLiveness.h
include/llvm/CodeGen/LinkAllAsmWriterComponents.h
include/llvm/CodeGen/LinkAllCodegenComponents.h
include/llvm/CodeGen/LiveInterval.h
@@ -174,12 +172,15 @@ include/llvm/CodeGen/MachineLocation.h
include/llvm/CodeGen/MachineLoopInfo.h
include/llvm/CodeGen/MachineMemOperand.h
include/llvm/CodeGen/MachineModuleInfo.h
+include/llvm/CodeGen/MachineModuleInfoImpls.h
include/llvm/CodeGen/MachineOperand.h
include/llvm/CodeGen/MachinePassRegistry.h
include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
+include/llvm/CodeGen/MachineSSAUpdater.h
include/llvm/CodeGen/ObjectCodeEmitter.h
include/llvm/CodeGen/Passes.h
+include/llvm/CodeGen/ProcessImplicitDefs.h
include/llvm/CodeGen/PseudoSourceValue.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterCoalescer.h
@@ -191,6 +192,8 @@ include/llvm/CodeGen/SchedulerRegistry.h
include/llvm/CodeGen/SelectionDAG.h
include/llvm/CodeGen/SelectionDAGISel.h
include/llvm/CodeGen/SelectionDAGNodes.h
+include/llvm/CodeGen/SlotIndexes.h
+include/llvm/CodeGen/TargetLoweringObjectFileImpl.h
include/llvm/CodeGen/ValueTypes.h
include/llvm/CodeGen/ValueTypes.td
include/llvm/CompilerDriver/Action.h
@@ -205,18 +208,12 @@ include/llvm/CompilerDriver/Plugin.h
include/llvm/CompilerDriver/Tool.h
include/llvm/Config/AsmParsers.def
include/llvm/Config/AsmPrinters.def
+include/llvm/Config/Disassemblers.def
include/llvm/Config/Targets.def
-include/llvm/Config/alloca.h
include/llvm/Config/config.h
include/llvm/Config/config.h.cmake
include/llvm/Constant.h
include/llvm/Constants.h
-include/llvm/Debugger/Debugger.h
-include/llvm/Debugger/InferiorProcess.h
-include/llvm/Debugger/ProgramInfo.h
-include/llvm/Debugger/RuntimeInfo.h
-include/llvm/Debugger/SourceFile.h
-include/llvm/Debugger/SourceLanguage.h
include/llvm/DerivedTypes.h
include/llvm/ExecutionEngine/ExecutionEngine.h
include/llvm/ExecutionEngine/GenericValue.h
@@ -225,6 +222,7 @@ include/llvm/ExecutionEngine/JIT.h
include/llvm/ExecutionEngine/JITEventListener.h
include/llvm/ExecutionEngine/JITMemoryManager.h
include/llvm/Function.h
+include/llvm/GVMaterializer.h
include/llvm/GlobalAlias.h
include/llvm/GlobalValue.h
include/llvm/GlobalVariable.h
@@ -239,7 +237,6 @@ include/llvm/Intrinsics.h
include/llvm/Intrinsics.td
include/llvm/IntrinsicsARM.td
include/llvm/IntrinsicsAlpha.td
-include/llvm/IntrinsicsBlackfin.td
include/llvm/IntrinsicsCellSPU.td
include/llvm/IntrinsicsPowerPC.td
include/llvm/IntrinsicsX86.td
@@ -248,11 +245,24 @@ include/llvm/LLVMContext.h
include/llvm/LinkAllPasses.h
include/llvm/LinkAllVMCore.h
include/llvm/Linker.h
-include/llvm/MC/MCAsmLexer.h
-include/llvm/MC/MCAsmParser.h
+include/llvm/MC/MCAsmInfo.h
+include/llvm/MC/MCAsmInfoCOFF.h
+include/llvm/MC/MCAsmInfoDarwin.h
include/llvm/MC/MCAssembler.h
+include/llvm/MC/MCCodeEmitter.h
include/llvm/MC/MCContext.h
+include/llvm/MC/MCDirectives.h
+include/llvm/MC/MCDisassembler.h
+include/llvm/MC/MCExpr.h
+include/llvm/MC/MCFixup.h
include/llvm/MC/MCInst.h
+include/llvm/MC/MCInstPrinter.h
+include/llvm/MC/MCParser/AsmCond.h
+include/llvm/MC/MCParser/AsmLexer.h
+include/llvm/MC/MCParser/AsmParser.h
+include/llvm/MC/MCParser/MCAsmLexer.h
+include/llvm/MC/MCParser/MCAsmParser.h
+include/llvm/MC/MCParser/MCParsedAsmOperand.h
include/llvm/MC/MCSection.h
include/llvm/MC/MCSectionELF.h
include/llvm/MC/MCSectionMachO.h
@@ -262,7 +272,6 @@ include/llvm/MC/MCValue.h
include/llvm/MC/SectionKind.h
include/llvm/Metadata.h
include/llvm/Module.h
-include/llvm/ModuleProvider.h
include/llvm/OperandTraits.h
include/llvm/Operator.h
include/llvm/Pass.h
@@ -270,7 +279,6 @@ include/llvm/PassAnalysisSupport.h
include/llvm/PassManager.h
include/llvm/PassManagers.h
include/llvm/PassSupport.h
-include/llvm/Support/AIXDataTypesFix.h
include/llvm/Support/AlignOf.h
include/llvm/Support/Allocator.h
include/llvm/Support/CFG.h
@@ -282,8 +290,6 @@ include/llvm/Support/ConstantFolder.h
include/llvm/Support/ConstantRange.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataFlow.h
-include/llvm/Support/DataTypes.h
-include/llvm/Support/DataTypes.h.cmake
include/llvm/Support/Debug.h
include/llvm/Support/DebugLoc.h
include/llvm/Support/Dwarf.h
@@ -296,11 +302,12 @@ include/llvm/Support/FormattedStream.h
include/llvm/Support/GetElementPtrTypeIterator.h
include/llvm/Support/GraphWriter.h
include/llvm/Support/IRBuilder.h
+include/llvm/Support/IRReader.h
include/llvm/Support/InstIterator.h
include/llvm/Support/InstVisitor.h
include/llvm/Support/LeakDetector.h
+include/llvm/Support/MachO.h
include/llvm/Support/ManagedStatic.h
-include/llvm/Support/Mangler.h
include/llvm/Support/MathExtras.h
include/llvm/Support/MemoryBuffer.h
include/llvm/Support/MemoryObject.h
@@ -315,24 +322,30 @@ include/llvm/Support/PredIteratorCache.h
include/llvm/Support/PrettyStackTrace.h
include/llvm/Support/Recycler.h
include/llvm/Support/RecyclingAllocator.h
+include/llvm/Support/Regex.h
include/llvm/Support/Registry.h
include/llvm/Support/RegistryParser.h
+include/llvm/Support/SMLoc.h
include/llvm/Support/SlowOperationInformer.h
include/llvm/Support/SourceMgr.h
include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/StandardPasses.h
-include/llvm/Support/Streams.h
include/llvm/Support/StringPool.h
include/llvm/Support/SystemUtils.h
include/llvm/Support/TargetFolder.h
include/llvm/Support/Timer.h
include/llvm/Support/TypeBuilder.h
include/llvm/Support/ValueHandle.h
+include/llvm/Support/circular_raw_ostream.h
+include/llvm/Support/raw_os_ostream.h
include/llvm/Support/raw_ostream.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTableListTraits.h
+include/llvm/System/AIXDataTypesFix.h
include/llvm/System/Alarm.h
include/llvm/System/Atomic.h
+include/llvm/System/DataTypes.h
+include/llvm/System/DataTypes.h.cmake
include/llvm/System/Disassembler.h
include/llvm/System/DynamicLibrary.h
include/llvm/System/Errno.h
@@ -350,11 +363,11 @@ include/llvm/System/Solaris.h
include/llvm/System/ThreadLocal.h
include/llvm/System/Threading.h
include/llvm/System/TimeValue.h
-include/llvm/Target/COFFTargetAsmInfo.h
-include/llvm/Target/DarwinTargetAsmInfo.h
+include/llvm/Target/Mangler.h
include/llvm/Target/SubtargetFeature.h
include/llvm/Target/Target.td
-include/llvm/Target/TargetAsmInfo.h
+include/llvm/Target/TargetAsmBackend.h
+include/llvm/Target/TargetAsmLexer.h
include/llvm/Target/TargetAsmParser.h
include/llvm/Target/TargetCallingConv.td
include/llvm/Target/TargetData.h
@@ -367,8 +380,8 @@ include/llvm/Target/TargetIntrinsicInfo.h
include/llvm/Target/TargetJITInfo.h
include/llvm/Target/TargetLowering.h
include/llvm/Target/TargetLoweringObjectFile.h
-include/llvm/Target/TargetMachOWriterInfo.h
include/llvm/Target/TargetMachine.h
+include/llvm/Target/TargetOpcodes.h
include/llvm/Target/TargetOptions.h
include/llvm/Target/TargetRegisterInfo.h
include/llvm/Target/TargetRegistry.h
@@ -384,11 +397,12 @@ include/llvm/Transforms/Scalar.h
include/llvm/Transforms/Utils/AddrModeMatcher.h
include/llvm/Transforms/Utils/BasicBlockUtils.h
include/llvm/Transforms/Utils/BasicInliner.h
+include/llvm/Transforms/Utils/BuildLibCalls.h
include/llvm/Transforms/Utils/Cloning.h
include/llvm/Transforms/Utils/FunctionUtils.h
-include/llvm/Transforms/Utils/InlineCost.h
include/llvm/Transforms/Utils/Local.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
+include/llvm/Transforms/Utils/SSAUpdater.h
include/llvm/Transforms/Utils/SSI.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
include/llvm/Transforms/Utils/UnrollLoop.h
@@ -400,6 +414,9 @@ include/llvm/User.h
include/llvm/Value.h
include/llvm/ValueSymbolTable.h
lib/libCompilerDriver.a
+lib/libEnhancedDisassembly.a
+lib/libEnhancedDisassembly.so
+lib/libLLVMARMAsmParser.a
lib/libLLVMARMAsmPrinter.a
lib/libLLVMARMCodeGen.a
lib/libLLVMARMInfo.a
@@ -424,14 +441,18 @@ lib/libLLVMCodeGen.a
lib/libLLVMCore.a
lib/libLLVMCppBackend.a
lib/libLLVMCppBackendInfo.a
-lib/libLLVMDebugger.a
lib/libLLVMExecutionEngine.a
lib/libLLVMHello.so
+lib/libLLVMInstCombine.a
lib/libLLVMInstrumentation.a
lib/libLLVMInterpreter.a
lib/libLLVMJIT.a
lib/libLLVMLinker.a
+lib/libLLVMMBlazeAsmPrinter.a
+lib/libLLVMMBlazeCodeGen.a
+lib/libLLVMMBlazeInfo.a
lib/libLLVMMC.a
+lib/libLLVMMCParser.a
lib/libLLVMMSIL.a
lib/libLLVMMSILInfo.a
lib/libLLVMMSP430AsmPrinter.a
@@ -461,14 +482,17 @@ lib/libLLVMTransformUtils.a
lib/libLLVMX86AsmParser.a
lib/libLLVMX86AsmPrinter.a
lib/libLLVMX86CodeGen.a
+lib/libLLVMX86Disassembler.a
lib/libLLVMX86Info.a
lib/libLLVMXCoreAsmPrinter.a
lib/libLLVMXCoreCodeGen.a
lib/libLLVMXCoreInfo.a
lib/libLLVMipa.a
lib/libLLVMipo.a
+lib/libLLVMpic16passes.a
lib/libLTO.a
lib/libLTO.so
+lib/libUnitTestMain.a
lib/libplugin_llvmc_Base.a
lib/libplugin_llvmc_Clang.a
lib/libprofile_rt.so
@@ -483,13 +507,13 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/FileCheck.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/bugpoint.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/lit.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llc.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/lli.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-ar.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-as.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-bcanalyzer.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-config.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-db.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-dis.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-extract.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-ld.html
@@ -507,6 +531,7 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/CompilerDriver.html
%%PORTDOCS%%%%DOCSDIR%%/html/CompilerDriverTutorial.html
%%PORTDOCS%%%%DOCSDIR%%/html/CompilerWriterInfo.html
+%%PORTDOCS%%%%DOCSDIR%%/html/DebuggingJITedCode.html
%%PORTDOCS%%%%DOCSDIR%%/html/DeveloperPolicy.html
%%PORTDOCS%%%%DOCSDIR%%/html/ExceptionHandling.html
%%PORTDOCS%%%%DOCSDIR%%/html/ExtendingLLVM.html
@@ -523,10 +548,10 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/Lexicon.html
%%PORTDOCS%%%%DOCSDIR%%/html/LinkTimeOptimization.html
%%PORTDOCS%%%%DOCSDIR%%/html/MakefileGuide.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Packaging.html
%%PORTDOCS%%%%DOCSDIR%%/html/Passes.html
%%PORTDOCS%%%%DOCSDIR%%/html/ProgrammersManual.html
%%PORTDOCS%%%%DOCSDIR%%/html/Projects.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ReleaseNotes-2.6.html
%%PORTDOCS%%%%DOCSDIR%%/html/ReleaseNotes.html
%%PORTDOCS%%%%DOCSDIR%%/html/SourceLevelDebugging.html
%%PORTDOCS%%%%DOCSDIR%%/html/SystemLibrary.html
@@ -543,8 +568,6 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/img/venusflytrap.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/llvm.css
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/JITTutorial1.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/JITTutorial2.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl1.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl2.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl3.html
@@ -563,13 +586,13 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/index.html
%%PORTDOCS%%%%DOCSDIR%%/ps/FileCheck.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/bugpoint.ps
+%%PORTDOCS%%%%DOCSDIR%%/ps/lit.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llc.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/lli.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-ar.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-as.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-bcanalyzer.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-config.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-db.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-dis.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-extract.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-ld.ps
@@ -588,9 +611,9 @@ lib/libprofile_rt.so
@dirrm include/llvm/Target
@dirrm include/llvm/System
@dirrm include/llvm/Support
+@dirrm include/llvm/MC/MCParser
@dirrm include/llvm/MC
@dirrm include/llvm/ExecutionEngine
-@dirrm include/llvm/Debugger
@dirrm include/llvm/Config
@dirrm include/llvm/CompilerDriver
@dirrm include/llvm/CodeGen