aboutsummaryrefslogtreecommitdiff
path: root/devel/lmdbg
diff options
context:
space:
mode:
authorFrank J. Laszlo <laszlof@FreeBSD.org>2009-05-19 13:14:17 +0000
committerFrank J. Laszlo <laszlof@FreeBSD.org>2009-05-19 13:14:17 +0000
commit421e7a3ae74c3d0b0a1de2412a6958e860697a73 (patch)
tree5576d251495c273546983e4b3be47c034623492f /devel/lmdbg
parentfeca62211a62d7af83af41cb63266f62b13b8fe0 (diff)
-Added port: devel/lmdbg
LMDBG is a collection of small tools for collecting and analyzing the logs of malloc/realloc/memalign/free function calls. Unlike many others, LMDBG does not provide any way to detect overruns of the boundaries of malloc() memory allocations, as this is not the goal. Like most other malloc debuggers, LMDBG allows detecting memory leaks and double frees. However, unlike others, LMDBG generates full stacktraces and separates the logging process from analysis, thus allowing you to analyze an application on a per-module basis. WWW: http://sourceforge.net/projects/lmdbg Author: Aleksey Cheusov (cheusov at users.sourceforge.net) PR: ports/134617 Submitted by: Mikolaj Golub <to.my.trociny@gmail.com>
Notes
Notes: svn path=/head/; revision=234203
Diffstat (limited to 'devel/lmdbg')
-rw-r--r--devel/lmdbg/Makefile29
-rw-r--r--devel/lmdbg/distinfo3
-rw-r--r--devel/lmdbg/pkg-descr11
-rw-r--r--devel/lmdbg/pkg-plist14
4 files changed, 57 insertions, 0 deletions
diff --git a/devel/lmdbg/Makefile b/devel/lmdbg/Makefile
new file mode 100644
index 000000000000..51c9bb213b25
--- /dev/null
+++ b/devel/lmdbg/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: lmdbg
+# Date created: 14 March 2009
+# Whom: Mikolaj Golub <to.my.trociny@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lmdbg
+PORTVERSION= 0.9.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= to.my.trociny@gmail.com
+COMMENT= Lightweight malloc debugger
+
+HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/NEWS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/ChangeLog ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/TODO ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/lmdbg/distinfo b/devel/lmdbg/distinfo
new file mode 100644
index 000000000000..a32e339fbb97
--- /dev/null
+++ b/devel/lmdbg/distinfo
@@ -0,0 +1,3 @@
+MD5 (lmdbg-0.9.0.tar.gz) = 6bfc0710cf6726dcc674697d93528742
+SHA256 (lmdbg-0.9.0.tar.gz) = 10c1bad1dbcf456591bc5324ea0d4d2648e42f56fbd94d996e3a690818e4913a
+SIZE (lmdbg-0.9.0.tar.gz) = 79069
diff --git a/devel/lmdbg/pkg-descr b/devel/lmdbg/pkg-descr
new file mode 100644
index 000000000000..f1165504ecf3
--- /dev/null
+++ b/devel/lmdbg/pkg-descr
@@ -0,0 +1,11 @@
+LMDBG is a collection of small tools for collecting and analyzing
+the logs of malloc/realloc/memalign/free function calls. Unlike many
+others, LMDBG does not provide any way to detect overruns of the
+boundaries of malloc() memory allocations, as this is not the goal.
+Like most other malloc debuggers, LMDBG allows detecting memory leaks
+and double frees. However, unlike others, LMDBG generates full
+stacktraces and separates the logging process from analysis, thus
+allowing you to analyze an application on a per-module basis.
+
+WWW: http://sourceforge.net/projects/lmdbg
+Author: Aleksey Cheusov (cheusov at users.sourceforge.net)
diff --git a/devel/lmdbg/pkg-plist b/devel/lmdbg/pkg-plist
new file mode 100644
index 000000000000..1a5d9d68a465
--- /dev/null
+++ b/devel/lmdbg/pkg-plist
@@ -0,0 +1,14 @@
+lib/liblmdbg.a
+lib/liblmdbg.la
+lib/liblmdbg.so.0
+lib/liblmdbg.so
+bin/lmdbg-run
+bin/lmdbg-sym
+bin/lmdbg-leaks
+bin/lmdbg-sysleaks
+bin/lmdbg-leak-check
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%