aboutsummaryrefslogtreecommitdiff
path: root/devel/log4cpp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-12-17 20:46:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-12-17 20:46:56 +0000
commit1ac6e82c7d492b5bffa04e88cf374de738e52f65 (patch)
treea37f08f508d5eb4d9f82c7d060be46af253127be /devel/log4cpp
parent91d75201963095abe8f973754a36aa6d30f67e52 (diff)
downloadports-1ac6e82c7d492b5bffa04e88cf374de738e52f65.tar.gz
ports-1ac6e82c7d492b5bffa04e88cf374de738e52f65.zip
Notes
Diffstat (limited to 'devel/log4cpp')
-rw-r--r--devel/log4cpp/Makefile10
-rw-r--r--devel/log4cpp/distinfo6
-rw-r--r--devel/log4cpp/files/patch-config::ltmain.sh41
-rw-r--r--devel/log4cpp/files/patch-doc_Makefile.in10
-rw-r--r--devel/log4cpp/pkg-plist4
5 files changed, 18 insertions, 53 deletions
diff --git a/devel/log4cpp/Makefile b/devel/log4cpp/Makefile
index 177c6db85dd1..5461ac586083 100644
--- a/devel/log4cpp/Makefile
+++ b/devel/log4cpp/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= log4cpp
-PORTVERSION= 0.3.4b
+DISTVERSION= 0.3.5rc3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A library of C++ classes for flexible logging
+USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
@@ -27,7 +28,7 @@ USE_LDCONFIG= yes
.if exists (${LOCALBASE}/bin/doxygen) || !defined (NOPORTDOCS)
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
-MAN3= log4cpp.3 log4cpp::Appender.3 log4cpp::AppenderSkeleton.3\
+MAN3= log4cpp.3 log4cpp::AbortAppender.3 log4cpp::Appender.3 log4cpp::AppenderSkeleton.3\
log4cpp::BasicConfigurator.3 log4cpp::BasicLayout.3 log4cpp::Category.3\
log4cpp::CategoryNameComponent.3 log4cpp::CategoryStream.3\
log4cpp::ConfigureFailure.3 log4cpp::FileAppender.3 log4cpp::Filter.3\
@@ -46,8 +47,8 @@ MAN3= log4cpp.3 log4cpp::Appender.3 log4cpp::AppenderSkeleton.3\
log4cpp::SimpleLayout.3 log4cpp::StringLiteralComponent.3\
log4cpp::StringQueueAppender.3 log4cpp::StringUtil.3\
log4cpp::SyslogAppender.3 log4cpp::ThreadNameComponent.3\
- log4cpp::TimeStamp.3 log4cpp::TimeStampComponent.3\
- log4cpp::Win32DebugAppender.3 log4cpp::threading.3\
+ log4cpp::TimeStamp.3 log4cpp::TimeStampComponent.3 log4cpp::width.3\
+ log4cpp::Win32DebugAppender.3 log4cpp::tab.3 log4cpp::threading.3\
log4cpp::threading::MSMutex.3 log4cpp::threading::MSScopedLock.3\
log4cpp::threading::Mutex.3 log4cpp::threading::ScopedLock.3\
log4cpp::threading::ThreadLocalDataHolder.3
@@ -68,5 +69,6 @@ this build by hitting CTRL+C and re-run the installation with -DNOPORTDOCS | ${F
post-patch:
@${REINPLACE_CMD} -e 's| -pedantic||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
.include <bsd.port.post.mk>
diff --git a/devel/log4cpp/distinfo b/devel/log4cpp/distinfo
index 5de39dd92944..ba60f068fc82 100644
--- a/devel/log4cpp/distinfo
+++ b/devel/log4cpp/distinfo
@@ -1,3 +1,3 @@
-MD5 (log4cpp-0.3.4b.tar.gz) = 8051f012fcc58173e8015710d449457a
-SHA256 (log4cpp-0.3.4b.tar.gz) = 030f7cb38e0fe2c6cea8983bddba8d47c13a76c96c1327f394254dcbfd47efd5
-SIZE (log4cpp-0.3.4b.tar.gz) = 323195
+MD5 (log4cpp-0.3.5rc3.tar.gz) = 13177d6bf50e403cc72b15e903326392
+SHA256 (log4cpp-0.3.5rc3.tar.gz) = 2bcfefc7a59cedd0e3754ed796fa025081e66a2bca5120687c8605ce417325e8
+SIZE (log4cpp-0.3.5rc3.tar.gz) = 472249
diff --git a/devel/log4cpp/files/patch-config::ltmain.sh b/devel/log4cpp/files/patch-config::ltmain.sh
deleted file mode 100644
index 9b5e8dfc8472..000000000000
--- a/devel/log4cpp/files/patch-config::ltmain.sh
+++ /dev/null
@@ -1,41 +0,0 @@
---- config/ltmain.sh.orig Tue Aug 20 10:13:37 2002
-+++ config/ltmain.sh Sun Dec 1 08:55:09 2002
-@@ -1056,14 +1056,14 @@
- # These systems don't actually have a C library (as such)
- test "X$arg" = "X-lc" && continue
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- test "X$arg" = "X-lc" && continue
- ;;
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -2499,7 +2499,7 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
- *)
-@@ -4286,10 +4286,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/log4cpp/files/patch-doc_Makefile.in b/devel/log4cpp/files/patch-doc_Makefile.in
index 0deaab037494..8a84a3609b7c 100644
--- a/devel/log4cpp/files/patch-doc_Makefile.in
+++ b/devel/log4cpp/files/patch-doc_Makefile.in
@@ -1,11 +1,11 @@
---- doc/Makefile.in.orig Tue Nov 29 17:28:32 2005
-+++ doc/Makefile.in Tue Nov 29 17:33:03 2005
-@@ -96,7 +96,7 @@
+--- doc/Makefile.in.orig Fri Jul 29 14:25:28 2005
++++ doc/Makefile.in Sat Dec 9 00:03:10 2006
+@@ -182,7 +182,7 @@
+ target_alias = @target_alias@
SUBDIRS = html
-
man3dir = $(mandir)/man3
-docdir = $(prefix)/doc/@PACKAGE_TARNAME@-@PACKAGE_VERSION@
+docdir = $(prefix)/share/doc/@PACKAGE_TARNAME@
-
EXTRA_DIST = \
mainPage.txt
+
diff --git a/devel/log4cpp/pkg-plist b/devel/log4cpp/pkg-plist
index ab256dd2f0e2..c49fc919c596 100644
--- a/devel/log4cpp/pkg-plist
+++ b/devel/log4cpp/pkg-plist
@@ -1,4 +1,5 @@
bin/log4cpp-config
+include/log4cpp/AbortAppender.hh
include/log4cpp/Appender.hh
include/log4cpp/AppenderSkeleton.hh
include/log4cpp/BasicConfigurator.hh
@@ -15,6 +16,7 @@ include/log4cpp/IdsaAppender.hh
include/log4cpp/Layout.hh
include/log4cpp/LayoutAppender.hh
include/log4cpp/LoggingEvent.hh
+include/log4cpp/Manipulator.hh
include/log4cpp/NDC.hh
include/log4cpp/NTEventLogAppender.hh
include/log4cpp/OstreamAppender.hh
@@ -40,8 +42,10 @@ include/log4cpp/threading/OmniThreads.hh
include/log4cpp/threading/PThreads.hh
include/log4cpp/threading/Threading.hh
lib/liblog4cpp.a
+lib/liblog4cpp.la
lib/liblog4cpp.so
lib/liblog4cpp.so.4
+libdata/pkgconfig/log4cpp.pc
share/aclocal/log4cpp.m4
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/default.css