aboutsummaryrefslogtreecommitdiff
path: root/devel/log4net/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-01-01 18:25:01 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-01-01 18:25:01 +0000
commit151197ea4e1494e98d2ecd2c829679b2d12484c8 (patch)
treea9a05b0da5cfb3776a83a10f96fbdfd72ceebc03 /devel/log4net/Makefile
parent2c5e3bfc37c6bf7916eb3d0ff551c1952043d27e (diff)
Notes
Diffstat (limited to 'devel/log4net/Makefile')
-rw-r--r--devel/log4net/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/devel/log4net/Makefile b/devel/log4net/Makefile
new file mode 100644
index 000000000000..798c24c62ce8
--- /dev/null
+++ b/devel/log4net/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: log4net
+# Date created: July 8th, 2005
+# Whom: Christopher Nehren <apeiron@coitusmentis.info>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.13 2006/10/10 00:26:57 killfill Exp $
+#
+
+PORTNAME= log4net
+PORTVERSION= 1.2.10
+PORTREVISION= 1
+CATEGORIES= devel
+MASTER_SITES= APACHE
+MASTER_SITE_SUBDIR= incubator/log4net/${PORTVERSION}
+DISTNAME= incubating-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= Port for .NET of the Apache Logging Services project
+
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
+RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+SUB_FILES= log4net.pc
+SUB_LIST+= PORTVERSION=${PORTVERSION}
+
+.if !defined (NOPORTDOCS)
+PORTDOCS= *
+.endif
+.if !defined (NOPORTEXAMPLES)
+PORTEXAMPLES= *
+.endif
+
+do-install:
+ @(cd ${INSTALL_WRKSRC}/bin/mono/2.0/release && ${SETENV} MONO_SHARED_DIR=${WRKDIR} ${LOCALBASE}/bin/gacutil /root ${PREFIX}/lib/ /gacdir ${PREFIX}/lib /package 2.0 /i log4net.dll)
+ ${INSTALL_DATA} ${WRKDIR}/log4net.pc ${PREFIX}/libdata/pkgconfig/log4net.pc
+.if !defined (NOPORTDOCS)
+ @${ECHO_CMD} "Installing documentation..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+.if !defined (NOPORTEXAMPLES)
+ @${ECHO_CMD} "Installing examples..."
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+.endif
+
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+.include <bsd.port.mk>