aboutsummaryrefslogtreecommitdiff
path: root/devel/loki
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-03-03 12:05:05 +0000
committerWen Heping <wen@FreeBSD.org>2010-03-03 12:05:05 +0000
commit4b012c89eefe04bf171bb9edbe91d64086f1c4b3 (patch)
tree3051522d94cd929fe3e1186ef499eddcb918160d /devel/loki
parentb05e8e409c04592d15f58b0c975917e08317bfe4 (diff)
downloadports-4b012c89eefe04bf171bb9edbe91d64086f1c4b3.tar.gz
ports-4b012c89eefe04bf171bb9edbe91d64086f1c4b3.zip
Notes
Diffstat (limited to 'devel/loki')
-rw-r--r--devel/loki/Makefile2
-rw-r--r--devel/loki/distinfo6
-rw-r--r--devel/loki/files/patch-Makefile20
-rw-r--r--devel/loki/files/patch-Makefile.common11
-rw-r--r--devel/loki/files/patch-include-loki-Threads.h13
-rw-r--r--devel/loki/files/patch-src-Makefile33
-rw-r--r--devel/loki/files/patch-test-Makefile12
-rw-r--r--devel/loki/files/patch-test-SingletonDll-Makefile18
-rw-r--r--devel/loki/files/patch-test-SmartPtr-main.cpp11
-rw-r--r--devel/loki/files/patch-test_SingletonDll_Makefile25
-rw-r--r--devel/loki/pkg-plist10
11 files changed, 62 insertions, 99 deletions
diff --git a/devel/loki/Makefile b/devel/loki/Makefile
index 0218e972575f..b8bca7cd201d 100644
--- a/devel/loki/Makefile
+++ b/devel/loki/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= loki
-PORTVERSION= 0.1.5
+PORTVERSION= 0.1.7
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}-lib/Loki/Loki%20${PORTVERSION}
diff --git a/devel/loki/distinfo b/devel/loki/distinfo
index 23db439947ea..11bcfc2bbf1e 100644
--- a/devel/loki/distinfo
+++ b/devel/loki/distinfo
@@ -1,3 +1,3 @@
-MD5 (loki-0.1.5.tar.gz) = f246e9e91b46d4e55ce36193984697e6
-SHA256 (loki-0.1.5.tar.gz) = 01ae8b65e286a64017a9fa2eb633d70b5f029b03bb4682f3105148165e3345f5
-SIZE (loki-0.1.5.tar.gz) = 324972
+MD5 (loki-0.1.7.tar.gz) = 005d79581fbe888ceabd65d46c99c8b1
+SHA256 (loki-0.1.7.tar.gz) = 0f185478552009cd3f82a4ef3038fd6080d293308c15a6501284ba6092b21cf6
+SIZE (loki-0.1.7.tar.gz) = 520453
diff --git a/devel/loki/files/patch-Makefile b/devel/loki/files/patch-Makefile
deleted file mode 100644
index 852a2a2ddc92..000000000000
--- a/devel/loki/files/patch-Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.orig Sun Jan 28 02:20:26 2007
-+++ Makefile Sun Jan 28 02:24:49 2007
-@@ -2,7 +2,7 @@
- export OS ?= $(shell uname -s)
-
- export CXXWARNFLAGS = -Wall -Wold-style-cast -Wundef -Wsign-compare -Wconversion -Wpointer-arith -pedantic
--export CXXFLAGS = $(CXXWARNFLAGS) -g -O2
-+export CXXFLAGS += $(CXXWARNFLAGS) -fPIC
-
- .PHONY: all build-static build-shared check clean distclean
- all: build-static build-shared check
-@@ -23,7 +23,7 @@
- $(MAKE) -C src distclean
-
- ifneq ($(OS),Windows)
--export prefix ?= /usr
-+export prefix ?= ${PREFIX}
-
- .PHONY: install install-static
- install:
diff --git a/devel/loki/files/patch-Makefile.common b/devel/loki/files/patch-Makefile.common
new file mode 100644
index 000000000000..af7ef74c0c26
--- /dev/null
+++ b/devel/loki/files/patch-Makefile.common
@@ -0,0 +1,11 @@
+$FreeBSD$
+
+--- Makefile.common.orig
++++ Makefile.common
+@@ -4,4 +4,4 @@
+ CXXWARNFLAGS := -Wall -Wold-style-cast -Wundef -Wsign-compare -Wconversion -Wpointer-arith -pedantic
+ CXXFLAGS := $(CXXWARNFLAGS) -g -O2
+
+-prefix := /usr
++prefix := ${PREFIX}
+
diff --git a/devel/loki/files/patch-include-loki-Threads.h b/devel/loki/files/patch-include-loki-Threads.h
deleted file mode 100644
index d74da8b69bdf..000000000000
--- a/devel/loki/files/patch-include-loki-Threads.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- include/loki/Threads.h.orig Mon Nov 6 20:39:26 2006
-+++ include/loki/Threads.h Mon Nov 6 20:42:26 2006
-@@ -51,8 +51,8 @@
-
- #include <cassert>
-
--#if defined(LOKI_CLASS_LEVEL_THREADING) || defined(LOKI_OBJECT_LEVEL_THREADING)
--
-+//#if defined(LOKI_CLASS_LEVEL_THREADING) || defined(LOKI_OBJECT_LEVEL_THREADING)
-+#if 0
- #define LOKI_DEFAULT_THREADING_NO_OBJ_LEVEL ::Loki::ClassLevelLockable
-
- #if defined(LOKI_CLASS_LEVEL_THREADING) && !defined(LOKI_OBJECT_LEVEL_THREADING)
diff --git a/devel/loki/files/patch-src-Makefile b/devel/loki/files/patch-src-Makefile
index bd786736ef51..8c30b94fab1c 100644
--- a/devel/loki/files/patch-src-Makefile
+++ b/devel/loki/files/patch-src-Makefile
@@ -1,21 +1,14 @@
---- src/Makefile.orig Sun Jan 28 01:57:12 2007
-+++ src/Makefile Sun Jan 28 01:59:57 2007
-@@ -20,10 +20,18 @@
- LDLIBS = -lpthread
- RESULT_DIR = ../lib/
+
+$FreeBSD$
+
+--- src/Makefile.orig
++++ src/Makefile
+@@ -20,7 +20,7 @@
+ override LDFLAGS += --shared -Wl,-soname=$(SHARED_LIB_VERSIONED) -fPIC
+ LDLIBS := -lpthread
else
-+ifeq ($(OS), FreeBSD)
-+ SHARED_LIB_BASE = libloki.so
-+ SHARED_LIB_VERSIONED = libloki.so.0
-+ LDFLAGS = --shared -Wl,-soname=$(SHARED_LIB_VERSIONED)
-+ LDLIBS = -pthread
-+ RESULT_DIR = ../lib/
-+else
- SHARED_LIB_BASE = libloki.dll
- LDFLAGS = --shared
- LDLIBS =
- RESULT_DIR = ../lib/
-+endif
- endif
- endif
-
+-ifeq ($(OS), GNU/kFreeBSD)
++ifeq ($(OS), $(filter $(OS),GNU/kFreeBSD FreeBSD))
+ SHARED_LIB_BASE := libloki.so
+ SHARED_LIB_VERSIONED := libloki.so.$(VERSION)
+ override LDFLAGS += --shared -Wl,-soname=$(SHARED_LIB_VERSIONED) -fPIC
diff --git a/devel/loki/files/patch-test-Makefile b/devel/loki/files/patch-test-Makefile
deleted file mode 100644
index 2f66708ab1b3..000000000000
--- a/devel/loki/files/patch-test-Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
---- test/Makefile.orig Mon Nov 6 20:45:11 2006
-+++ test/Makefile Mon Nov 6 20:49:04 2006
-@@ -1,5 +1,9 @@
- export CPPFLAGS = -I../../include -DNDEBUG
-+ifeq ($(OS),FreeBSD)
-+export LDFLAGS = -L../../lib -pthread
-+else
- export LDFLAGS = -L../../lib
-+endif
- export LDLIBS = -lloki
-
- ifeq ($(OS),Windows)
diff --git a/devel/loki/files/patch-test-SingletonDll-Makefile b/devel/loki/files/patch-test-SingletonDll-Makefile
deleted file mode 100644
index 08414f1242a3..000000000000
--- a/devel/loki/files/patch-test-SingletonDll-Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- test/SingletonDll/Makefile.orig Sun Jan 28 02:00:34 2007
-+++ test/SingletonDll/Makefile Sun Jan 28 02:05:49 2007
-@@ -8,9 +8,15 @@
- LIB2 = libsingletondll.so
- SHARED_LIB_FLAG = --shared
- else
-+ifeq ($(OS),FreeBSD)
-+ LIB1 = libfoo.so
-+ LIB2 = libsingletondll.so
-+ SHARED_LIB_FLAG = --shared
-+else
- LIB1 = foo.dll
- LIB2 = singletondll.dll
- SHARED_LIB_FLAG = --shared
-+endif
- endif
- endif
-
diff --git a/devel/loki/files/patch-test-SmartPtr-main.cpp b/devel/loki/files/patch-test-SmartPtr-main.cpp
deleted file mode 100644
index b13c415963db..000000000000
--- a/devel/loki/files/patch-test-SmartPtr-main.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- test/SmartPtr/main.cpp.orig Mon Nov 6 20:25:41 2006
-+++ test/SmartPtr/main.cpp Mon Nov 6 20:26:02 2006
-@@ -998,7 +998,7 @@
-
- // ----------------------------------------------------------------------------
-
--int main( unsigned int , const char * [] )
-+int main( int , const char * [] )
- {
-
- DoRefLinkTests();
diff --git a/devel/loki/files/patch-test_SingletonDll_Makefile b/devel/loki/files/patch-test_SingletonDll_Makefile
new file mode 100644
index 000000000000..fd96968efbaa
--- /dev/null
+++ b/devel/loki/files/patch-test_SingletonDll_Makefile
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- test/SingletonDll/Makefile.orig
++++ test/SingletonDll/Makefile
+@@ -5,6 +5,11 @@
+ LIB2 := libsingletondll.dylib
+ SHARED_LIB_FLAG := -dynamiclib -fPIC
+ else
++ifeq ($(OS),FreeBSD)
++ LIB1 := libfoo.so
++ LIB2 := libsingletondll.so
++ SHARED_LIB_FLAG := --shared -fPIC
++else
+ ifeq ($(OS),Linux)
+ LIB1 := libfoo.so
+ LIB2 := libsingletondll.so
+@@ -15,6 +20,7 @@
+ SHARED_LIB_FLAG := --shared
+ endif
+ endif
++endif
+
+ BIN1 := client$(BIN_SUFFIX)
+ SRC1 := client.cpp
diff --git a/devel/loki/pkg-plist b/devel/loki/pkg-plist
index 1d310e6c5c9b..5030b1cd2a4a 100644
--- a/devel/loki/pkg-plist
+++ b/devel/loki/pkg-plist
@@ -1,5 +1,9 @@
include/loki/AbstractFactory.h
+include/loki/Allocator.h
include/loki/AssocVector.h
+include/loki/CachedFactory.h
+include/loki/CheckReturn.h
+include/loki/Checker.h
include/loki/ConstPolicy.h
include/loki/DataGenerators.h
include/loki/EmptyType.h
@@ -7,6 +11,8 @@ include/loki/Factory.h
include/loki/Function.h
include/loki/Functor.h
include/loki/HierarchyGenerators.h
+include/loki/Key.h
+include/loki/LevelMutex.h
include/loki/LockingPtr.h
include/loki/LokiExport.h
include/loki/LokiTypeInfo.h
@@ -16,6 +22,8 @@ include/loki/OrderedStatic.h
include/loki/Pimpl.h
include/loki/RefToValue.h
include/loki/Register.h
+include/loki/SPCachedFactory.h
+include/loki/SafeBits.h
include/loki/SafeFormat.h
include/loki/ScopeGuard.h
include/loki/Sequence.h
@@ -48,7 +56,7 @@ include/loki/yasli/yasli_traits.h
include/loki/yasli/yasli_vector.h
lib/libloki.a
lib/libloki.so
-lib/libloki.so.0
+lib/libloki.so.0.1.7
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/Notes.txt
%%PORTDOCS%%%%DOCSDIR%%/README