aboutsummaryrefslogtreecommitdiff
path: root/devel/lua-alien
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-09-01 07:29:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-09-01 07:29:09 +0000
commit2c247cfbe31cca01aff9a5130dfabe44e830bd65 (patch)
treee97cfe049534135763c40d208919b0f4bae05025 /devel/lua-alien
parent9092473c3cc385bf73f9af5e956a40fdc8825bc0 (diff)
downloadports-2c247cfbe31cca01aff9a5130dfabe44e830bd65.tar.gz
ports-2c247cfbe31cca01aff9a5130dfabe44e830bd65.zip
Notes
Diffstat (limited to 'devel/lua-alien')
-rw-r--r--devel/lua-alien/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/lua-alien/Makefile b/devel/lua-alien/Makefile
index 5ecddb82c8e2..2c9b9202feba 100644
--- a/devel/lua-alien/Makefile
+++ b/devel/lua-alien/Makefile
@@ -20,11 +20,11 @@ LICENSE= MIT
USE_LUA= 5.1
CFLAGS+= -I${LOCALBASE}/include -I${LUA_INCDIR} \
- -DBSD -fPIC -fno-stack-protector
+ -DBSD -fPIC #-fno-stack-protector
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR} -llua -shared
MAKE_ENV+= LIB_OPTION="${LDFLAGS}" LIB_EXT=".so" LUA="${LUA_CMD}"
-# add lua prefix in pkgname
+# add lua prefix to directories
.for p in data: docs:doc/ examples:examples/
${p:C/:.*//:U}DIR_REL= share/${p:C/.*://}${LUA_PKGNAMEPREFIX}${PORTNAME}
${p:C/:.*//:U}DIR= ${PREFIX}/${${p:C/:.*//:U}DIR_REL}