aboutsummaryrefslogtreecommitdiff
path: root/devel/lua-alien
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-10-19 00:15:33 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-10-19 00:15:33 +0000
commit760241cd8f86ca2098cf891e9594d86a0b95b876 (patch)
tree99434f2aec0bdaffe073ded970d609f250ce57d9 /devel/lua-alien
parent607ccd7384ed2c251225aa0bdcf0290b49a0e441 (diff)
downloadports-760241cd8f86ca2098cf891e9594d86a0b95b876.tar.gz
ports-760241cd8f86ca2098cf891e9594d86a0b95b876.zip
Notes
Diffstat (limited to 'devel/lua-alien')
-rw-r--r--devel/lua-alien/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/lua-alien/Makefile b/devel/lua-alien/Makefile
index 8c729f0e5bb0..30244fc8fd98 100644
--- a/devel/lua-alien/Makefile
+++ b/devel/lua-alien/Makefile
@@ -23,6 +23,7 @@ CFLAGS+= -I${LOCALBASE}/include -I${LUA_INCDIR} \
-DBSD -fPIC #-fno-stack-protector
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR} -llua -shared
MAKE_ENV+= LIB_OPTION="${LDFLAGS}" LIB_EXT=".so" LUA="${LUA_CMD}"
+TESTS_EXCLUDE= tests/alien tests/alien.lua
# add lua prefix to directories
.for p in data: docs:doc/ examples:examples/
@@ -51,7 +52,8 @@ do-install:
.if !defined(NOPORTDATA)
${MKDIR} ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/src/constants ${DATADIR}
- ${TAR} cf - -C${WRKSRC} tests | ${TAR} xof - -C${DATADIR}
+ ${TAR} cf - -C${WRKSRC} ${TESTS_EXCLUDE:S,^,--exclude ,} tests \
+ | ${TAR} xof - -C${DATADIR}
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -63,9 +65,8 @@ do-install:
.endif
regression-test: build
- cd ${WRKSRC}/tests; \
- ${LN} -s ../src/alien* .; \
- ${LUA_CMD} test_alien.lua; \
- ${RM} alien alien.lua
+ ${LN} -fs ${TESTS_EXCLUDE:S,tests/,../src/,} ${WRKSRC}/tests
+ cd ${WRKSRC}/tests && ${LUA_CMD} test_alien.lua
+ ${RM} -f ${TESTS_EXCLUDE:S,^,${WRKSRC}/,}
.include <bsd.port.mk>