aboutsummaryrefslogtreecommitdiff
path: root/devel/lua-filename
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-09-15 08:17:11 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-09-15 08:17:11 +0000
commitc5aeb93cd5e4998728da54611bdf63c686a2fdfd (patch)
treef418d7aa01e7bae10fc4d0734eec45cd9e925529 /devel/lua-filename
parentf4c5a682e5c43c1c1477307463458409ae3b3de5 (diff)
downloadports-c5aeb93cd5e4998728da54611bdf63c686a2fdfd.tar.gz
ports-c5aeb93cd5e4998728da54611bdf63c686a2fdfd.zip
Notes
Diffstat (limited to 'devel/lua-filename')
-rw-r--r--devel/lua-filename/Makefile16
-rw-r--r--devel/lua-filename/pkg-descr6
-rw-r--r--devel/lua-filename/pkg-plist3
3 files changed, 12 insertions, 13 deletions
diff --git a/devel/lua-filename/Makefile b/devel/lua-filename/Makefile
index 7b97eb46dc89..c885a92d2c12 100644
--- a/devel/lua-filename/Makefile
+++ b/devel/lua-filename/Makefile
@@ -5,23 +5,25 @@
# $FreeBSD$
#
-PORTNAME= lua50-filename
+PORTNAME= filename
PORTVERSION= 1.2
CATEGORIES= devel
MASTER_SITES= http://cvs.bsdinstaller.org/cgi-bin/cvsweb.cgi/installer/src/lib/lua/filename/
+PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
DISTFILES= filename.lua?rev=${PORTVERSION}
-EXTRACT_ONLY=
+EXTRACT_ONLY= #
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= Filename-manipulating functions for Lua 5.0.x
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
-
-NO_WRKSUBDIR= yes
+USE_LUA= 5.0
NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%LUA_MODSHAREDIR%%/filename.lua
do-install:
- ${MKDIR} ${PREFIX}/share/lua/5.0
- ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${PREFIX}/share/lua/5.0/${DISTFILES:C/\?.*$//}
+ ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} \
+ ${LUA_MODSHAREDIR}/${DISTFILES:C/\?.*$//}
.include <bsd.port.mk>
diff --git a/devel/lua-filename/pkg-descr b/devel/lua-filename/pkg-descr
index 1235fd14c6ba..ce9fcc2f3ddb 100644
--- a/devel/lua-filename/pkg-descr
+++ b/devel/lua-filename/pkg-descr
@@ -1,3 +1,3 @@
-Package of routines for manipulating filenames.
-Also contains convenience functions for querying the
-status of files in the filesystem named by those filenames.
+Package of routines for manipulating filenames. Also contains convenience
+functions for querying the status of files in the filesystem named by those
+filenames.
diff --git a/devel/lua-filename/pkg-plist b/devel/lua-filename/pkg-plist
index af8e59d4d461..e69de29bb2d1 100644
--- a/devel/lua-filename/pkg-plist
+++ b/devel/lua-filename/pkg-plist
@@ -1,3 +0,0 @@
-share/lua/5.0/filename.lua
-@dirrmtry share/lua/5.0
-@dirrmtry share/lua