aboutsummaryrefslogtreecommitdiff
path: root/devel/lua-filename
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2006-04-17 17:09:17 +0000
committerPhilip Paeps <philip@FreeBSD.org>2006-04-17 17:09:17 +0000
commitce606010712d233141780a001bd2bad2e4753fc2 (patch)
tree35d59971dc43c3d0f05c45a5ffdd0c9b01c0653d /devel/lua-filename
parent8c969ef0d9745700a9f57bf31b2543d28b4d0082 (diff)
downloadports-ce606010712d233141780a001bd2bad2e4753fc2.tar.gz
ports-ce606010712d233141780a001bd2bad2e4753fc2.zip
Notes
Diffstat (limited to 'devel/lua-filename')
-rw-r--r--devel/lua-filename/Makefile27
-rw-r--r--devel/lua-filename/distinfo3
-rw-r--r--devel/lua-filename/pkg-descr3
-rw-r--r--devel/lua-filename/pkg-plist3
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/lua-filename/Makefile b/devel/lua-filename/Makefile
new file mode 100644
index 000000000000..3950ecb5e739
--- /dev/null
+++ b/devel/lua-filename/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: lua50-filename
+# Date created: 17 April 2006
+# Whom: Andrew Turner <andrew+ports@fubar.geek.nz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lua50-filename
+PORTVERSION= 1.2
+CATEGORIES= devel
+MASTER_SITES= http://cvs.bsdinstaller.org/cgi-bin/cvsweb.cgi/installer/src/lib/lua/filename/
+DISTFILES= filename.lua?rev=${PORTVERSION}
+EXTRACT_ONLY=
+
+MAINTAINER= andrew+ports@fubar.geek.nz
+COMMENT= Filename-manipulating functions for Lua 5.0.x
+
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/lua/5.0
+ ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${PREFIX}/share/lua/5.0/${DISTFILES:C/\?.*$//}
+
+.include <bsd.port.mk>
diff --git a/devel/lua-filename/distinfo b/devel/lua-filename/distinfo
new file mode 100644
index 000000000000..ca40911362d1
--- /dev/null
+++ b/devel/lua-filename/distinfo
@@ -0,0 +1,3 @@
+MD5 (filename.lua?rev=1.2) = 85157fb0a36a9f2a8b3b6a9f329a1fbe
+SHA256 (filename.lua?rev=1.2) = ff8d2648bf0aa17b8da197afec9f55c01a470e7b4448d19b1233efe879715f1a
+SIZE (filename.lua?rev=1.2) = 2888
diff --git a/devel/lua-filename/pkg-descr b/devel/lua-filename/pkg-descr
new file mode 100644
index 000000000000..1235fd14c6ba
--- /dev/null
+++ b/devel/lua-filename/pkg-descr
@@ -0,0 +1,3 @@
+Package of routines for manipulating filenames.
+Also contains convenience functions for querying the
+status of files in the filesystem named by those filenames.
diff --git a/devel/lua-filename/pkg-plist b/devel/lua-filename/pkg-plist
new file mode 100644
index 000000000000..af8e59d4d461
--- /dev/null
+++ b/devel/lua-filename/pkg-plist
@@ -0,0 +1,3 @@
+share/lua/5.0/filename.lua
+@dirrmtry share/lua/5.0
+@dirrmtry share/lua