aboutsummaryrefslogtreecommitdiff
path: root/devel/lua-pty/Makefile
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2006-12-05 22:51:12 +0000
committerPhilip Paeps <philip@FreeBSD.org>2006-12-05 22:51:12 +0000
commit463177d875fdc8a962404d4bb9f13030d5ea8b26 (patch)
tree434fb08852bdff09c2c5942a2841697de81f10ab /devel/lua-pty/Makefile
parent7a52d004a07218675363f2ec795880f9c31ef59a (diff)
Notes
Diffstat (limited to 'devel/lua-pty/Makefile')
-rw-r--r--devel/lua-pty/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/lua-pty/Makefile b/devel/lua-pty/Makefile
index 0ee1db962e74..9ae1cd8e746f 100644
--- a/devel/lua-pty/Makefile
+++ b/devel/lua-pty/Makefile
@@ -14,15 +14,16 @@ PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
DISTFILES= pty.lua?rev=1.2 pty.c?rev=1.25
MAINTAINER= andrew+ports@fubar.geek.nz
-COMMENT= Pty (pseudo-terminal) bindings for Lua 5.0.x
+COMMENT= Pty (pseudo-terminal) bindings for Lua 5
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
-
-USE_LUA= 5.0
-LUA_COMPS= lua compat51
+USE_LUA?= 5.1
+.if ${USE_LUA} == 5.0
+LUA_COMPS= compat51 lua
+BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
COMPAT_SRC= `(cd ${PORTSDIR}/devel/lua50-compat51 && ${MAKE} -V WRKSRC)`
MAKE_ENV= COMPATDIR="${COMPAT_SRC}"
+.endif
PLIST_FILES= %%LUA_MODSHAREDIR%%/pty.lua \
%%LUA_MODLIBDIR%%/lpty.so