aboutsummaryrefslogtreecommitdiff
path: root/devel/lua50-compat51
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-15 16:54:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-15 16:54:49 +0000
commit2ec89cef7172c1d9d698c7222dfcc4482579bafd (patch)
treefca11eb12f5c1753db6c9134fe0ab1c70051b6d8 /devel/lua50-compat51
parent14ffb79ed38bddeff6d59fbf6ed145f6d7e3eb04 (diff)
downloadports-2ec89cef7172c1d9d698c7222dfcc4482579bafd.tar.gz
ports-2ec89cef7172c1d9d698c7222dfcc4482579bafd.zip
Notes
Diffstat (limited to 'devel/lua50-compat51')
-rw-r--r--devel/lua50-compat51/Makefile33
-rw-r--r--devel/lua50-compat51/distinfo3
-rw-r--r--devel/lua50-compat51/files/Makefile9
-rw-r--r--devel/lua50-compat51/pkg-descr4
-rw-r--r--devel/lua50-compat51/pkg-plist5
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/lua50-compat51/Makefile b/devel/lua50-compat51/Makefile
new file mode 100644
index 000000000000..eab327704d8a
--- /dev/null
+++ b/devel/lua50-compat51/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: lua50-compat51
+# Date created: 14 April 2006
+# Whom: Andrew Turner <andrew+ports@fubar.geek.nz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lua50-compat51
+PORTVERSION= ${CVER}.${CREV}
+CATEGORIES= devel
+MASTER_SITES= http://luaforge.net/frs/download.php/1410/
+DISTNAME= compat-${CVER}${CREV}.tar.gz
+
+MAINTAINER= andrew+ports@fubar.geek.nz
+COMMENT= Lua 5.1 package compatibility layer for Lua 5.0.x
+
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+
+# Update these values when there is a new release
+CVER= 5.1
+CREV= r5
+
+WRKSRC= ${WRKDIR}/compat-${CVER}${CREV}
+LIBDIR= ${PREFIX}/lib
+
+post-extract:
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/lua/5.0
+ ${INSTALL_DATA} ${WRKSRC}/compat-5.1.lua ${PREFIX}/share/lua/5.0
+
+.include <bsd.port.mk>
diff --git a/devel/lua50-compat51/distinfo b/devel/lua50-compat51/distinfo
new file mode 100644
index 000000000000..0ebef78581ca
--- /dev/null
+++ b/devel/lua50-compat51/distinfo
@@ -0,0 +1,3 @@
+MD5 (compat-5.1r5.tar.gz.tar.gz) = 30d50d173ab236e96c4b969347163eb7
+SHA256 (compat-5.1r5.tar.gz.tar.gz) = 93262ad793552c338b825e6b67c903063aa07625952ef643d126ae60949c8ab6
+SIZE (compat-5.1r5.tar.gz.tar.gz) = 2977
diff --git a/devel/lua50-compat51/files/Makefile b/devel/lua50-compat51/files/Makefile
new file mode 100644
index 000000000000..3f62c9d29785
--- /dev/null
+++ b/devel/lua50-compat51/files/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+LIB= lua-compat-5.1
+
+SRCS= compat-5.1.c
+
+CFLAGS+= -I${PREFIX}/include
+
+.include <bsd.lib.mk>
diff --git a/devel/lua50-compat51/pkg-descr b/devel/lua50-compat51/pkg-descr
new file mode 100644
index 000000000000..302f6a32bfbc
--- /dev/null
+++ b/devel/lua50-compat51/pkg-descr
@@ -0,0 +1,4 @@
+The Package Compatibility (Compat-5.1) is a set of files which provides an
+implementation of the new package model of Lua 5.1 to be used in Lua 5.0.
+
+WWW: http://luaforge.net/projects/compat/
diff --git a/devel/lua50-compat51/pkg-plist b/devel/lua50-compat51/pkg-plist
new file mode 100644
index 000000000000..d9f372c130e2
--- /dev/null
+++ b/devel/lua50-compat51/pkg-plist
@@ -0,0 +1,5 @@
+lib/liblua-compat-5.1.a
+lib/liblua-compat-5.1_p.a
+share/lua/5.0/compat-5.1.lua
+@dirrmtry share/lua/5.0
+@dirrmtry share/lua