aboutsummaryrefslogtreecommitdiff
path: root/devel/lua50-pty/Makefile
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2006-04-17 16:21:41 +0000
committerPhilip Paeps <philip@FreeBSD.org>2006-04-17 16:21:41 +0000
commitd4e1e5b071eabc70ad6d7707136c39154d7ce6a8 (patch)
tree4e1a8c92ac4df2c6006496f7c25a8723578caf09 /devel/lua50-pty/Makefile
parentb70c80936aa967000d1a1a4ecf0176279de12c4a (diff)
downloadports-d4e1e5b071eabc70ad6d7707136c39154d7ce6a8.tar.gz
ports-d4e1e5b071eabc70ad6d7707136c39154d7ce6a8.zip
Notes
Diffstat (limited to 'devel/lua50-pty/Makefile')
-rw-r--r--devel/lua50-pty/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/lua50-pty/Makefile b/devel/lua50-pty/Makefile
new file mode 100644
index 000000000000..fa29708e8764
--- /dev/null
+++ b/devel/lua50-pty/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: lua50-pty
+# Date created: 17 April 2006
+# Whom: Andrew Turner <andrew+ports@fubar.geek.nz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lua50-pty
+PORTVERSION= 1.25
+CATEGORIES= devel
+MASTER_SITES= http://cvs.bsdinstaller.org/cgi-bin/cvsweb.cgi/installer/src/lib/lua/pty/
+DISTFILES= pty.lua?rev=1.2 pty.c?rev=1.25
+
+MAINTAINER= andrew+ports@fubar.geek.nz
+COMMENT= Pty (pseudo-terminal) bindings for Lua 5.0.x
+
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+ ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+ ${LOCALBASE}/share/lua/5.0/compat-5.1.lua:${PORTSDIR}/devel/lua50-compat51
+
+LIBDIR= ${PREFIX}/lib/lua/5.0
+COMPAT_SRC= `(cd ${PORTSDIR}/devel/lua50-compat51 && make -V WRKSRC)`
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+.for file in ${DISTFILES}
+ @${CP} ${DISTDIR}/${file} ${WRKSRC}/${file:C/\?.*$//}
+.endfor
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%COMPATDIR%%|${COMPAT_SRC}|" ${WRKSRC}/Makefile
+
+pre-install:
+ ${MKDIR} ${LIBDIR}
+ ${MKDIR} ${PREFIX}/share/lua/5.0
+ ${INSTALL_DATA} ${WRKSRC}/pty.lua ${PREFIX}/share/lua/5.0
+
+.include <bsd.port.mk>