aboutsummaryrefslogtreecommitdiff
path: root/devel/m17n-docs
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-29 17:53:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-29 17:53:00 +0000
commit914ea7398475ee7171987f865183dc6dd0301ffc (patch)
tree8126f026a0d8f4bc842e8a12412c1bf5c02ca121 /devel/m17n-docs
parent0d72ddb92f3ca0af02f0a9c23b5c586798a8cb9c (diff)
downloadports-914ea7398475ee7171987f865183dc6dd0301ffc.tar.gz
ports-914ea7398475ee7171987f865183dc6dd0301ffc.zip
Notes
Diffstat (limited to 'devel/m17n-docs')
-rw-r--r--devel/m17n-docs/Makefile231
-rw-r--r--devel/m17n-docs/distinfo2
-rw-r--r--devel/m17n-docs/pkg-descr3
3 files changed, 236 insertions, 0 deletions
diff --git a/devel/m17n-docs/Makefile b/devel/m17n-docs/Makefile
new file mode 100644
index 000000000000..b8430aacf4b0
--- /dev/null
+++ b/devel/m17n-docs/Makefile
@@ -0,0 +1,231 @@
+# New ports collection makefile for: m17n-docs
+# Date created: 29 May 2004
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= m17n-docs
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= http://www.m17n.org/m17n-lib/download/
+
+MAINTAINER= fuyuki@hadaly.org
+COMMENT= The m17n library documentation
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+MAN1= m17n-config.1 mconv.1 mdate.1 mdump.1 medit.1 \
+ mimx-anthy.1 mimx-ispell.1 mview.1
+MAN3= m17nCharacter.3m17n \
+ m17nCharset.3m17n \
+ m17nChartable.3m17n \
+ m17nConv.3m17n \
+ m17nCore.3m17n \
+ m17nDatabase.3m17n \
+ m17nDebug.3m17n \
+ m17nDraw.3m17n \
+ m17nError.3m17n \
+ m17nFace.3m17n \
+ m17nFont.3m17n \
+ m17nFontset.3m17n \
+ m17nFrame.3m17n \
+ m17nGUI.3m17n \
+ m17nInputMethod.3m17n \
+ m17nInputMethodWin.3m17n \
+ m17nIntro.3m17n \
+ m17nLocale.3m17n \
+ m17nMisc.3m17n \
+ m17nMtext.3m17n \
+ m17nObject.3m17n \
+ m17nPlist.3m17n \
+ m17nShell.3m17n \
+ m17nSymbol.3m17n \
+ m17nTextProperty.3m17n \
+ m17n_object.3m17n \
+ m17n_object_ref.3m17n \
+ m17n_object_unref.3m17n \
+ mchar_decode.3m17n \
+ mchar_define_charset.3m17n \
+ mchar_define_property.3m17n \
+ mchar_encode.3m17n \
+ mchar_get_prop.3m17n \
+ mchar_list_charset.3m17n \
+ mchar_map_charset.3m17n \
+ mchar_put_prop.3m17n \
+ mchar_resolve_charset.3m17n \
+ mchartable.3m17n \
+ mchartable_lookup.3m17n \
+ mchartable_map.3m17n \
+ mchartable_range.3m17n \
+ mchartable_set.3m17n \
+ mchartable_set_range.3m17n \
+ mconv_buffer_converter.3m17n \
+ mconv_decode.3m17n \
+ mconv_decode_buffer.3m17n \
+ mconv_decode_stream.3m17n \
+ mconv_define_coding.3m17n \
+ mconv_encode.3m17n \
+ mconv_encode_buffer.3m17n \
+ mconv_encode_range.3m17n \
+ mconv_encode_stream.3m17n \
+ mconv_free_converter.3m17n \
+ mconv_getc.3m17n \
+ mconv_gets.3m17n \
+ mconv_list_codings.3m17n \
+ mconv_putc.3m17n \
+ mconv_rebind_buffer.3m17n \
+ mconv_rebind_stream.3m17n \
+ mconv_reset_converter.3m17n \
+ mconv_resolve_coding.3m17n \
+ mconv_stream_converter.3m17n \
+ mconv_ungetc.3m17n \
+ mdatabase_define.3m17n \
+ mdatabase_find.3m17n \
+ mdatabase_list.3m17n \
+ mdatabase_load.3m17n \
+ mdatabase_tag.3m17n \
+ mdebug_dump_all_symbols.3m17n \
+ mdebug_dump_chartab.3m17n \
+ mdebug_dump_face.3m17n \
+ mdebug_dump_font.3m17n \
+ mdebug_dump_fontset.3m17n \
+ mdebug_dump_im.3m17n \
+ mdebug_dump_mtext.3m17n \
+ mdebug_dump_plist.3m17n \
+ mdebug_dump_symbol.3m17n \
+ mdebug_hook.3m17n \
+ mdraw_clear_cache.3m17n \
+ mdraw_coordinates_position.3m17n \
+ mdraw_default_line_break.3m17n \
+ mdraw_glyph_info.3m17n \
+ mdraw_image_text.3m17n \
+ mdraw_per_char_extents.3m17n \
+ mdraw_text.3m17n \
+ mdraw_text_extents.3m17n \
+ mdraw_text_items.3m17n \
+ mdraw_text_per_char_extents.3m17n \
+ mdraw_text_with_control.3m17n \
+ mface.3m17n \
+ mface_copy.3m17n \
+ mface_from_font.3m17n \
+ mface_get_prop.3m17n \
+ mface_merge.3m17n \
+ mface_put_prop.3m17n \
+ mface_update.3m17n \
+ mfont.3m17n \
+ mfont_copy.3m17n \
+ mfont_find.3m17n \
+ mfont_from_name.3m17n \
+ mfont_get_prop.3m17n \
+ mfont_name.3m17n \
+ mfont_put_prop.3m17n \
+ mfont_selection_priority.3m17n \
+ mfont_set_encoding.3m17n \
+ mfont_set_selection_priority.3m17n \
+ mfontset.3m17n \
+ mfontset_copy.3m17n \
+ mfontset_modify_entry.3m17n \
+ mfontset_name.3m17n \
+ mframe.3m17n \
+ mframe_get_prop.3m17n \
+ minput_close_im.3m17n \
+ minput_create_ic.3m17n \
+ minput_destroy_ic.3m17n \
+ minput_event_to_key.3m17n \
+ minput_filter.3m17n \
+ minput_lookup.3m17n \
+ minput_open_im.3m17n \
+ minput_set_spot.3m17n \
+ minput_toggle.3m17n \
+ mlocale_get_prop.3m17n \
+ mlocale_set.3m17n \
+ mplist.3m17n \
+ mplist_add.3m17n \
+ mplist_copy.3m17n \
+ mplist_find_by_key.3m17n \
+ mplist_find_by_value.3m17n \
+ mplist_get.3m17n \
+ mplist_key.3m17n \
+ mplist_length.3m17n \
+ mplist_next.3m17n \
+ mplist_pop.3m17n \
+ mplist_push.3m17n \
+ mplist_put.3m17n \
+ mplist_set.3m17n \
+ mplist_value.3m17n \
+ msymbol.3m17n \
+ msymbol_as_managing_key.3m17n \
+ msymbol_exist.3m17n \
+ msymbol_get.3m17n \
+ msymbol_name.3m17n \
+ msymbol_put.3m17n \
+ mtext.3m17n \
+ mtext_attach_property.3m17n \
+ mtext_case_compare.3m17n \
+ mtext_casecmp.3m17n \
+ mtext_cat.3m17n \
+ mtext_cat_char.3m17n \
+ mtext_character.3m17n \
+ mtext_chr.3m17n \
+ mtext_cmp.3m17n \
+ mtext_coll.3m17n \
+ mtext_compare.3m17n \
+ mtext_copy.3m17n \
+ mtext_cpy.3m17n \
+ mtext_cspn.3m17n \
+ mtext_del.3m17n \
+ mtext_deserialize.3m17n \
+ mtext_detach_property.3m17n \
+ mtext_dup.3m17n \
+ mtext_duplicate.3m17n \
+ mtext_from_data.3m17n \
+ mtext_ftime.3m17n \
+ mtext_get_prop.3m17n \
+ mtext_get_prop_keys.3m17n \
+ mtext_get_prop_values.3m17n \
+ mtext_get_properties.3m17n \
+ mtext_get_property.3m17n \
+ mtext_getenv.3m17n \
+ mtext_ins.3m17n \
+ mtext_ins_char.3m17n \
+ mtext_len.3m17n \
+ mtext_ncasecmp.3m17n \
+ mtext_ncat.3m17n \
+ mtext_ncmp.3m17n \
+ mtext_ncpy.3m17n \
+ mtext_pbrk.3m17n \
+ mtext_pop_prop.3m17n \
+ mtext_prop_range.3m17n \
+ mtext_property.3m17n \
+ mtext_property_end.3m17n \
+ mtext_property_key.3m17n \
+ mtext_property_mtext.3m17n \
+ mtext_property_start.3m17n \
+ mtext_property_value.3m17n \
+ mtext_push_prop.3m17n \
+ mtext_push_property.3m17n \
+ mtext_put_prop.3m17n \
+ mtext_put_prop_values.3m17n \
+ mtext_putenv.3m17n \
+ mtext_rchr.3m17n \
+ mtext_ref_char.3m17n \
+ mtext_search.3m17n \
+ mtext_serialize.3m17n \
+ mtext_set_char.3m17n \
+ mtext_spn.3m17n \
+ mtext_text.3m17n \
+ mtext_tok.3m17n
+MAN5= mdbCharsetList.5 mdbCodingList.5 mdbDir.5 \
+ mdbFLT.5 mdbFontEncoding.5 mdbFontSize.5 mdbFontset.5 \
+ mdbGeneral.5 mdbIM.5
+
+DOCSDIR= ${PREFIX}/share/doc/m17n
+PORTDOCS= *
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/m17n/docs,/doc/m17n,' \
+ ${WRKSRC}/configure ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/devel/m17n-docs/distinfo b/devel/m17n-docs/distinfo
new file mode 100644
index 000000000000..fd2170dce5be
--- /dev/null
+++ b/devel/m17n-docs/distinfo
@@ -0,0 +1,2 @@
+MD5 (m17n-docs-1.0.tar.gz) = 59ae74ede02115cba42d230e492f9257
+SIZE (m17n-docs-1.0.tar.gz) = 745891
diff --git a/devel/m17n-docs/pkg-descr b/devel/m17n-docs/pkg-descr
new file mode 100644
index 000000000000..d64160fd2c7a
--- /dev/null
+++ b/devel/m17n-docs/pkg-descr
@@ -0,0 +1,3 @@
+This package contains the documentation files for the m17n library.
+
+WWW: http://www.m17n.org/m17n-lib/