aboutsummaryrefslogtreecommitdiff
path: root/devel/m17n-lib/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-03-03 12:51:48 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-03-03 12:51:48 +0000
commit2b06b64a29cf26e47dde4b4596d98c16140283a3 (patch)
treeb6bbdccc1d095bb32b977e0d116b991e4c4e6547 /devel/m17n-lib/Makefile
parent82c90c073f01559b8a0fb592b492e5f3823a5856 (diff)
downloadports-2b06b64a29cf26e47dde4b4596d98c16140283a3.tar.gz
ports-2b06b64a29cf26e47dde4b4596d98c16140283a3.zip
Notes
Diffstat (limited to 'devel/m17n-lib/Makefile')
-rw-r--r--devel/m17n-lib/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/devel/m17n-lib/Makefile b/devel/m17n-lib/Makefile
index fa410f3b4231..5e24c6b3a91b 100644
--- a/devel/m17n-lib/Makefile
+++ b/devel/m17n-lib/Makefile
@@ -6,25 +6,26 @@
#
PORTNAME= m17n-lib
-PORTVERSION= 1.1.0
+PORTVERSION= 1.2.0
CATEGORIES= devel
MASTER_SITES= http://www.m17n.org/m17n-lib/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= A library for the multilingual text handling
+BUILD_DEPENDS= ${LOCALBASE}/share/m17n/mdb.dir:${PORTSDIR}/devel/m17n-db
LIB_DEPENDS= fribidi.0:${PORTSDIR}/converters/fribidi \
+ gd.4:${PORTSDIR}/graphics/gd \
otf.0:${PORTSDIR}/print/libotf \
- Xft.2:${PORTSDIR}/x11-fonts/libXft \
- gd.4:${PORTSDIR}/graphics/gd
-BUILD_DEPENDS= ${LOCALBASE}/share/m17n/mdb.dir:${PORTSDIR}/devel/m17n-db
+ Xft.2:${PORTSDIR}/x11-fonts/libXft
RUN_DEPENDS= ${LOCALBASE}/share/m17n/mdb.dir:${PORTSDIR}/devel/m17n-db
-USE_REINPLACE= yes
USE_XLIB= yes
-USE_GNOME= libxml2
+USE_GNOME= gnometarget libxml2 pkgconfig
+USE_REINPLACE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
OPTIONS= ANTHY "With Anthy support" off \
@@ -32,13 +33,13 @@ OPTIONS= ANTHY "With Anthy support" off \
.include <bsd.port.pre.mk>
-.ifdef WITH_ANTHY
+.if defined(WITH_ANTHY)
LIB_DEPENDS+= anthy.1:${PORTSDIR}/japanese/anthy
.else
CONFIGURE_ENV+= ac_cv_lib_anthydic_anthy_init_sessions=no
.endif
-.ifdef WITH_ISPELL
+.if defined(WITH_ISPELL)
BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.else
@@ -46,6 +47,8 @@ CONFIGURE_ENV+= HAVE_ISPELL=no
.endif
post-patch:
- ${REINPLACE_CMD} -e 's/-ldl//' ${WRKSRC}/*/Makefile.in
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|g ; \
+ s|-ldl||g'
.include <bsd.port.post.mk>