aboutsummaryrefslogtreecommitdiff
path: root/devel/magit
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-09-08 14:09:57 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-09-08 14:09:57 +0000
commit3bd8fc0614d42ae8890e36b69afe504977f5792f (patch)
treefe82bb9606b63b59094541c3055e4d928bb83db5 /devel/magit
parentc69f233a1ef4fba976cef9bd362a16cd04510412 (diff)
With Magit, you can inspect and modify your Git repositories with
Emacs. You can review and commit the changes you have made to the tracked files, for example, and you can browse the history of past changes. There is support for cherry picking, reverting, merging, rebasing, and other common Git operations. WWW: http://philjackson.github.com/magit/
Notes
Notes: svn path=/head/; revision=260768
Diffstat (limited to 'devel/magit')
-rw-r--r--devel/magit/Makefile23
-rw-r--r--devel/magit/distinfo3
-rw-r--r--devel/magit/pkg-descr7
-rw-r--r--devel/magit/pkg-plist5
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/magit/Makefile b/devel/magit/Makefile
new file mode 100644
index 000000000000..fcc446743ad9
--- /dev/null
+++ b/devel/magit/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: magit
+# Date created: 8 Sep 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= magit
+PORTVERSION= 0.8.2
+CATEGORIES= devel elisp
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://cloud.github.com/downloads/philjackson/magit/
+MASTER_SITE_SUBDIR= kuriyama
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Interface to Git for Emacs
+
+USE_EMACS= YES
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+INFO= magit
+
+.include <bsd.port.mk>
diff --git a/devel/magit/distinfo b/devel/magit/distinfo
new file mode 100644
index 000000000000..34b107dbd2fa
--- /dev/null
+++ b/devel/magit/distinfo
@@ -0,0 +1,3 @@
+MD5 (magit-0.8.2.tar.gz) = fe7e1a1085190ede6bed49e406fe0ce9
+SHA256 (magit-0.8.2.tar.gz) = fc02c23e3e8994e9c3e3299d560d0cbfed888dcc66088f06b8cea3bc89cd6ae8
+SIZE (magit-0.8.2.tar.gz) = 214803
diff --git a/devel/magit/pkg-descr b/devel/magit/pkg-descr
new file mode 100644
index 000000000000..8b105e0dd2ab
--- /dev/null
+++ b/devel/magit/pkg-descr
@@ -0,0 +1,7 @@
+With Magit, you can inspect and modify your Git repositories with
+Emacs. You can review and commit the changes you have made to the
+tracked files, for example, and you can browse the history of past
+changes. There is support for cherry picking, reverting, merging,
+rebasing, and other common Git operations.
+
+WWW: http://philjackson.github.com/magit/
diff --git a/devel/magit/pkg-plist b/devel/magit/pkg-plist
new file mode 100644
index 000000000000..9e2143291932
--- /dev/null
+++ b/devel/magit/pkg-plist
@@ -0,0 +1,5 @@
+etc/emacs/site-start.d/50magit.el
+@dirrmtry etc/emacs/site-start.d
+@dirrmtry etc/emacs
+share/emacs/site-lisp/magit.el
+share/emacs/site-lisp/magit.elc