aboutsummaryrefslogtreecommitdiff
path: root/devel/matreshka
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-07-01 19:18:17 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-07-01 19:18:17 +0000
commit06bff7a001ac75bbd3a6b46df54e49015d79c59d (patch)
tree9c9f758e41fd70bda28b53c6f087aaf9bb6d332a /devel/matreshka
parentd20298d4738f9ffd68578ee92e8d47498e131a2f (diff)
downloadports-06bff7a001ac75bbd3a6b46df54e49015d79c59d.tar.gz
ports-06bff7a001ac75bbd3a6b46df54e49015d79c59d.zip
Notes
Diffstat (limited to 'devel/matreshka')
-rw-r--r--devel/matreshka/Makefile65
-rw-r--r--devel/matreshka/distinfo2
-rw-r--r--devel/matreshka/files/patch-Makefile.build15
-rw-r--r--devel/matreshka/files/patch-Makefile.install15
-rw-r--r--devel/matreshka/pkg-descr24
5 files changed, 121 insertions, 0 deletions
diff --git a/devel/matreshka/Makefile b/devel/matreshka/Makefile
new file mode 100644
index 000000000000..abfcab60230c
--- /dev/null
+++ b/devel/matreshka/Makefile
@@ -0,0 +1,65 @@
+# Created by: John Marino <draco@marino.st>
+# $FreeBSD$
+
+PORTNAME= matreshka
+PORTVERSION= 0.5.0
+CATEGORIES= devel
+MASTER_SITES= http://forge.ada-ru.org/matreshka/downloads/
+
+MAINTAINER= draco@marino.st
+COMMENT= Ada framework for information systems development
+
+LICENSE= BSD
+
+BUILD_DEPENDS= gprbuild>=20120510:${PORTSDIR}/devel/gprbuild
+
+USES= ada
+USE_GMAKE= yes
+DESTINY= ${WRKDIR}/destino
+
+OPTIONS_DEFINE= SQLITE3 FIREBIRD PGSQL MYSQL ORACLE AMF
+OPTIONS_DEFAULT=SQLITE3 FIREBIRD PGSQL MYSQL
+
+AMF_DESC= Build Ada Modeling Framework
+
+MAKE_JOBS_UNSAFE= yes
+
+MAKE_ENV+= SMP_MFLAGS=-j${MAKE_JOBS_NUMBER} \
+ DESTDIR=${DESTINY}
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MFIREBIRD}
+MAKE_ENV+= HAS_FIREBIRD=yes
+.endif
+
+.if ${PORT_OPTIONS:MMYSQL}
+MAKE_ENV+= HAS_MYSQL=yes
+.endif
+
+.if ${PORT_OPTIONS:MORACLE}
+MAKE_ENV+= HAS_OCI=yes
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+MAKE_ENV+= HAS_POSTGRESQL=yes
+.endif
+
+.if ${PORT_OPTIONS:MSQLITE3}
+MAKE_ENV+= HAS_SQLITE3=yes
+.endif
+
+.if ${PORT_OPTIONS:MAMF}
+MAKE_ENV+= WANT_AMF=yes
+.endif
+
+post-install:
+ ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
+ @cd ${DESTINY}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${SORT} > ${WRKDIR}/PLIST.all
+ @cd ${DESTINY}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | ${SORT} -r | \
+ ${SED} -e '/lib\/gnat$$/d' -e 's/^/@dirrm /g' >> ${WRKDIR}/PLIST.all
+ @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
+ @${CAT} ${WRKDIR}/PLIST.all >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/matreshka/distinfo b/devel/matreshka/distinfo
new file mode 100644
index 000000000000..2b65d99e0765
--- /dev/null
+++ b/devel/matreshka/distinfo
@@ -0,0 +1,2 @@
+SHA256 (matreshka-0.5.0.tar.gz) = 09b7fd82f47d0e64ceaa1b538ed7f4e96351759ca10c0f307d0d20fec3bafe98
+SIZE (matreshka-0.5.0.tar.gz) = 32055197
diff --git a/devel/matreshka/files/patch-Makefile.build b/devel/matreshka/files/patch-Makefile.build
new file mode 100644
index 000000000000..f1b63f8168cd
--- /dev/null
+++ b/devel/matreshka/files/patch-Makefile.build
@@ -0,0 +1,15 @@
+--- Makefile.build.orig 2013-03-26 10:11:24.640151000 +0000
++++ Makefile.build
+@@ -2,7 +2,11 @@ include Makefile.config
+
+ GPRBUILD_FLAGS = -p $(SMP_MFLAGS)
+
+-ALL_TARGETS = league xml fastcgi soap wsse wsdl2ada sql amf dd uml mofext ocl utp
++ALL_TARGETS = league xml fastcgi soap wsse wsdl2ada sql
++
++ifdef WANT_AMF
++ALL_TARGETS += amf dd uml mofext ocl utp
++endif
+
+ ifdef HAS_FIREBIRD
+ ALL_TARGETS += firebird
diff --git a/devel/matreshka/files/patch-Makefile.install b/devel/matreshka/files/patch-Makefile.install
new file mode 100644
index 000000000000..6eafba588a5f
--- /dev/null
+++ b/devel/matreshka/files/patch-Makefile.install
@@ -0,0 +1,15 @@
+--- Makefile.install.orig 2012-12-05 19:49:10.977713000 +0000
++++ Makefile.install
+@@ -22,7 +22,11 @@ LIBEXT = dll
+ EXEEXT = .exe
+ endif
+
+-INSTALL_TARGETS = league xml fastcgi soap wsse wsdl2ada sql amf dd uml mofext ocl utp
++INSTALL_TARGETS = league xml fastcgi soap wsse wsdl2ada sql
++
++ifdef WANT_AMF
++INSTALL_TARGETS += amf dd uml mofext ocl utp
++endif
+
+ ifdef HAS_FIREBIRD
+ INSTALL_TARGETS += firebird
diff --git a/devel/matreshka/pkg-descr b/devel/matreshka/pkg-descr
new file mode 100644
index 000000000000..a486281c1afb
--- /dev/null
+++ b/devel/matreshka/pkg-descr
@@ -0,0 +1,24 @@
+Matreshka is an Ada framework to develop information systems. It consists
+of five major components: League, XML processor, Web framework, SQL access,
+and the Modeling framework.
+
+League:
+ High level abstraction of localization and internationalization. Also
+ provides calendrical calculations, regular expressions, and JSON.
+
+XML processor:
+ Sax reader and writer, supports XML 1.0 and 1.1 as well as namespaces.
+ It also has an XML catalogs resolver.
+
+Web framework:
+ Supports FastCGI, SOAP 1.2 and has a WSDL to Ada translator.
+
+SQL access:
+ Database abstraction of MySQL, Oracle, PostgreSQL, SQLite and Firebird.
+
+Modeling framework:
+ provides implementation of Meta Object Facility (MOF) written entirely
+ in Ada. Extension modules assist in the analysis of UML modules and
+ extensions (MOF, OCL, and UML testing profile) and diagram definition.
+
+WWW: http://forge.ada-ru.org/matreshka