aboutsummaryrefslogtreecommitdiff
path: root/devel/mdds/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-07-22 22:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-07-22 22:51:05 +0000
commitdb5fe063ec389d3471867a4defe56ba7c768e3c3 (patch)
tree0c3cb0e5399db1416572d00e2cada16d5f1dd80e /devel/mdds/Makefile
parent6219e04b4df8f99aaa8131ad3a2d3f3d165effe5 (diff)
Notes
Diffstat (limited to 'devel/mdds/Makefile')
-rw-r--r--devel/mdds/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/mdds/Makefile b/devel/mdds/Makefile
new file mode 100644
index 000000000000..7c8afd4848d8
--- /dev/null
+++ b/devel/mdds/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mdds
+# Date created: 2011-07-22
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mdds
+PORTVERSION= 0.5.3
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Multi-dimensional data index algorithm
+
+LICENSE= MIT
+
+PROJECTHOST= multidimalgorithm
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/mdds
+ @${MKDIR} ${PREFIX}/mdds/hash_container
+ @${INSTALL_DATA} ${WRKSRC}/include/mdds/*.hpp ${PREFIX}/mdds
+ @${INSTALL_DATA} ${WRKSRC}/include/mdds/*.inl ${PREFIX}/mdds
+ @${INSTALL_DATA} ${WRKSRC}/include/mdds/hash_container/*.hpp ${PREFIX}/mdds/hash_container
+
+.include <bsd.port.mk>