aboutsummaryrefslogtreecommitdiff
path: root/devel/mdds
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-07-22 22:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-07-22 22:51:05 +0000
commitdb5fe063ec389d3471867a4defe56ba7c768e3c3 (patch)
tree0c3cb0e5399db1416572d00e2cada16d5f1dd80e /devel/mdds
parent6219e04b4df8f99aaa8131ad3a2d3f3d165effe5 (diff)
Notes
Diffstat (limited to 'devel/mdds')
-rw-r--r--devel/mdds/Makefile31
-rw-r--r--devel/mdds/Makefile~31
-rw-r--r--devel/mdds/distinfo2
-rw-r--r--devel/mdds/pkg-descr3
-rw-r--r--devel/mdds/pkg-plist21
5 files changed, 88 insertions, 0 deletions
diff --git a/devel/mdds/Makefile b/devel/mdds/Makefile
new file mode 100644
index 000000000000..7c8afd4848d8
--- /dev/null
+++ b/devel/mdds/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mdds
+# Date created: 2011-07-22
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mdds
+PORTVERSION= 0.5.3
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Multi-dimensional data index algorithm
+
+LICENSE= MIT
+
+PROJECTHOST= multidimalgorithm
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/mdds
+ @${MKDIR} ${PREFIX}/mdds/hash_container
+ @${INSTALL_DATA} ${WRKSRC}/include/mdds/*.hpp ${PREFIX}/mdds
+ @${INSTALL_DATA} ${WRKSRC}/include/mdds/*.inl ${PREFIX}/mdds
+ @${INSTALL_DATA} ${WRKSRC}/include/mdds/hash_container/*.hpp ${PREFIX}/mdds/hash_container
+
+.include <bsd.port.mk>
diff --git a/devel/mdds/Makefile~ b/devel/mdds/Makefile~
new file mode 100644
index 000000000000..b2765e549786
--- /dev/null
+++ b/devel/mdds/Makefile~
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mdds
+# Date created: 2011-07-22
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mdds
+PORTVERSION= 0.5.3
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Multi-dimensional data index algorithm
+
+LICENSE= MIT
+
+PROJECTHOST= multidimalgorithm
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/mdds
+ @${MKDIR} ${PREFIX}/mdds/hash_container
+ @${INSTALL_DATA} ${WRKSRC}/include/mdds/*.hpp ${PREFIX}/mdds
+ @${INSTALL_DATA} ${WRKSRC}/include/mdds/*.inl ${PREFIX}/mdds
+ @${INSTALL_DATA} ${WRKSRC}/include/mdds/hash_container/*.hpp ${PREFIX}/mdds/hash_container
+
+.include <bsd.port.mk>
diff --git a/devel/mdds/distinfo b/devel/mdds/distinfo
new file mode 100644
index 000000000000..e5fc63222a4c
--- /dev/null
+++ b/devel/mdds/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mdds_0.5.3.tar.bz2) = a19205ac076973b55d9c5d3c8b664735d5b89fe793629ec10c110caa98e0bc1d
+SIZE (mdds_0.5.3.tar.bz2) = 92050
diff --git a/devel/mdds/pkg-descr b/devel/mdds/pkg-descr
new file mode 100644
index 000000000000..30ad61076ad9
--- /dev/null
+++ b/devel/mdds/pkg-descr
@@ -0,0 +1,3 @@
+A collection of multi-dimensional data structure and indexing algorithm.
+
+WWW: http://code.google.com/p/multidimalgorithm/
diff --git a/devel/mdds/pkg-plist b/devel/mdds/pkg-plist
new file mode 100644
index 000000000000..3be3713915f1
--- /dev/null
+++ b/devel/mdds/pkg-plist
@@ -0,0 +1,21 @@
+mdds/flat_segment_tree.hpp
+mdds/flat_segment_tree_def.inl
+mdds/flat_segment_tree_itr.hpp
+mdds/global.hpp
+mdds/hash_container/map.hpp
+mdds/mixed_type_matrix.hpp
+mdds/mixed_type_matrix_def.inl
+mdds/mixed_type_matrix_element.hpp
+mdds/mixed_type_matrix_flag_storage.hpp
+mdds/mixed_type_matrix_storage.hpp
+mdds/mixed_type_matrix_storage_filled_linear.inl
+mdds/mixed_type_matrix_storage_filled_nested_array.inl
+mdds/mixed_type_matrix_storage_sparse.inl
+mdds/node.hpp
+mdds/point_quad_tree.hpp
+mdds/quad_node.hpp
+mdds/rectangle_set.hpp
+mdds/rectangle_set_def.inl
+mdds/segment_tree.hpp
+@dirrmtry mdds/hash_container
+@dirrmtry mdds