aboutsummaryrefslogtreecommitdiff
path: root/devel/mdds
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2012-08-17 20:32:46 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2012-08-17 20:32:46 +0000
commit72826d2c943b75a1338a8d07bac1cf6d941bc136 (patch)
tree8bbea842cbdb9e39dc3d74f0fc09bb15d524dc11 /devel/mdds
parente450e8266c650e3fe371389587df9e99f372cbfd (diff)
downloadports-72826d2c943b75a1338a8d07bac1cf6d941bc136.tar.gz
ports-72826d2c943b75a1338a8d07bac1cf6d941bc136.zip
Notes
Diffstat (limited to 'devel/mdds')
-rw-r--r--devel/mdds/Makefile7
-rw-r--r--devel/mdds/distinfo4
-rw-r--r--devel/mdds/files/patch-include__mdds__mixed_type_matrix_storage.hpp13
-rw-r--r--devel/mdds/pkg-plist18
4 files changed, 33 insertions, 9 deletions
diff --git a/devel/mdds/Makefile b/devel/mdds/Makefile
index 47cc91177029..014cfe67f90b 100644
--- a/devel/mdds/Makefile
+++ b/devel/mdds/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mdds
-PORTVERSION= 0.5.4
-PORTREVISION= 1
+PORTVERSION= 0.6.0
CATEGORIES= devel
MASTER_SITES= GOOGLE_CODE
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -24,9 +23,11 @@ NO_BUILD= yes
do-install:
@${MKDIR} ${PREFIX}/include/mdds
- @${MKDIR} ${PREFIX}/include//mdds/hash_container
+ @${MKDIR} ${PREFIX}/include/mdds/compat
+ @${MKDIR} ${PREFIX}/include/mdds/hash_container
@${INSTALL_DATA} ${WRKSRC}/include/mdds/*.hpp ${PREFIX}/include/mdds
@${INSTALL_DATA} ${WRKSRC}/include/mdds/*.inl ${PREFIX}/include/mdds
+ @${INSTALL_DATA} ${WRKSRC}/include/mdds/compat/*.hpp ${PREFIX}/include/mdds/compat
@${INSTALL_DATA} ${WRKSRC}/include/mdds/hash_container/*.hpp ${PREFIX}/include/mdds/hash_container
.include <bsd.port.mk>
diff --git a/devel/mdds/distinfo b/devel/mdds/distinfo
index 3fa3213ba071..030557b558fc 100644
--- a/devel/mdds/distinfo
+++ b/devel/mdds/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mdds_0.5.4.tar.bz2) = 0f229706053e1d192351eab10b69ea6a356ac75ba460256930546fa41d25ae35
-SIZE (mdds_0.5.4.tar.bz2) = 92462
+SHA256 (mdds_0.6.0.tar.bz2) = 846200f5c8ddf34f86747fd4dc5feb5fea90e753639a7d5dbd3ccdce4467a67b
+SIZE (mdds_0.6.0.tar.bz2) = 123325
diff --git a/devel/mdds/files/patch-include__mdds__mixed_type_matrix_storage.hpp b/devel/mdds/files/patch-include__mdds__mixed_type_matrix_storage.hpp
new file mode 100644
index 000000000000..e74e8f792009
--- /dev/null
+++ b/devel/mdds/files/patch-include__mdds__mixed_type_matrix_storage.hpp
@@ -0,0 +1,13 @@
+--- include/mdds/mixed_type_matrix_storage.hpp.orig 2012-07-18 23:09:49.000000000 -0400
++++ include/mdds/mixed_type_matrix_storage.hpp 2012-08-09 14:14:09.000000000 -0400
+@@ -32,6 +32,10 @@
+
+ #include <boost/ptr_container/ptr_vector.hpp>
+ #include <boost/ptr_container/ptr_map.hpp>
++// Boost.Pool indirectly pulls in Boost.System, causing linking error
++// with Boost 1.50, because some (deprecated) symbols from System are
++// not found.
++#define BOOST_SYSTEM_NO_DEPRECATED
+ #include <boost/pool/object_pool.hpp>
+
+ namespace mdds {
diff --git a/devel/mdds/pkg-plist b/devel/mdds/pkg-plist
index 2fd159249ab5..dc4e7dd24cd6 100644
--- a/devel/mdds/pkg-plist
+++ b/devel/mdds/pkg-plist
@@ -1,21 +1,31 @@
+include/mdds/default_deleter.hpp
include/mdds/flat_segment_tree.hpp
include/mdds/flat_segment_tree_def.inl
include/mdds/flat_segment_tree_itr.hpp
include/mdds/global.hpp
-include/mdds/hash_container/map.hpp
include/mdds/mixed_type_matrix.hpp
include/mdds/mixed_type_matrix_def.inl
include/mdds/mixed_type_matrix_element.hpp
include/mdds/mixed_type_matrix_flag_storage.hpp
include/mdds/mixed_type_matrix_storage.hpp
include/mdds/mixed_type_matrix_storage_filled_linear.inl
-include/mdds/mixed_type_matrix_storage_filled_nested_array.inl
include/mdds/mixed_type_matrix_storage_sparse.inl
+include/mdds/multi_type_matrix.hpp
+include/mdds/multi_type_matrix_def.inl
+include/mdds/multi_type_vector.hpp
+include/mdds/multi_type_vector_def.inl
+include/mdds/multi_type_vector_itr.hpp
+include/mdds/multi_type_vector_macro.hpp
+include/mdds/multi_type_vector_trait.hpp
+include/mdds/multi_type_vector_types.hpp
include/mdds/node.hpp
include/mdds/point_quad_tree.hpp
include/mdds/quad_node.hpp
include/mdds/rectangle_set.hpp
include/mdds/rectangle_set_def.inl
include/mdds/segment_tree.hpp
-@dirrmtry include/mdds/hash_container
-@dirrmtry include/mdds
+include/mdds/compat/unique_ptr.hpp
+include/mdds/hash_container/map.hpp
+@dirrm include/mdds/hash_container
+@dirrm include/mdds/compat
+@dirrm include/mdds