aboutsummaryrefslogtreecommitdiff
path: root/devel/meta-cvs/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-12-04 17:36:37 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-12-04 17:36:37 +0000
commitd0333567de839abf771d3bb404b43e55562ded04 (patch)
tree8d269b1f76ba6bc1ad5862eb2b0c8deb5a0a2428 /devel/meta-cvs/Makefile
parent445f663a91055d82de79045356f860e680169070 (diff)
Notes
Diffstat (limited to 'devel/meta-cvs/Makefile')
-rw-r--r--devel/meta-cvs/Makefile49
1 files changed, 33 insertions, 16 deletions
diff --git a/devel/meta-cvs/Makefile b/devel/meta-cvs/Makefile
index b9749c12acd6..d32bfbb8dfad 100644
--- a/devel/meta-cvs/Makefile
+++ b/devel/meta-cvs/Makefile
@@ -6,39 +6,56 @@
#
PORTNAME= meta-cvs
-PORTVERSION= 1.0.13
-PORTREVISION= 3
+PORTVERSION= 1.1.98
CATEGORIES= devel
-MASTER_SITES= http://users.footprints.net/~kaz/
-DISTNAME= mcvs-${PORTVERSION}
+MASTER_SITES= http://common-lisp.net/project/meta-cvs/downloads/
MAINTAINER= gahr@FreeBSD.org
COMMENT= A more capable version control system than CVS, built around CVS
+OPTIONS= PDFDOC "Build PDF documentation" off
+
BUILD_DEPENDS= clisp:${PORTSDIR}/lang/clisp \
- ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall
-RUN_DEPENDS= clisp:${PORTSDIR}/lang/clisp \
- ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall
+ lndir:${PORTSDIR}/devel/lndir
+RUN_DEPENDS= clisp:${PORTSDIR}/lang/clisp
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/mcvs \
+ bin/mcvs-debug \
+ ${DATADIR:C/${PREFIX}\///}/mcvs.mem \
+ ${DATADIR:C/${PREFIX}\///}/mcvs-debug.mem
+PLIST_DIRS= ${DATADIR:C/${PREFIX}\///}
-USE_GETTEXT= yes
+PORTDOCS= Meta-CVS-PAPER \
+ PORTING \
+ QUICK-GUIDE \
+ SCRIPTING
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" && ${OSVERSION} >= 700000
-USE_GCC= 3.4
+.if !defined(WITHOUT_PDFDOC) && !defined(NOPORTDOCS)
+BUILD_DEPENDS+= pdflatex:${PORTSDIR}/print/teTeX-base
+PORTDOCS+= meta-cvs.pdf
.endif
post-patch:
- ${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
- ${CP} ${FILESDIR}/build.sh ${WRKSRC}/code
+ ${REINPLACE_CMD} -e '232s|make|${GMAKE}|g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|type -P|which|g;s|$$(prefix)/lib|${DATADIR}|g' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|libc.so.6|libc.so|' ${WRKSRC}/code/clisp-ffi.lisp
+ ${REINPLACE_CMD} -e '12s|latex|pdflatex|' ${WRKSRC}/docs/tex-manual/Makefile
post-install:
- ${SED} 's:PREFIX:${PREFIX}:g' ${FILESDIR}/mcvs.tmpl > ${WRKDIR}/mcvs
- ${INSTALL_SCRIPT} ${WRKDIR}/mcvs ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/Meta-CVS-PAPER ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/QUICK-GUIDE ${DOCSDIR}
+. if !defined(WITHOUT_PDFDOC)
+ (cd ${WRKSRC}/docs/tex-manual && ${GMAKE} && \
+ ${CP} ${WRKSRC}/docs/tex-manual/meta-cvs.pdf ${WRKSRC}/docs/misc-text-files)
+. endif
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/misc-text-files/${doc} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.post.mk>