aboutsummaryrefslogtreecommitdiff
path: root/devel/meta-cvs
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-12-04 17:36:37 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-12-04 17:36:37 +0000
commitd0333567de839abf771d3bb404b43e55562ded04 (patch)
tree8d269b1f76ba6bc1ad5862eb2b0c8deb5a0a2428 /devel/meta-cvs
parent445f663a91055d82de79045356f860e680169070 (diff)
Notes
Diffstat (limited to 'devel/meta-cvs')
-rw-r--r--devel/meta-cvs/Makefile49
-rw-r--r--devel/meta-cvs/distinfo6
-rw-r--r--devel/meta-cvs/files/Makefile9
-rw-r--r--devel/meta-cvs/files/build.sh24
-rw-r--r--devel/meta-cvs/files/mcvs.tmpl2
-rw-r--r--devel/meta-cvs/files/patch-Makefile22
-rw-r--r--devel/meta-cvs/files/patch-install.sh124
-rw-r--r--devel/meta-cvs/files/patch-unix.lisp12
-rw-r--r--devel/meta-cvs/pkg-descr2
-rw-r--r--devel/meta-cvs/pkg-plist8
10 files changed, 37 insertions, 221 deletions
diff --git a/devel/meta-cvs/Makefile b/devel/meta-cvs/Makefile
index b9749c12acd6..d32bfbb8dfad 100644
--- a/devel/meta-cvs/Makefile
+++ b/devel/meta-cvs/Makefile
@@ -6,39 +6,56 @@
#
PORTNAME= meta-cvs
-PORTVERSION= 1.0.13
-PORTREVISION= 3
+PORTVERSION= 1.1.98
CATEGORIES= devel
-MASTER_SITES= http://users.footprints.net/~kaz/
-DISTNAME= mcvs-${PORTVERSION}
+MASTER_SITES= http://common-lisp.net/project/meta-cvs/downloads/
MAINTAINER= gahr@FreeBSD.org
COMMENT= A more capable version control system than CVS, built around CVS
+OPTIONS= PDFDOC "Build PDF documentation" off
+
BUILD_DEPENDS= clisp:${PORTSDIR}/lang/clisp \
- ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall
-RUN_DEPENDS= clisp:${PORTSDIR}/lang/clisp \
- ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall
+ lndir:${PORTSDIR}/devel/lndir
+RUN_DEPENDS= clisp:${PORTSDIR}/lang/clisp
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/mcvs \
+ bin/mcvs-debug \
+ ${DATADIR:C/${PREFIX}\///}/mcvs.mem \
+ ${DATADIR:C/${PREFIX}\///}/mcvs-debug.mem
+PLIST_DIRS= ${DATADIR:C/${PREFIX}\///}
-USE_GETTEXT= yes
+PORTDOCS= Meta-CVS-PAPER \
+ PORTING \
+ QUICK-GUIDE \
+ SCRIPTING
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" && ${OSVERSION} >= 700000
-USE_GCC= 3.4
+.if !defined(WITHOUT_PDFDOC) && !defined(NOPORTDOCS)
+BUILD_DEPENDS+= pdflatex:${PORTSDIR}/print/teTeX-base
+PORTDOCS+= meta-cvs.pdf
.endif
post-patch:
- ${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
- ${CP} ${FILESDIR}/build.sh ${WRKSRC}/code
+ ${REINPLACE_CMD} -e '232s|make|${GMAKE}|g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|type -P|which|g;s|$$(prefix)/lib|${DATADIR}|g' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|libc.so.6|libc.so|' ${WRKSRC}/code/clisp-ffi.lisp
+ ${REINPLACE_CMD} -e '12s|latex|pdflatex|' ${WRKSRC}/docs/tex-manual/Makefile
post-install:
- ${SED} 's:PREFIX:${PREFIX}:g' ${FILESDIR}/mcvs.tmpl > ${WRKDIR}/mcvs
- ${INSTALL_SCRIPT} ${WRKDIR}/mcvs ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/Meta-CVS-PAPER ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/QUICK-GUIDE ${DOCSDIR}
+. if !defined(WITHOUT_PDFDOC)
+ (cd ${WRKSRC}/docs/tex-manual && ${GMAKE} && \
+ ${CP} ${WRKSRC}/docs/tex-manual/meta-cvs.pdf ${WRKSRC}/docs/misc-text-files)
+. endif
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/misc-text-files/${doc} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.post.mk>
diff --git a/devel/meta-cvs/distinfo b/devel/meta-cvs/distinfo
index f087ff6be72d..f2b42ca81e89 100644
--- a/devel/meta-cvs/distinfo
+++ b/devel/meta-cvs/distinfo
@@ -1,3 +1,3 @@
-MD5 (mcvs-1.0.13.tar.gz) = 46355633fb763214480978df88919e23
-SHA256 (mcvs-1.0.13.tar.gz) = 2b0dcc8787fdf2cfab047232c017c4488664926800da7ad8454f6f00b1da4b81
-SIZE (mcvs-1.0.13.tar.gz) = 129469
+MD5 (meta-cvs-1.1.98.tar.gz) = 1804561985990599b7c9f138b1b91e09
+SHA256 (meta-cvs-1.1.98.tar.gz) = 4f3351b0e545a728816f8fcaff1950032543efe53f2246b198b98fa514616966
+SIZE (meta-cvs-1.1.98.tar.gz) = 152231
diff --git a/devel/meta-cvs/files/Makefile b/devel/meta-cvs/files/Makefile
deleted file mode 100644
index 6dd3f6f04c54..000000000000
--- a/devel/meta-cvs/files/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-# $FreeBSD$
-
-all: meta-cvs
-
-meta-cvs:
- (cd code; /bin/sh build.sh)
-
-install:
- (cd code; /bin/sh install.sh ${PREFIX})
diff --git a/devel/meta-cvs/files/build.sh b/devel/meta-cvs/files/build.sh
deleted file mode 100644
index 43011043463f..000000000000
--- a/devel/meta-cvs/files/build.sh
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-CLISP_LIB=$(clisp -q -norc -x '(progn (princ *lib-directory*) (values))')
-
-LINKSET=unix-bindings-linking-set
-
-if [ ! -e $LINKSET ] ; then
- export CLISP_LINKKIT="${CLISP_LIB}linkkit"
- sh "${CLISP_LIB}clisp-link" add-module-set unix-bindings \
- "${CLISP_LIB}base" $LINKSET
-fi
-
-LISPRUN=$LINKSET/lisp.run
-
-if ! $LISPRUN -M $LINKSET/lispinit.mem -q -c mcvs-main ; then
- echo "There were compilation errors."
- exit 1
-fi
-
-$LISPRUN -M $LINKSET/lispinit.mem -q -i mcvs-main -x '(ext:saveinitmem "mcvs.mem" :quiet t)'
-
-exit 0
diff --git a/devel/meta-cvs/files/mcvs.tmpl b/devel/meta-cvs/files/mcvs.tmpl
deleted file mode 100644
index caf557726ee7..000000000000
--- a/devel/meta-cvs/files/mcvs.tmpl
+++ /dev/null
@@ -1,2 +0,0 @@
-#!PREFIX/lib/clisp/meta-cvs/lisp.run -MPREFIX/lib/clisp/meta-cvs/lispinit.mem
-(mcvs)
diff --git a/devel/meta-cvs/files/patch-Makefile b/devel/meta-cvs/files/patch-Makefile
deleted file mode 100644
index 66091a1aaf38..000000000000
--- a/devel/meta-cvs/files/patch-Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- code/unix-bindings/Makefile.orig 2003-01-16 06:06:09.000000000 +0100
-+++ code/unix-bindings/Makefile 2008-01-18 15:35:17.000000000 +0100
-@@ -1,18 +1,12 @@
- # Makefile for CLISP module set unix-bindings
-
--CC =
--CFLAGS =
--INCLUDES=
--
--CLISP =
--
- SHELL = /bin/sh
-
- unix.c : unix.lisp
- clisp -c unix.lisp
-
- unix.o : unix.c
-- $(CC) $(CFLAGS) -I$(INCLUDES) -c unix.c
-+ $(CC) $(CFLAGS) -I$(INCLUDES) -I${LOCALBASE}/include -c unix.c
-
- wrap.o : wrap.c
- $(CC) $(CFLAGS) -I$(INCLUDES) -c wrap.c
diff --git a/devel/meta-cvs/files/patch-install.sh b/devel/meta-cvs/files/patch-install.sh
deleted file mode 100644
index 586c0bd00308..000000000000
--- a/devel/meta-cvs/files/patch-install.sh
+++ /dev/null
@@ -1,124 +0,0 @@
-$FreeBSD$
-
---- code/install.sh.orig Thu Feb 13 19:30:54 2003
-+++ code/install.sh Thu Feb 13 19:31:01 2003
-@@ -51,12 +51,6 @@
- exit 1
- fi
-
--if [ ! -e $LINKSET ] ; then
-- export CLISP_LINKKIT="${CLISP_LIB}linkkit"
-- sh "${CLISP_LIB}clisp-link" add-module-set unix-bindings \
-- "${CLISP_LIB}base" $LINKSET
--fi
--
- LISPRUN=$LINKSET/lisp
-
- if [ -f $LISPRUN.run ] ; then
-@@ -65,18 +59,8 @@
- elif [ -f $LISPRUN.exe ] ; then
- LISPRUN=$LISPRUN.exe
- LISPEXE=.exe
--else
-- echo "linking set failed to build."
-- exit 1
--fi
--
--if ! $LISPRUN -M $LINKSET/lispinit.mem -q -c mcvs-main ; then
-- echo "There were compilation errors."
-- exit 1
- fi
-
--$LISPRUN -M $LINKSET/lispinit.mem -q -i mcvs-main -x '(ext:saveinitmem "mcvs.mem" :quiet t)'
--
- if ! cp mcvs.mem $TARGET_LIB/lispinit.mem; then
- echo "Unable to copy to $TARGET_LIB."
- exit 1
-@@ -84,87 +68,6 @@
-
- if ! cp $LISPRUN $TARGET_LIB; then
- echo "Unable to copy to $TARGET_LIB."
-- exit 1
--fi
--
--if ! cat > $TARGET_BIN/mcvs <<END
--#!$TARGET_LIB/lisp$LISPEXE -M$TARGET_LIB/lispinit.mem
--(mcvs)
--END
--then
-- echo "Could not create mcvs script in $TARGET."
-- exit 1
--fi
--
--if ! chmod a+x "$TARGET_BIN/mcvs" ; then
-- echo "Could not set permissions of mcvs script in $TARGET."
-- exit 1
--fi
--
--if ! cat > $TARGET_BIN/mcvs-upgrade <<END
--#!/bin/sh
--TARGET_LIB="$TARGET_LIB"
--LISPRUN="\$TARGET_LIB/lisp.run -M \$TARGET_LIB/lispinit.mem"
--
--if [ \$# != 1 ] ; then
-- echo
-- echo "Syntax:"
-- echo
-- echo " mcvs-upgrade <path-to-source>"
-- echo
-- echo "The path specifies the directory which holds unpacked Meta-CVS source,"
-- echo "the place where the file mcvs-main.lisp is located."
-- echo
-- echo "This upgrade mechanism is intended to make it possible to use a"
-- echo "newer version of Meta-CVS without having to obtain a complete binary"
-- echo "distribution that includes the Lisp executable, and without having"
-- echo "to install the Lisp development environment to build the sources."
-- echo
-- echo "Note that it's not possible to upgrade if the newer Meta-CVS sources"
-- echo "rely on new C functions being linked into the Lisp system; get a"
-- echo "new binary distribution, or set up CLISP and compile Meta-CVS from"
-- echo "the sources using its install.sh script"
-- echo
-- echo "Ignore the copious compiler warnings about objects and functions"
-- echo "being redefined; this is what we want."
-- echo
-- exit 1
--fi
--
--SOURCE_PATH="\$1"
--
--if ! cd "\$SOURCE_PATH" ; then
-- echo "unable to change to \$SOURCE_PATH"
-- exit 1
--fi
--
--if ! \$LISPRUN -c mcvs-main ; then
-- echo "unable to compile"
-- exit 1
--fi
--
--if ! \$LISPRUN -q -i mcvs-main -x '(ext:saveinitmem "mcvs.mem" :quiet t)' ; then
-- echo "unable to load and generate memory image"
-- exit 1
--fi
--
--if ! cp mcvs.mem \$TARGET_LIB/lispinit.mem ; then
-- echo "unable to copy new Meta-CVS image to \$TARGET_LIB directory."
-- exit 1
--fi
--
--echo
--echo "It appears that Meta-CVS has been re-generated from the given sources."
--echo
--
--END
--then
-- echo "Could not create mcvs script in $TARGET."
-- exit 1
--fi
--
--if ! chmod a+x "$TARGET_BIN/mcvs-upgrade" ; then
-- echo "Could not set permissions of mcvs script in $TARGET."
- exit 1
- fi
-
diff --git a/devel/meta-cvs/files/patch-unix.lisp b/devel/meta-cvs/files/patch-unix.lisp
deleted file mode 100644
index 576f2b202b6a..000000000000
--- a/devel/meta-cvs/files/patch-unix.lisp
+++ /dev/null
@@ -1,12 +0,0 @@
---- code/unix-bindings/unix.lisp~ 2004-01-08 16:34:05.000000000 +0100
-+++ code/unix-bindings/unix.lisp 2004-10-16 16:06:28.000000000 +0200
-@@ -38,7 +38,8 @@
- (defmacro def-c-call-out (sym &body args)
- `(def-call-out ,sym (:language :stdc) ,@args))
-
--#.(when (> (read-from-string (lisp-implementation-version)) 2.30)
-+#.(when (> (read-from-string (subseq (lisp-implementation-version)
-+ 0 4)) 2.30)
- (push :clisp-newer-than-2.30 *features*)
- (values))
-
diff --git a/devel/meta-cvs/pkg-descr b/devel/meta-cvs/pkg-descr
index 255fda99af55..8213c6a9c0e8 100644
--- a/devel/meta-cvs/pkg-descr
+++ b/devel/meta-cvs/pkg-descr
@@ -12,7 +12,7 @@ Its main features are:
* Tracking of third party code containing moves and renames.
* Ease of deployment.
-WWW: http://users.footprints.net/~kaz/mcvs.html
+WWW: http://common-lisp.net/project/meta-cvs/
- Johannes Groedem
johs@copyleft.no
diff --git a/devel/meta-cvs/pkg-plist b/devel/meta-cvs/pkg-plist
deleted file mode 100644
index 0b9396ea5fef..000000000000
--- a/devel/meta-cvs/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/mcvs
-lib/clisp/meta-cvs/lispinit.mem
-lib/clisp/meta-cvs/lisp.run
-@dirrm lib/clisp/meta-cvs
-@dirrmtry lib/clisp
-%%PORTDOCS%%%%DOCSDIR%%/Meta-CVS-PAPER
-%%PORTDOCS%%%%DOCSDIR%%/QUICK-GUIDE
-%%PORTDOCS%%@dirrm %%DOCSDIR%%