aboutsummaryrefslogtreecommitdiff
path: root/devel/mico
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-04-17 10:02:28 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-04-17 10:02:28 +0000
commitf0e098d9a06524a330f8e4c24d85dc7cb1ac9a9f (patch)
tree273d2f6afbef32b751a9105d864015c941356e77 /devel/mico
parentc444978d0bf7412c3d145b3c5c74defd1a3f25fb (diff)
downloadports-f0e098d9a06524a330f8e4c24d85dc7cb1ac9a9f.tar.gz
ports-f0e098d9a06524a330f8e4c24d85dc7cb1ac9a9f.zip
Notes
Diffstat (limited to 'devel/mico')
-rw-r--r--devel/mico/Makefile5
-rw-r--r--devel/mico/files/patch-configure.in13
2 files changed, 14 insertions, 4 deletions
diff --git a/devel/mico/Makefile b/devel/mico/Makefile
index 2076c217eea5..47ed6fa97e16 100644
--- a/devel/mico/Makefile
+++ b/devel/mico/Makefile
@@ -71,9 +71,10 @@ CONFIGURE_ARGS+= --with-gtk=${LOCALBASE}
MICO_GTK= "@comment "
.endif
.if ${PORT_OPTIONS:MTCL}
-LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83
+USE_TCL= yes
CONFIGURE_ARGS+= --with-tcl
-CPPFLAGS+= -I${LOCALBASE}/include/tcl8.3
+CPPFLAGS+= -I${TCL_INCLUDEDIR}
+LDFLAGS+= -L${LOCALBASE}/lib
.else
MICO_TCL= "@comment "
.endif
diff --git a/devel/mico/files/patch-configure.in b/devel/mico/files/patch-configure.in
index 5201e9abc8e1..4d90269d2ca8 100644
--- a/devel/mico/files/patch-configure.in
+++ b/devel/mico/files/patch-configure.in
@@ -1,5 +1,5 @@
---- configure.in.orig Sat Jul 22 15:43:10 2006
-+++ configure.in Sat Jul 22 15:43:37 2006
+--- configure.in.orig 2006-01-21 16:12:08.000000000 +0100
++++ configure.in 2013-04-17 11:45:36.000000000 +0200
@@ -605,7 +605,7 @@
# System dependencies.
#
@@ -18,3 +18,12 @@
fi
CONF_SHARED_CC="$CXX -shared"
+@@ -1082,7 +1082,7 @@
+ AC_GET_DEFINE(TCL_VERSION, TCL_VERSION, tcl.h)
+ if test X"$TCL_VERSION" != X; then
+ dnl # remove quotes if any
+- TCL_VERSION=`echo $TCL_VERSION | tr -d \"`
++ TCL_VERSION=`echo $TCL_VERSION | tr -d \" | tr -d \.`
+ TCL_LIBS=-ltcl$TCL_VERSION
+ HAVE_TCL=yes
+ AC_MSG_RESULT($TCL_VERSION)