aboutsummaryrefslogtreecommitdiff
path: root/devel/mico
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-02-25 05:38:13 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-02-25 05:38:13 +0000
commit9e504f8f2be8680f43b4ad75befcf3ec6cb8f503 (patch)
tree02859ff018a57c63f373de1627f5f43d5522ceb0 /devel/mico
parent9c04b872ba4fbefb170a2396a73475536978aff7 (diff)
downloadports-9e504f8f2be8680f43b4ad75befcf3ec6cb8f503.tar.gz
ports-9e504f8f2be8680f43b4ad75befcf3ec6cb8f503.zip
Notes
Diffstat (limited to 'devel/mico')
-rw-r--r--devel/mico/Makefile45
-rw-r--r--devel/mico/distinfo2
-rw-r--r--devel/mico/files/patch-fixes::lifecycle17
-rw-r--r--devel/mico/pkg-plist3
4 files changed, 49 insertions, 18 deletions
diff --git a/devel/mico/Makefile b/devel/mico/Makefile
index 3ab1d3742e25..bc2d625358d6 100644
--- a/devel/mico/Makefile
+++ b/devel/mico/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mico
PORTVERSION= 2.3.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.mico.org/:src \
http://www.ciam.ru/~sem/FreeBSD/:docs
@@ -23,12 +23,38 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 253
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+OPTIONS= SERVICES "Build with all services, not only ORB" on \
+ SSL "Build with SSL" on \
+ X11 "Build with X11 support" off \
+ QT "Build with QT support" off \
+ GTK "Build with GTK support" off \
+ SYSTEM_GCC "Build with system gcc. (Only for 4.x)" off \
+ DEBUG "Build debug version" off
+
+# stolen from bsd.port.mk (for OPTIONS works)
+PORT_DBDIR?= /var/db/ports
+
+OPTIONSFILE?= ${PORT_DBDIR}/${PORTNAME}/options
+.if exists(${OPTIONSFILE}) && !make(rmconfig)
+.include "${OPTIONSFILE}"
+.endif
+.if exists(${OPTIONSFILE}.local)
+.include "${OPTIONSFILE}.local"
+.endif
+# ================
+
.if !defined(WITH_SYSTEM_GCC)
USE_GCC= 3.3
.endif
CONFIGURE_ARGS= --enable-cd --disable-mini-stl --enable-threads
-.if !defined(WITHOUT_SERVICES)
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+.if defined(WITH_SERVICES)
CONFIGURE_ARGS+= --enable-ccm --enable-life --enable-externalize
.else
CONFIGURE_ARGS+= --disable-coss
@@ -74,8 +100,6 @@ CONFIGURE_ARGS+= --enable-ssl=${OPENSSLBASE}
CONFIGURE_ARGS+= --enable-csiv2 --enable-csl2
.endif
-.include <bsd.port.pre.mk>
-
PLIST_SUB+= MICO_X11=${MICO_X11} MICO_QT=${MICO_QT} MICO_GTK=${MICO_GTK} \
MICO_TCL=${MICO_TCL} MICO_SSL=${MICO_SSL} \
MICO_SERVICE=${MICO_SERVICE}
@@ -84,18 +108,7 @@ MAN1= idl.1 imr.1 nsadmin.1
MAN5= micorc.5
MAN8= ird.8 micod.8 nsd.8
-pre-fetch:
- @${ECHO_MSG} "============================================================================"
-.if ${OSVERSION} < 500035
- @${ECHO_MSG} "Use WITH_SYSTEM_GCC=yes to build Mico with system gcc."
- @${ECHO_MSG} ""
-.endif
- @${ECHO_MSG} "Following options are allowed:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "WITHOUT_SERVICES=yes - build without services, only ORB"
- @${ECHO_MSG} "WITHOUT_SSL=yes - build without SSL and security services"
- @${ECHO_MSG} "WITH_X11=yes, WITH_QT=yes, WITH_GTK=yes, WITH_TCL=yes"
- @${ECHO_MSG} "============================================================================"
+.include <bsd.port.pre.mk>
post-extract:
@${TAR} xzf ${DISTDIR}/doc-html.tar.gz -C ${WRKDIR}
diff --git a/devel/mico/distinfo b/devel/mico/distinfo
index 29f134227c65..a7d9822fb5ed 100644
--- a/devel/mico/distinfo
+++ b/devel/mico/distinfo
@@ -1,2 +1,4 @@
MD5 (mico-2.3.11.tar.gz) = 669d98ec5da2f6c50937a2a25e797eec
+SIZE (mico-2.3.11.tar.gz) = 2523850
MD5 (doc-html.tar.gz) = f32f618cfb2da541efd5dba50c3e2273
+SIZE (doc-html.tar.gz) = 133700
diff --git a/devel/mico/files/patch-fixes::lifecycle b/devel/mico/files/patch-fixes::lifecycle
index ff1b2b405c75..b41d6dc0cade 100644
--- a/devel/mico/files/patch-fixes::lifecycle
+++ b/devel/mico/files/patch-fixes::lifecycle
@@ -1,5 +1,5 @@
---- coss/lifecycle/Makefile.orig Fri Feb 14 13:55:55 2003
-+++ coss/lifecycle/Makefile Fri Jul 4 12:33:15 2003
+--- coss/lifecycle/Makefile.orig Mon Oct 13 13:49:23 2003
++++ coss/lifecycle/Makefile Sun Feb 15 21:15:07 2004
@@ -101,6 +101,8 @@
$(CXX) $(CXXFLAGS) $(LDFLAGS) genericfactory.o $(LDLIBS) -o genericfactory
$(POSTLD) $@
@@ -9,6 +9,19 @@
CosLifeCycle.h CosLifeCycle.cc: \
../../include/coss/CosLifeCycle.idl $(IDL)
$(IDL) $(IDLFLAGS) --name CosLifeCycle \
+@@ -149,6 +151,12 @@
+ $(IBINCMD) lifecontainmentd $(INSTDIR)/bin
+ $(IDIRCMD) $(INSTDIR)/bin
+ $(IBINCMD) lifereferenced $(INSTDIR)/bin
++ $(IDIRCMD) $(INSTDIR)/bin
++ $(IBINCMD) lifecriteriad $(INSTDIR)/bin
++ $(IDIRCMD) $(INSTDIR)/bin
++ $(IBINCMD) factoryfinderd $(INSTDIR)/bin
++ $(IDIRCMD) $(INSTDIR)/bin
++ $(IBINCMD) genericfactory $(INSTDIR)/bin
+
+
+ ifeq (.depend, $(wildcard .depend))
--- coss/lifecycle/FactoryFinder_impl.cc.orig Fri Jul 4 14:44:09 2003
+++ coss/lifecycle/FactoryFinder_impl.cc Fri Jul 4 16:44:03 2003
@@ -28,6 +28,8 @@
diff --git a/devel/mico/pkg-plist b/devel/mico/pkg-plist
index d8c270fb7e68..f2cc9c1e3d01 100644
--- a/devel/mico/pkg-plist
+++ b/devel/mico/pkg-plist
@@ -6,11 +6,14 @@
%%MICO_SERVICE%%bin/extcriteriad
%%MICO_SERVICE%%bin/extnoded
%%MICO_SERVICE%%bin/extreferenced
+%%MICO_SERVICE%%bin/factoryfinderd
+%%MICO_SERVICE%%bin/genericfactory
bin/idl
bin/imr
bin/iordump
bin/ird
%%MICO_SERVICE%%bin/lifecontainmentd
+%%MICO_SERVICE%%bin/lifecriteriad
%%MICO_SERVICE%%bin/lifenoded
%%MICO_SERVICE%%bin/lifereferenced
bin/mico-ar