aboutsummaryrefslogtreecommitdiff
path: root/devel/mime
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-31 00:47:29 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-31 00:47:29 +0000
commit10a73f5a159a66102c9189356fd8af12341012d4 (patch)
tree4dca281e66370e42af8896d2f909e0c5a6887ef6 /devel/mime
parent8a4f2e108e97d395d0915d90f43f22482107edd3 (diff)
downloadports-10a73f5a159a66102c9189356fd8af12341012d4.tar.gz
ports-10a73f5a159a66102c9189356fd8af12341012d4.zip
Notes
Diffstat (limited to 'devel/mime')
-rw-r--r--devel/mime/Makefile14
-rw-r--r--devel/mime/files/patch-header.c20
-rw-r--r--devel/mime/files/patch-message.c24
-rw-r--r--devel/mime/files/patch-util.c20
-rw-r--r--devel/mime/files/patch-util.h10
5 files changed, 76 insertions, 12 deletions
diff --git a/devel/mime/Makefile b/devel/mime/Makefile
index c66bef314405..f97dff887219 100644
--- a/devel/mime/Makefile
+++ b/devel/mime/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mime
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://resnet.uoregon.edu/~gurney_j/jmpc/dist/
@@ -18,16 +18,10 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 600034
-BROKEN= "Does not compile on FreeBSD >= 6.0"
-.endif
-
post-patch:
- ${REINPLACE_CMD} -e "s,-fpic,-fpic -fPIC,g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s,-fpic,-fpic -fPIC,g" ${WRKSRC}/Makefile.in
post-install:
- @ cd ${PREFIX}/lib ; ${LN} -sf libmime.so.1 libmime.so
+ @(cd ${PREFIX}/lib ; ${LN} -sf libmime.so.1 libmime.so )
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/mime/files/patch-header.c b/devel/mime/files/patch-header.c
new file mode 100644
index 000000000000..f28b35dc9ff5
--- /dev/null
+++ b/devel/mime/files/patch-header.c
@@ -0,0 +1,20 @@
+--- header.c.orig Sun Oct 30 23:37:49 2005
++++ header.c Sun Oct 30 23:38:13 2005
+@@ -67,7 +67,7 @@
+ alc = 0;
+
+ while (value < end) {
+- crlf = memmem(value, end - value, crlfpair, strlen(crlfpair));
++ crlf = memmemory(value, end - value, crlfpair, strlen(crlfpair));
+ if (crlf == NULL)
+ goto fv_error;
+
+@@ -123,7 +123,7 @@
+ * header line
+ */
+ colon = memchr(header, ':', end - header);
+- crlf = memmem(header, end - header, crlfpair, strlen(crlfpair));
++ crlf = memmemory(header, end - header, crlfpair, strlen(crlfpair));
+
+ if (colon == NULL || crlf == NULL || colon > crlf)
+ goto mph_error;
diff --git a/devel/mime/files/patch-message.c b/devel/mime/files/patch-message.c
index 7230dec6de2b..1a2571821c76 100644
--- a/devel/mime/files/patch-message.c
+++ b/devel/mime/files/patch-message.c
@@ -1,5 +1,25 @@
---- message.c.orig Sat Jun 12 22:24:35 2004
-+++ message.c Sat Jun 12 22:24:52 2004
+--- message.c.orig Tue Sep 16 03:37:19 2003
++++ message.c Sun Oct 30 23:38:44 2005
+@@ -89,7 +89,7 @@
+ * XXX - need to be fixed to support "\r\n"
+ */
+ bdcm = bd_makenorm(bd, crlfpair);
+- bdlc = memmem(pos, len - (pos - msg), bdcm, strlen(bdcm));
++ bdlc = memmemory(pos, len - (pos - msg), bdcm, strlen(bdcm));
+ free(bdcm);
+
+ if (bdlc != pos) {
+@@ -146,8 +146,8 @@
+ for (;;) {
+ ret = realloc(ret, sizeof *ret * *cnt + 1);
+
+- if ((next = memmem(msg, len, bdnorm, bdnormlen)) == NULL)
+- next = memmem(msg, len, bdtail, bdtaillen);
++ if ((next = memmemory(msg, len, bdnorm, bdnormlen)) == NULL)
++ next = memmemory(msg, len, bdtail, bdtaillen);
+
+ ret[(*cnt)++] = mime_readmessage(msg, next - msg, crlfpair);
+
@@ -272,6 +272,7 @@
eqcnt++;
break;
diff --git a/devel/mime/files/patch-util.c b/devel/mime/files/patch-util.c
new file mode 100644
index 000000000000..24a9b5eeca2a
--- /dev/null
+++ b/devel/mime/files/patch-util.c
@@ -0,0 +1,20 @@
+--- util.c.orig Sun Oct 30 23:38:55 2005
++++ util.c Sun Oct 30 23:39:26 2005
+@@ -31,7 +31,7 @@
+
+ #if 0
+ char *
+-memmem(const char *big, int blen, const char *lit, int llen)
++memmemory(const char *big, int blen, const char *lit, int llen)
+ {
+ const char *pos;
+
+@@ -61,7 +61,7 @@
+ }
+
+ const char *
+-memmem(const char *T, size_t n, const char *P, size_t m)
++memmemory(const char *T, size_t n, const char *P, size_t m)
+ {
+ static unsigned int q = 4294967291u;
+ static unsigned int d = 256;
diff --git a/devel/mime/files/patch-util.h b/devel/mime/files/patch-util.h
new file mode 100644
index 000000000000..20047f262028
--- /dev/null
+++ b/devel/mime/files/patch-util.h
@@ -0,0 +1,10 @@
+--- util.h.orig Sun Oct 30 23:39:40 2005
++++ util.h Sun Oct 30 23:39:56 2005
+@@ -30,6 +30,6 @@
+ #ifndef _UTIL_H_
+ #define _UTIL_H_
+
+-char *memmem(const char *, int, const char *, int);
++char *memmemory(const char *, int, const char *, int);
+
+ #endif