aboutsummaryrefslogtreecommitdiff
path: root/devel/mingw32-gcc/Makefile
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-01-29 14:10:05 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-01-29 14:10:05 +0000
commit48f3ac2a596e2fb74706bf3cfd8c2c724e31b7b1 (patch)
tree41bf34cd0a9fca65ab6fb747d5240c6d1a5287d0 /devel/mingw32-gcc/Makefile
parent4f60223fb89fcd277c09b9d5181c16e590cfb167 (diff)
Notes
Diffstat (limited to 'devel/mingw32-gcc/Makefile')
-rw-r--r--devel/mingw32-gcc/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index b4659ce6d904..ef179cbd9dce 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -8,8 +8,15 @@
PORTNAME= gcc
PORTVERSION= 2.95.2
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= gcc
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
+MASTER_SITE_SUBDIR= gcc/releases/${DISTNAME}
+DISTFILES= gcc-core-${PORTVERSION}${EXTRACT_SUFX} \
+ gcc-chill-${PORTVERSION}${EXTRACT_SUFX} \
+ gcc-g++-${PORTVERSION}${EXTRACT_SUFX} \
+ gcc-g77-${PORTVERSION}${EXTRACT_SUFX} \
+ gcc-java-${PORTVERSION}${EXTRACT_SUFX} \
+ gcc-objc-${PORTVERSION}${EXTRACT_SUFX}
+
PKGNAMEPREFIX= mingw-
PATCH_SITES= http://www.ab.wakwak.com/~tino/windows/
@@ -24,6 +31,7 @@ BUILD_DEPENDS= i386-mingw32msvc-as:${PORTSDIR}/devel/mingw-binutils \
RUN_DEPENDS= i386-mingw32msvc-as:${PORTSDIR}/devel/mingw-binutils \
mingwm10.dll:${PORTSDIR}/devel/mingw-bin-msvcrt
+USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=i386-mingw32msvc \