aboutsummaryrefslogtreecommitdiff
path: root/devel/mingw32-gcc
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-02-23 22:09:02 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-02-23 22:09:02 +0000
commita4d72ab3e4c622dedae9bc0a03e3e1d8fd6c0562 (patch)
treeb6c9e864264d52aa6f36494be499dcf1b7976da8 /devel/mingw32-gcc
parent1085ee534d4a8f5f6f7aee81b48cca6b40535679 (diff)
downloadports-a4d72ab3e4c622dedae9bc0a03e3e1d8fd6c0562.tar.gz
ports-a4d72ab3e4c622dedae9bc0a03e3e1d8fd6c0562.zip
Notes
Diffstat (limited to 'devel/mingw32-gcc')
-rw-r--r--devel/mingw32-gcc/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index a70e7f420eb4..4eb954d11382 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -69,6 +69,12 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION} GCC_TARG=${PKGNAMEPREFIX:S/-$//} \
BINARIES= gcc cpp g++ g77 gcov gcj gcjh jcf-dump jv-scan grepjar jar
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "ia64"
+BROKEN= "Does not compile on !i386 and !ia64"
+.endif
+
post-configure:
@${PERL} -pi.bak -e 's,^(TARGET_CONFIGDIRS\s*=\s*).+$$,\1libstdc++-v3 libf2c libobjc mingw,' ${WRKSRC}/Makefile
@${PERL} -pi.bak -e 's,^(install-info:),\1\ndonot-\1,' ${WRKSRC}/gcc/Makefile
@@ -80,4 +86,4 @@ post-install:
${PREFIX}/${PKGNAMEPREFIX:S/-$//}/bin/$F
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>