aboutsummaryrefslogtreecommitdiff
path: root/devel/monotone
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-10-17 06:16:04 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-10-17 06:16:04 +0000
commit1089faec533902a74bc138bab2407e28367cf609 (patch)
tree7ef11cbf7fb8d0355ecf378d60fb9b9f4e45c3cd /devel/monotone
parent9336f843a351c05ac8bbe91af21ba9e3538c6e51 (diff)
downloadports-1089faec533902a74bc138bab2407e28367cf609.tar.gz
ports-1089faec533902a74bc138bab2407e28367cf609.zip
Notes
Diffstat (limited to 'devel/monotone')
-rw-r--r--devel/monotone/Makefile4
-rw-r--r--devel/monotone/distinfo4
-rw-r--r--devel/monotone/files/patch-monotone.cc14
-rw-r--r--devel/monotone/files/patch-sanity.hh15
4 files changed, 11 insertions, 26 deletions
diff --git a/devel/monotone/Makefile b/devel/monotone/Makefile
index 07db5458dcfe..616fe14d858d 100644
--- a/devel/monotone/Makefile
+++ b/devel/monotone/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= monotone
-PORTVERSION= 0.22
+PORTVERSION= 0.23
CATEGORIES= devel
MASTER_SITES= http://www.venge.net/monotone/downloads/ \
http://norton.kettering.edu/freebsd/
-MAINTAINER= mwicks@kettering.edu
+MAINTAINER= lapo@lapo.it
COMMENT= A distributed version control system with digital signatures
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
diff --git a/devel/monotone/distinfo b/devel/monotone/distinfo
index ea7921f5123c..ea309e152306 100644
--- a/devel/monotone/distinfo
+++ b/devel/monotone/distinfo
@@ -1,2 +1,2 @@
-MD5 (monotone-0.22.tar.gz) = ee0f25577b8a640df3015113e67bb718
-SIZE (monotone-0.22.tar.gz) = 5038069
+MD5 (monotone-0.23.tar.gz) = 6d9e909480c2be0b23e2820c3a42e6f1
+SIZE (monotone-0.23.tar.gz) = 5300093
diff --git a/devel/monotone/files/patch-monotone.cc b/devel/monotone/files/patch-monotone.cc
index acdb4c2bfba7..03387326c2d1 100644
--- a/devel/monotone/files/patch-monotone.cc
+++ b/devel/monotone/files/patch-monotone.cc
@@ -1,13 +1,13 @@
---- monotone.cc.orig Fri Dec 31 03:16:53 2004
-+++ monotone.cc Wed Jan 26 22:20:17 2005
-@@ -140,8 +140,10 @@
+--- monotone.cc.orig Fri Sep 30 11:50:05 2005
++++ monotone.cc Fri Oct 14 11:31:14 2005
+@@ -238,8 +238,10 @@
+ // go-go gadget i18n
- setlocale(LC_CTYPE, "");
- setlocale(LC_MESSAGES, "");
+ setlocale(LC_ALL, "");
+#ifdef ENABLE_NLS
bindtextdomain(PACKAGE, LOCALEDIR);
textdomain(PACKAGE);
+#endif
- L(F("set locale: LC_CTYPE=%s, LC_MESSAGES=%s\n")
- % (setlocale(LC_CTYPE, NULL) == NULL ? "n/a" : setlocale(LC_CTYPE, NULL))
+
+ // we want to catch any early informative_failures due to charset
diff --git a/devel/monotone/files/patch-sanity.hh b/devel/monotone/files/patch-sanity.hh
deleted file mode 100644
index f0c21ba0cc83..000000000000
--- a/devel/monotone/files/patch-sanity.hh
+++ /dev/null
@@ -1,15 +0,0 @@
---- sanity.hh.orig Fri Dec 31 03:16:54 2004
-+++ sanity.hh Wed Jan 26 22:20:17 2005
-@@ -64,7 +64,12 @@
- extern sanity global_sanity;
-
- // F is for when you want to build a boost formatter
-+#ifdef ENABLE_NLS
- #define F(str) boost::format(gettext(str))
-+#else
-+#define F(str) boost::format((str))
-+#endif
-+
-
- // L is for logging, you can log all you want
- #define L(fmt) global_sanity.log(fmt, __FILE__, __LINE__)