aboutsummaryrefslogtreecommitdiff
path: root/devel/motor
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-02-21 00:15:07 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-02-21 00:15:07 +0000
commitd07e4e801e97b789838e5eb6cfabbce757f72da3 (patch)
tree315a1de67a7546411cff743fc5354579226c4a10 /devel/motor
parentc4e3c399f3c64a3b8f8a3d91ff6c738674ed04c7 (diff)
Add motor 2.6.3, a powerful text mode based programming IDE.
Notes
Notes: svn path=/head/; revision=38533
Diffstat (limited to 'devel/motor')
-rw-r--r--devel/motor/Makefile22
-rw-r--r--devel/motor/distinfo1
-rw-r--r--devel/motor/files/patch-configure16
-rw-r--r--devel/motor/files/patch-po::Makefile.in14
-rw-r--r--devel/motor/files/patch-src::Makefile.in14
-rw-r--r--devel/motor/pkg-comment1
-rw-r--r--devel/motor/pkg-descr6
-rw-r--r--devel/motor/pkg-plist34
8 files changed, 108 insertions, 0 deletions
diff --git a/devel/motor/Makefile b/devel/motor/Makefile
new file mode 100644
index 000000000000..b09710fdca37
--- /dev/null
+++ b/devel/motor/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: motor
+# Date created: 20 February 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= motor
+PORTVERSION= 2.6.3
+CATEGORIES= devel
+MASTER_SITES= http://konst.org.ua/download/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS}" \
+ LOCALBASE="${LOCALBASE}"
+
+.include <bsd.port.mk>
diff --git a/devel/motor/distinfo b/devel/motor/distinfo
new file mode 100644
index 000000000000..0ad84f7c26cc
--- /dev/null
+++ b/devel/motor/distinfo
@@ -0,0 +1 @@
+MD5 (motor-2.6.3.tar.gz) = 4d3ac7566c8d90efc96f0b4a18f152dc
diff --git a/devel/motor/files/patch-configure b/devel/motor/files/patch-configure
new file mode 100644
index 000000000000..5d7481eb2b81
--- /dev/null
+++ b/devel/motor/files/patch-configure
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- configure.orig Tue Feb 20 09:42:20 2001
++++ configure Wed Feb 21 00:26:08 2001
+@@ -563,8 +563,8 @@
+ FreeBSD*)
+ echo "$ac_t""freebsd" 1>&6
+ if test -z "$GCC"; then
+- LDFLAGS="-L/usr/local/lib -lintl"
+- CPPFLAGS="-I/usr/local/include"
++ LDFLAGS="-L${LOCALBASE}/lib -lintl"
++ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
+ fi
+ ;;
+
diff --git a/devel/motor/files/patch-po::Makefile.in b/devel/motor/files/patch-po::Makefile.in
new file mode 100644
index 000000000000..7269faa8159b
--- /dev/null
+++ b/devel/motor/files/patch-po::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- po/Makefile.in 2001/02/20 22:35:16 1.1
++++ po/Makefile.in 2001/02/20 22:36:03
+@@ -23,7 +23,7 @@
+ for i in $(LANGS); do msgfmt -o $$i.mo $$i.po; done
+
+ install:
+- for i in $(LANGS); do install -D -m 644 $$i.mo ${datadir}/locale/$$i/LC_MESSAGES/motor.mo; done
++ for i in $(LANGS); do install -c -D -m 644 $$i.mo ${datadir}/locale/$$i/LC_MESSAGES/motor.mo; done
+
+ uninstall:
+ find ${datadir}/locale/ -name motor.mo -exec rm -f {} \;
diff --git a/devel/motor/files/patch-src::Makefile.in b/devel/motor/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..aae097477f5e
--- /dev/null
+++ b/devel/motor/files/patch-src::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/Makefile.in 2001/02/20 22:38:22 1.1
++++ src/Makefile.in 2001/02/20 22:38:53
+@@ -51,7 +51,7 @@
+ $(CXX) @CPPFLAGS@ $*.cc -c $(INCLUDE) "-DVERSION=\"$(VERSION)\"" "-DSHAREDIR=\"@CONFIG_MOTOR_SHAREDIR@\"" "-DMAKECMD=\"$(MAKE)\"" -o $*.o
+
+ install:
+- install -Ds motor $(bindir)/$(PROG)
++ install -c -Ds motor $(bindir)/$(PROG)
+ mkdir -p $(datadir)/$(PROG)/
+ cp -R ../share/* ../COPYING $(datadir)/$(PROG)
+
diff --git a/devel/motor/pkg-comment b/devel/motor/pkg-comment
new file mode 100644
index 000000000000..b8a861ebba97
--- /dev/null
+++ b/devel/motor/pkg-comment
@@ -0,0 +1 @@
+A powerful text mode based programming IDE
diff --git a/devel/motor/pkg-descr b/devel/motor/pkg-descr
new file mode 100644
index 000000000000..907533674cdf
--- /dev/null
+++ b/devel/motor/pkg-descr
@@ -0,0 +1,6 @@
+Motor is a text mode based programming environment for *nix. It
+consists of a powerful editor with syntax highlight, project
+manager, makefile generator, gcc and gdb front-end, etc. Deep CVS
+integration is also provided.
+
+WWW: http://konst.org.ua/motor/
diff --git a/devel/motor/pkg-plist b/devel/motor/pkg-plist
new file mode 100644
index 000000000000..73789d08b60c
--- /dev/null
+++ b/devel/motor/pkg-plist
@@ -0,0 +1,34 @@
+bin/motor
+share/locale/pl/LC_MESSAGES/motor.mo
+share/locale/ru/LC_MESSAGES/motor.mo
+share/motor/COPYING
+share/motor/external
+share/motor/syntax
+share/motor/templates/library/static/Browser
+share/motor/templates/library/static/Buildrules
+share/motor/templates/library/static/Folders
+share/motor/templates/library/static/Makefile
+share/motor/templates/library/static/rpm.Dist
+share/motor/templates/library/static/tar.gz.Dist
+share/motor/templates/terminal program/C++/Browser
+share/motor/templates/terminal program/C++/Buildrules
+share/motor/templates/terminal program/C++/Folders
+share/motor/templates/terminal program/C++/Makefile
+share/motor/templates/terminal program/C++/[value name].cc.tmpl
+share/motor/templates/terminal program/C++/rpm.Dist
+share/motor/templates/terminal program/C++/tar.gz.Dist
+share/motor/templates/terminal program/C/Browser
+share/motor/templates/terminal program/C/Buildrules
+share/motor/templates/terminal program/C/Folders
+share/motor/templates/terminal program/C/Makefile
+share/motor/templates/terminal program/C/[value name].c.tmpl
+share/motor/templates/terminal program/C/rpm.Dist
+share/motor/templates/terminal program/C/tar.gz.Dist
+share/motor/themes
+@dirrm share/motor/templates/terminal program/C++
+@dirrm share/motor/templates/terminal program/C
+@dirrm share/motor/templates/terminal program
+@dirrm share/motor/templates/library/static
+@dirrm share/motor/templates/library
+@dirrm share/motor/templates
+@dirrm share/motor