aboutsummaryrefslogtreecommitdiff
path: root/devel/motor
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-04-17 14:18:55 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-04-17 14:18:55 +0000
commit1a524f5a1f9d6840016d230a4c3494ca8c8c7e64 (patch)
treecbfdb4eed2cf61d31d80829d9b96823c5bb49f3f /devel/motor
parent202b5ccddb900f6c85ce963244cb423543167b32 (diff)
downloadports-1a524f5a1f9d6840016d230a4c3494ca8c8c7e64.tar.gz
ports-1a524f5a1f9d6840016d230a4c3494ca8c8c7e64.zip
Notes
Diffstat (limited to 'devel/motor')
-rw-r--r--devel/motor/Makefile9
-rw-r--r--devel/motor/distinfo2
-rw-r--r--devel/motor/files/patch-configure16
-rw-r--r--devel/motor/files/patch-ktools::src::Makefile.in14
-rw-r--r--devel/motor/files/patch-po::Makefile.in14
-rw-r--r--devel/motor/files/patch-src::Makefile.in35
-rw-r--r--devel/motor/pkg-plist43
7 files changed, 76 insertions, 57 deletions
diff --git a/devel/motor/Makefile b/devel/motor/Makefile
index 226cb996ccb9..95c0e91fda21 100644
--- a/devel/motor/Makefile
+++ b/devel/motor/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= motor
-PORTVERSION= 2.6.3
+PORTVERSION= 2.15.7
CATEGORIES= devel
-MASTER_SITES= http://konst.org.ua/download/ \
+MASTER_SITES= http://download.konst.org.ua/ \
+ http://konst.org.ua/download/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= sobomax
@@ -18,7 +19,7 @@ LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS}" \
- LOCALBASE="${LOCALBASE}"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
.include <bsd.port.mk>
diff --git a/devel/motor/distinfo b/devel/motor/distinfo
index 0ad84f7c26cc..03a78bd2f8c8 100644
--- a/devel/motor/distinfo
+++ b/devel/motor/distinfo
@@ -1 +1 @@
-MD5 (motor-2.6.3.tar.gz) = 4d3ac7566c8d90efc96f0b4a18f152dc
+MD5 (motor-2.15.7.tar.gz) = f5f39813f996ab51e23db0451fef689a
diff --git a/devel/motor/files/patch-configure b/devel/motor/files/patch-configure
deleted file mode 100644
index 5d7481eb2b81..000000000000
--- a/devel/motor/files/patch-configure
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig Tue Feb 20 09:42:20 2001
-+++ configure Wed Feb 21 00:26:08 2001
-@@ -563,8 +563,8 @@
- FreeBSD*)
- echo "$ac_t""freebsd" 1>&6
- if test -z "$GCC"; then
-- LDFLAGS="-L/usr/local/lib -lintl"
-- CPPFLAGS="-I/usr/local/include"
-+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
-+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
- fi
- ;;
-
diff --git a/devel/motor/files/patch-ktools::src::Makefile.in b/devel/motor/files/patch-ktools::src::Makefile.in
new file mode 100644
index 000000000000..e46856e60cc6
--- /dev/null
+++ b/devel/motor/files/patch-ktools::src::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ktools/src/Makefile.in 2001/04/17 13:43:29 1.1
++++ ktools/src/Makefile.in 2001/04/17 13:43:36
+@@ -88,7 +88,7 @@
+ noinst_LIBRARIES = libkonst.a
+ libkonst_a_SOURCES = konst.d.cc konst.fs.cc konst.list.cc konst.logic.cc konst.process.cc konst.socket.cc konst.string.cc konst.ui.edit.cc konst.ui.fm.cc konst.ui.func.cc konst.ui.horbar.cc konst.ui.input.cc konst.ui.menu.cc konst.ui.skel.cc konst.ui.text.cc konst.ui.tree.cc konst.ui.window.cc konst.ui.dlg.cc
+ EXTRA_DIST = konst.d.cc konst.fs.cc konst.list.cc konst.logic.cc konst.process.cc konst.socket.cc konst.string.cc konst.ui.edit.cc konst.ui.fm.cc konst.ui.func.cc konst.ui.horbar.cc konst.ui.input.cc konst.ui.menu.cc konst.ui.skel.cc konst.ui.text.cc konst.ui.tree.cc konst.ui.window.cc konst.ui.dlg.cc
+-CXXFLAGS = -g
++#CXXFLAGS = -g
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/devel/motor/files/patch-po::Makefile.in b/devel/motor/files/patch-po::Makefile.in
deleted file mode 100644
index 7269faa8159b..000000000000
--- a/devel/motor/files/patch-po::Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- po/Makefile.in 2001/02/20 22:35:16 1.1
-+++ po/Makefile.in 2001/02/20 22:36:03
-@@ -23,7 +23,7 @@
- for i in $(LANGS); do msgfmt -o $$i.mo $$i.po; done
-
- install:
-- for i in $(LANGS); do install -D -m 644 $$i.mo ${datadir}/locale/$$i/LC_MESSAGES/motor.mo; done
-+ for i in $(LANGS); do install -c -D -m 644 $$i.mo ${datadir}/locale/$$i/LC_MESSAGES/motor.mo; done
-
- uninstall:
- find ${datadir}/locale/ -name motor.mo -exec rm -f {} \;
diff --git a/devel/motor/files/patch-src::Makefile.in b/devel/motor/files/patch-src::Makefile.in
index aae097477f5e..b2bccb83d771 100644
--- a/devel/motor/files/patch-src::Makefile.in
+++ b/devel/motor/files/patch-src::Makefile.in
@@ -1,14 +1,31 @@
$FreeBSD$
---- src/Makefile.in 2001/02/20 22:38:22 1.1
-+++ src/Makefile.in 2001/02/20 22:38:53
-@@ -51,7 +51,7 @@
- $(CXX) @CPPFLAGS@ $*.cc -c $(INCLUDE) "-DVERSION=\"$(VERSION)\"" "-DSHAREDIR=\"@CONFIG_MOTOR_SHAREDIR@\"" "-DMAKECMD=\"$(MAKE)\"" -o $*.o
+--- src/Makefile.in.orig Mon Apr 16 23:04:06 2001
++++ src/Makefile.in Tue Apr 17 16:50:15 2001
+@@ -61,6 +61,7 @@
+ CATOBJEXT = @CATOBJEXT@
+ CC = @CC@
+ CXX = @CXX@
++CPPFLAGS = @CPPFLAGS@
+ DATADIRNAME = @DATADIRNAME@
+ GENCAT = @GENCAT@
+ GMOFILES = @GMOFILES@
+@@ -85,7 +86,7 @@
+ l = @l@
- install:
-- install -Ds motor $(bindir)/$(PROG)
-+ install -c -Ds motor $(bindir)/$(PROG)
- mkdir -p $(datadir)/$(PROG)/
- cp -R ../share/* ../COPYING $(datadir)/$(PROG)
+ INCLUDES = -I../include -I../ktools/include -I../parser/include -I$(top_srcdir)/intl
+-CPPFLAGS = -DSHARE_DIR=\"$(pkgdatadir)\" -DLOCALE_DIR=\"$(datadir)/locale\"
++CPPFLAGS += -DSHARE_DIR=\"$(pkgdatadir)\" -DLOCALE_DIR=\"$(datadir)/locale\"
+ bin_PROGRAMS = motor
+
+@@ -93,7 +94,7 @@
+
+
+ motor_LDADD = -lcurses ../parser/src/libparser.a ../ktools/src/libkonst.a @INTLLIBS@ @LIBS@
+-CXXFLAGS = -g
++#CXXFLAGS = -g
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/devel/motor/pkg-plist b/devel/motor/pkg-plist
index 73789d08b60c..08b04d487e2d 100644
--- a/devel/motor/pkg-plist
+++ b/devel/motor/pkg-plist
@@ -1,30 +1,47 @@
bin/motor
+share/locale/de/LC_MESSAGES/motor.mo
share/locale/pl/LC_MESSAGES/motor.mo
share/locale/ru/LC_MESSAGES/motor.mo
-share/motor/COPYING
+share/locale/zh_CN/LC_MESSAGES/motor.mo
share/motor/external
share/motor/syntax
share/motor/templates/library/static/Browser
-share/motor/templates/library/static/Buildrules
+share/motor/templates/library/static/Debug
+share/motor/templates/library/static/Dist
share/motor/templates/library/static/Folders
-share/motor/templates/library/static/Makefile
-share/motor/templates/library/static/rpm.Dist
-share/motor/templates/library/static/tar.gz.Dist
+share/motor/templates/library/static/Makefile.func
+share/motor/templates/library/static/Parserules
+share/motor/templates/library/static/[value name].spec.tmpl
+share/motor/templates/library/static/configure.in.tmpl
share/motor/templates/terminal program/C++/Browser
-share/motor/templates/terminal program/C++/Buildrules
+share/motor/templates/terminal program/C++/Debug
+share/motor/templates/terminal program/C++/Dist
share/motor/templates/terminal program/C++/Folders
-share/motor/templates/terminal program/C++/Makefile
+share/motor/templates/terminal program/C++/Makefile.func
+share/motor/templates/terminal program/C++/Parserules
share/motor/templates/terminal program/C++/[value name].cc.tmpl
-share/motor/templates/terminal program/C++/rpm.Dist
-share/motor/templates/terminal program/C++/tar.gz.Dist
+share/motor/templates/terminal program/C++/[value name].spec.tmpl
+share/motor/templates/terminal program/C++/configure.in.tmpl
share/motor/templates/terminal program/C/Browser
-share/motor/templates/terminal program/C/Buildrules
+share/motor/templates/terminal program/C/Debug
+share/motor/templates/terminal program/C/Dist
share/motor/templates/terminal program/C/Folders
-share/motor/templates/terminal program/C/Makefile
+share/motor/templates/terminal program/C/Makefile.func
+share/motor/templates/terminal program/C/Parserules
share/motor/templates/terminal program/C/[value name].c.tmpl
-share/motor/templates/terminal program/C/rpm.Dist
-share/motor/templates/terminal program/C/tar.gz.Dist
+share/motor/templates/terminal program/C/[value name].spec.tmpl
+share/motor/templates/terminal program/C/configure.in.tmpl
+share/motor/templates/terminal program/java/Browser
+share/motor/templates/terminal program/java/Debug
+share/motor/templates/terminal program/java/Dist
+share/motor/templates/terminal program/java/Folders
+share/motor/templates/terminal program/java/Makefile.func
+share/motor/templates/terminal program/java/Parserules
+share/motor/templates/terminal program/java/[value name].java.tmpl
+share/motor/templates/terminal program/java/[value name].spec.tmpl
+share/motor/templates/terminal program/java/configure.in.tmpl
share/motor/themes
+@dirrm share/motor/templates/terminal program/java
@dirrm share/motor/templates/terminal program/C++
@dirrm share/motor/templates/terminal program/C
@dirrm share/motor/templates/terminal program