aboutsummaryrefslogtreecommitdiff
path: root/devel/mprof
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-18 19:48:01 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-18 19:48:01 +0000
commita642acc639938f86a7d57ab061ce1307b4dad42d (patch)
tree6bd650c43faa01e34a002eeb71e19033bd72f9df /devel/mprof
parentf97133a3b0072303ce9bad597fc6b62f1db294cf (diff)
downloadports-a642acc639938f86a7d57ab061ce1307b4dad42d.tar.gz
ports-a642acc639938f86a7d57ab061ce1307b4dad42d.zip
Notes
Diffstat (limited to 'devel/mprof')
-rw-r--r--devel/mprof/Makefile8
-rw-r--r--devel/mprof/files/patch-malloc.c11
2 files changed, 12 insertions, 7 deletions
diff --git a/devel/mprof/Makefile b/devel/mprof/Makefile
index 0334dd91bf24..0b65d63e49e5 100644
--- a/devel/mprof/Makefile
+++ b/devel/mprof/Makefile
@@ -21,15 +21,9 @@ MAKEFILE= Makefile.i386
MAN1= mprof.1
PLIST_FILES= bin/mprof lib/libc_mp.a
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mprof ${PREFIX}/bin
${INSTALL} ${COPY} -m 555 ${WRKSRC}/libc_mp.a ${PREFIX}/lib
${INSTALL_MAN} ${WRKSRC}/mprof.1 ${PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/mprof/files/patch-malloc.c b/devel/mprof/files/patch-malloc.c
new file mode 100644
index 000000000000..5dc8171ff646
--- /dev/null
+++ b/devel/mprof/files/patch-malloc.c
@@ -0,0 +1,11 @@
+--- malloc.c.orig Wed Apr 21 04:36:17 1993
++++ malloc.c Tue Jun 19 02:43:44 2007
+@@ -261,6 +261,8 @@
+ */
+ int realloc_srchlen = 4; /* 4 should be plenty, -1 =>'s whole list */
+
++static findbucket(union overhead *, int srchlen);
++
+ char *
+ realloc(cp, nbytes)
+ char *cp;