aboutsummaryrefslogtreecommitdiff
path: root/devel/nant
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-07-10 22:41:56 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-07-10 22:41:56 +0000
commit3dc58baf24b53cfa520aecdcbc57e2c85cf49c9f (patch)
treeffb60f2f6a67000f33e80db6d24bc7d6d8b9406a /devel/nant
parent898c84cdf7f51ada025ec303f32c4f6716f02be6 (diff)
downloadports-3dc58baf24b53cfa520aecdcbc57e2c85cf49c9f.tar.gz
ports-3dc58baf24b53cfa520aecdcbc57e2c85cf49c9f.zip
Notes
Diffstat (limited to 'devel/nant')
-rw-r--r--devel/nant/Makefile45
-rw-r--r--devel/nant/distinfo2
-rw-r--r--devel/nant/pkg-descr16
-rw-r--r--devel/nant/pkg-plist492
4 files changed, 555 insertions, 0 deletions
diff --git a/devel/nant/Makefile b/devel/nant/Makefile
new file mode 100644
index 000000000000..4805702fb36b
--- /dev/null
+++ b/devel/nant/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: NAnt
+# Date created: 2005-5-21
+# Whom: Christopher Nehren <apeiron+ports@coitusmentis.info>
+#
+# $Id: Makefile,v 1.7 2005/07/10 22:29:48 mezz7 Exp $
+# $FreeBSD$
+#
+
+PORTNAME= nant
+DISTVERSION= 0.85r3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-0.85-rc3-src
+
+MAINTAINER= apeiron+ports@coitusmentis.info
+COMMENT= A .NET build tool inspired by Ant
+
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
+RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+MAKE_ENV= MONO_PATH=${WRKSRC}/lib
+INSTALL_TARGET= install prefix=${PREFIX}
+
+post-patch:
+ @${FIND} ${WRKSRC}/src ${WRKSRC}/tests -name '*.build' | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|warnaserror="true"|warnaserror="false"|g;'
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc; ${FIND} . \
+ | ${CPIO} -pdmv -R ${DOCOWN}:${DOCGRP} ${DOCSDIR}
+ @${CHMOD} -R ugo-w,ugo+rX ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples; ${FIND} . \
+ | ${CPIO} -pdmv -R ${DOCOWN}:${DOCGRP} ${EXAMPLESDIR}
+ @${CHMOD} -R ugo-w,ugo+rX ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/nant/distinfo b/devel/nant/distinfo
new file mode 100644
index 000000000000..7a05c1e81b8e
--- /dev/null
+++ b/devel/nant/distinfo
@@ -0,0 +1,2 @@
+MD5 (nant-0.85-rc3-src.tar.gz) = 64867347ec78a0e67f8e510fa5e14ac9
+SIZE (nant-0.85-rc3-src.tar.gz) = 1965686
diff --git a/devel/nant/pkg-descr b/devel/nant/pkg-descr
new file mode 100644
index 000000000000..8deecb0e6aa9
--- /dev/null
+++ b/devel/nant/pkg-descr
@@ -0,0 +1,16 @@
+What is it?
+-----------
+NAnt is a .NET based build tool. In theory it is kind of like make without
+make's wrinkles. In practice it's a lot like Ant.
+
+If you are not familiar with Jakarta Ant you can get more information at the
+Ant project web site (http://ant.apache.org/).
+
+
+Why NAnt?
+---------
+Because Ant was too Java specific.
+Because Ant needed the Java runtime. NAnt only needs the .NET
+or Mono runtime.
+
+WWW: http://nant.sourceforge.net/
diff --git a/devel/nant/pkg-plist b/devel/nant/pkg-plist
new file mode 100644
index 000000000000..4b46220cfa73
--- /dev/null
+++ b/devel/nant/pkg-plist
@@ -0,0 +1,492 @@
+bin/nant
+share/NAnt/bin/NAnt.CompressionTasks.dll
+share/NAnt/bin/NAnt.CompressionTasks.dll.mdb
+share/NAnt/bin/NAnt.CompressionTasks.xml
+share/NAnt/bin/NAnt.Core.dll
+share/NAnt/bin/NAnt.Core.dll.mdb
+share/NAnt/bin/NAnt.Core.xml
+share/NAnt/bin/NAnt.DotNetTasks.dll
+share/NAnt/bin/NAnt.DotNetTasks.dll.mdb
+share/NAnt/bin/NAnt.DotNetTasks.xml
+share/NAnt/bin/NAnt.NUnit.dll
+share/NAnt/bin/NAnt.NUnit.dll.mdb
+share/NAnt/bin/NAnt.NUnit.xml
+share/NAnt/bin/NAnt.NUnit1Tasks.dll
+share/NAnt/bin/NAnt.NUnit1Tasks.dll.mdb
+share/NAnt/bin/NAnt.NUnit1Tasks.xml
+share/NAnt/bin/NAnt.NUnit2Tasks.dll
+share/NAnt/bin/NAnt.NUnit2Tasks.dll.mdb
+share/NAnt/bin/NAnt.NUnit2Tasks.xml
+share/NAnt/bin/NAnt.Resources.dll
+share/NAnt/bin/NAnt.SourceControlTasks.dll
+share/NAnt/bin/NAnt.SourceControlTasks.dll.mdb
+share/NAnt/bin/NAnt.SourceControlTasks.xml
+share/NAnt/bin/NAnt.exe
+share/NAnt/bin/NAnt.exe.config
+share/NAnt/bin/NAnt.exe.mdb
+share/NAnt/bin/NAnt.xml
+share/NAnt/bin/lib/ICSharpCode.SharpCvsLib.Console.dll
+share/NAnt/bin/lib/ICSharpCode.SharpCvsLib.dll
+share/NAnt/bin/lib/ICSharpCode.SharpZipLib.dll
+share/NAnt/bin/lib/NUnitCore.dll
+share/NAnt/bin/lib/mono/1.0/NDoc.Core.dll
+share/NAnt/bin/lib/mono/1.0/NDoc.Documenter.Msdn.dll
+share/NAnt/bin/lib/mono/1.0/NDoc.ExtendedUI.dll
+share/NAnt/bin/lib/mono/1.0/nunit.core.dll
+share/NAnt/bin/lib/mono/1.0/nunit.framework.dll
+share/NAnt/bin/lib/mono/1.0/nunit.util.dll
+share/NAnt/bin/lib/mono/2.0/NDoc.Core.dll
+share/NAnt/bin/lib/mono/2.0/NDoc.Documenter.Msdn.dll
+share/NAnt/bin/lib/mono/2.0/NDoc.ExtendedUI.dll
+share/NAnt/bin/lib/mono/2.0/nunit.core.dll
+share/NAnt/bin/lib/mono/2.0/nunit.framework.dll
+share/NAnt/bin/lib/mono/2.0/nunit.util.dll
+share/NAnt/bin/lib/net/1.0/NDoc.Core.dll
+share/NAnt/bin/lib/net/1.0/NDoc.Documenter.Msdn.dll
+share/NAnt/bin/lib/net/1.0/NDoc.ExtendedUI.dll
+share/NAnt/bin/lib/net/1.0/nunit.core.dll
+share/NAnt/bin/lib/net/1.0/nunit.framework.dll
+share/NAnt/bin/lib/net/1.0/nunit.util.dll
+share/NAnt/bin/lib/net/1.1/NDoc.Core.dll
+share/NAnt/bin/lib/net/1.1/NDoc.Documenter.Msdn.dll
+share/NAnt/bin/lib/net/1.1/NDoc.ExtendedUI.dll
+share/NAnt/bin/lib/net/1.1/nunit.core.dll
+share/NAnt/bin/lib/net/1.1/nunit.framework.dll
+share/NAnt/bin/lib/net/1.1/nunit.util.dll
+share/NAnt/bin/lib/net/2.0/NDoc.Core.dll
+share/NAnt/bin/lib/net/2.0/NDoc.Documenter.Msdn.dll
+share/NAnt/bin/lib/net/2.0/NDoc.ExtendedUI.dll
+share/NAnt/bin/lib/net/2.0/nunit.core.dll
+share/NAnt/bin/lib/net/2.0/nunit.framework.dll
+share/NAnt/bin/lib/net/2.0/nunit.util.dll
+share/NAnt/bin/log4net.dll
+share/NAnt/bin/scvs.exe
+%%PORTDOCS%%%%EXAMPLESDIR%%/Filters/ReplaceCharacter/ReplaceCharacter.cs
+%%PORTDOCS%%%%EXAMPLESDIR%%/Filters/ReplaceCharacter/default.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/HelloWindowsForms/HelloWindowsForms.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/HelloWindowsForms/HelloWindowsForms.vbproj
+%%PORTDOCS%%%%EXAMPLESDIR%%/HelloWindowsForms/MainForm.resx
+%%PORTDOCS%%%%EXAMPLESDIR%%/HelloWindowsForms/MainForm.vb
+%%PORTDOCS%%%%EXAMPLESDIR%%/HelloWorld/HelloWorld.cs
+%%PORTDOCS%%%%EXAMPLESDIR%%/HelloWorld/HelloWorld.js
+%%PORTDOCS%%%%EXAMPLESDIR%%/HelloWorld/HelloWorld.vb
+%%PORTDOCS%%%%EXAMPLESDIR%%/HelloWorld/default.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/ScriptTask/script-sample.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/Simple/Simple.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/Simple/Simple.cs
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/AssemblyInfo.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/Form1.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/Form1.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/Form1.resX
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/ReadMe.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/WinForms.sln
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/WinForms.vcproj
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/app.ico
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/app.rc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/cpp.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/resource.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/stdafx.cpp
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/WinForms/stdafx.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cpp/default.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cs/WinForms/App.ico
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cs/WinForms/AssemblyInfo.cs
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cs/WinForms/Form1.cs
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cs/WinForms/Form1.resx
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cs/WinForms/WinForms.csproj
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cs/WinForms/WinForms.sln
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cs/WinForms/cs.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/cs/default.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vb/WinForms/AssemblyInfo.vb
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vb/WinForms/Form1.resx
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vb/WinForms/Form1.vb
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vb/WinForms/WinForms.sln
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vb/WinForms/WinForms.vbproj
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vb/WinForms/vb.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vb/default.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vjs/WinForms/AssemblyInfo.jsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vjs/WinForms/Form1.jsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vjs/WinForms/Form1.resx
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vjs/WinForms/WinForms.sln
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vjs/WinForms/WinForms.vjsproj
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vjs/WinForms/vjs.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/Solution/vjs/default.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/StyleTask/SimpleExtensionObject/SimpleExtension.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/StyleTask/SimpleExtensionObject/SimpleExtension.cs
+%%PORTDOCS%%%%EXAMPLESDIR%%/StyleTask/SimpleExtensionObject/SimpleExtension.dll
+%%PORTDOCS%%%%EXAMPLESDIR%%/StyleTask/SimpleExtensionObject/circle.xsl
+%%PORTDOCS%%%%EXAMPLESDIR%%/StyleTask/SimpleExtensionObject/circles.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/UserTask/UserTask.cs
+%%PORTDOCS%%%%EXAMPLESDIR%%/UserTask/default.build
+%%PORTDOCS%%%%EXAMPLESDIR%%/examples.build
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.DataTypeBase.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Filters.ChainableReader.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Filters.Filter.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Filters.PhysicalTextReader.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Target.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Task.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.TaskContainer.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Tasks.ExternalProgramBase.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Tasks.InElement.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.Argument.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.EnvironmentSet.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.EnvironmentVariable.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.FileSet.Exclude.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.FileSet.ExcludesFile.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.FileSet.Include.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.FileSet.IncludesFile.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.Formatter.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.Option.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.PathElement.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.RawXml.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.Token.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.XmlNamespace.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.XsltExtensionObject.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.Core.Types.XsltParameter.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.DotNet.Tasks.CompilerBase.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.DotNet.Types.AssemblyAttribute.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.DotNet.Types.CompilerWarning.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.DotNet.Types.DataTypeCollectionBase.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.DotNet.Types.LibDirectorySet.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.DotNet.Types.NamespaceImport.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.DotNet.Types.Package.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.NUnit.Types.FormatterElement.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.NUnit1.Types.NUnitTest.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.NUnit2.Types.Category.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.NUnit2.Types.CategoryCollection.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.NUnit2.Types.NUnit2Test.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.SourceControl.Tasks.AbstractCvsTask.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.SourceControl.Tasks.AbstractSourceControlTask.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.VSNet.Types.WebMap.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.VisualCpp.Types.Library.html
+%%PORTDOCS%%%%DOCSDIR%%/help/elements/NAnt.VisualCpp.Types.Symbol.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.Compression.Tasks.TarCompressionMethod.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.Core.Level.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.Core.Tasks.AvailableTask.ResourceType.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.Core.Tasks.LoopTask.LoopItem.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.Core.Tasks.LoopTask.LoopTrim.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.DotNet.Tasks.AssemblyInfoTask.CodeLanguage.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.DotNet.Tasks.RegsvcsTask.ActionType.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.DotNet.Types.DebugOutput.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.MSNet.Tasks.ServiceControllerTask.ActionType.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.NUnit.Types.FormatterType.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.VisualCpp.Tasks.ClTask.PrecompiledHeaderMode.html
+%%PORTDOCS%%%%DOCSDIR%%/help/enums/NAnt.VisualCpp.Types.CharacterSet.html
+%%PORTDOCS%%%%DOCSDIR%%/help/filters/expandproperties.html
+%%PORTDOCS%%%%DOCSDIR%%/help/filters/index.html
+%%PORTDOCS%%%%DOCSDIR%%/help/filters/replacestring.html
+%%PORTDOCS%%%%DOCSDIR%%/help/filters/replacetokens.html
+%%PORTDOCS%%%%DOCSDIR%%/help/filters/tabstospaces.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/assembly.get-full-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/assembly.get-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/assembly.load-from-file.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/assemblyname.get-assembly-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/assemblyname.get-codebase.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/assemblyname.get-escaped-codebase.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/assemblyname.get-full-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/assemblyname.get-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/assemblyname.get-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/bool.parse.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/bool.to-string.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/convert.to-boolean.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/convert.to-datetime.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/convert.to-double.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/convert.to-int.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/convert.to-string.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.get-day-of-week.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.get-day-of-year.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.get-day.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.get-days-in-month.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.get-hour.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.get-millisecond.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.get-minute.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.get-month.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.get-second.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.get-ticks.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.get-year.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.is-leap-year.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.now.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.parse.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/datetime.to-string.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/directory.exists.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/directory.get-creation-time.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/directory.get-current-directory.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/directory.get-directory-root.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/directory.get-last-access-time.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/directory.get-last-write-time.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/directory.get-parent-directory.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/double.parse.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/double.to-string.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/environment.get-folder-path.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/environment.get-machine-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/environment.get-operating-system.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/environment.get-user-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/environment.get-variable.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/environment.get-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/environment.variable-exists.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/file.exists.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/file.get-creation-time.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/file.get-last-access-time.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/file.get-last-write-time.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/file.get-length.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/file.is-assembly.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/file.up-to-date.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/fileversioninfo.get-company-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/fileversioninfo.get-file-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/fileversioninfo.get-product-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/fileversioninfo.get-product-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/fileversioninfo.get-version-info.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.exists.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.get-assembly-directory.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.get-clr-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.get-description.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.get-family.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.get-framework-directory.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.get-runtime-engine.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.get-runtime-framework.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.get-sdk-directory.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.get-target-framework.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.get-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/framework.sdk-exists.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/index.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/int.parse.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/int.to-string.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/long.parse.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/long.to-string.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/math.abs.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/math.ceiling.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/math.floor.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/math.round.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/nant.get-assembly.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/nant.get-base-directory.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/operating-system.get-platform.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/operating-system.get-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/operating-system.to-string.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.change-extension.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.combine.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.get-directory-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.get-extension.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.get-file-name-without-extension.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.get-file-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.get-full-path.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.get-path-root.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.get-temp-file-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.get-temp-path.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.has-extension.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/path.is-path-rooted.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/pkg-config.exists.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/pkg-config.get-compile-flags.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/pkg-config.get-link-flags.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/pkg-config.get-mod-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/pkg-config.get-variable.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/pkg-config.is-atleast-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/pkg-config.is-between-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/pkg-config.is-exact-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/pkg-config.is-max-version.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/platform.get-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/platform.is-unix.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/platform.is-win32.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/project.get-base-directory.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/project.get-buildfile-path.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/project.get-buildfile-uri.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/project.get-default-target.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/project.get-name.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/property.exists.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/property.get-value.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/property.is-dynamic.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/property.is-readonly.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.contains.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.ends-with.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.get-length.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.index-of.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.last-index-of.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.pad-left.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.pad-right.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.replace.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.starts-with.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.substring.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.to-lower.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.to-upper.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.trim-end.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.trim-start.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/string.trim.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/target.exists.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/target.get-current-target.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/target.has-executed.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/task.exists.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.from-days.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.from-hours.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.from-milliseconds.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.from-minutes.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.from-seconds.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.from-ticks.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.get-days.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.get-hours.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.get-milliseconds.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.get-minutes.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.get-seconds.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.get-ticks.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.get-total-days.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.get-total-hours.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.get-total-milliseconds.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.get-total-minutes.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.get-total-seconds.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.parse.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/timespan.to-string.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/version.get-build.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/version.get-major.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/version.get-minor.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/version.get-revision.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/version.parse.html
+%%PORTDOCS%%%%DOCSDIR%%/help/functions/version.to-string.html
+%%PORTDOCS%%%%DOCSDIR%%/help/fundamentals/buildfiles.html
+%%PORTDOCS%%%%DOCSDIR%%/help/fundamentals/expressions.html
+%%PORTDOCS%%%%DOCSDIR%%/help/fundamentals/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/help/fundamentals/index.html
+%%PORTDOCS%%%%DOCSDIR%%/help/fundamentals/listeners.html
+%%PORTDOCS%%%%DOCSDIR%%/help/fundamentals/projects.html
+%%PORTDOCS%%%%DOCSDIR%%/help/fundamentals/properties.html
+%%PORTDOCS%%%%DOCSDIR%%/help/fundamentals/running-nant.html
+%%PORTDOCS%%%%DOCSDIR%%/help/fundamentals/targets.html
+%%PORTDOCS%%%%DOCSDIR%%/help/fundamentals/tasks.html
+%%PORTDOCS%%%%DOCSDIR%%/help/images/arrow.gif
+%%PORTDOCS%%%%DOCSDIR%%/help/images/bullet.gif
+%%PORTDOCS%%%%DOCSDIR%%/help/images/logo.gif
+%%PORTDOCS%%%%DOCSDIR%%/help/index.html
+%%PORTDOCS%%%%DOCSDIR%%/help/introduction/fog0000000006.html
+%%PORTDOCS%%%%DOCSDIR%%/help/introduction/fog0000000041.html
+%%PORTDOCS%%%%DOCSDIR%%/help/introduction/fog0000000042.html
+%%PORTDOCS%%%%DOCSDIR%%/help/introduction/fog0000000079.html
+%%PORTDOCS%%%%DOCSDIR%%/help/introduction/fog0000000081.html
+%%PORTDOCS%%%%DOCSDIR%%/help/introduction/getting-started.gif
+%%PORTDOCS%%%%DOCSDIR%%/help/introduction/index.html
+%%PORTDOCS%%%%DOCSDIR%%/help/introduction/installation.html
+%%PORTDOCS%%%%DOCSDIR%%/help/style.css
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/al.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/asminfo.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/attrib.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/available.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/aximp.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/call.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/cl.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/copy.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/csc.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/cvs-changelog.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/cvs-checkout.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/cvs-export.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/cvs-pass.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/cvs-rtag.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/cvs-tag.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/cvs-update.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/cvs.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/delay-sign.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/delete.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/description.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/echo.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/exec.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/fail.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/foreach.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/get.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/gunzip.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/if.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/ifnot.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/ilasm.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/ildasm.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/include.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/index.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/jsc.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/lib.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/license.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/link.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/loadfile.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/loadtasks.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/mail.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/mc.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/midl.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/mkdir.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/move.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/nant.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/nantschema.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/ndoc.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/nunit.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/nunit2.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/property.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/rc.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/readregistry.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/regex.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/regsvcs.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/resgen.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/script.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/servicecontroller.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/setenv.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/sleep.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/solution.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/style.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/sysinfo.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/tar.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/tlbexp.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/tlbimp.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/touch.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/tstamp.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/unzip.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/uptodate.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/vbc.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/vjc.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/xmlpeek.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/xmlpoke.html
+%%PORTDOCS%%%%DOCSDIR%%/help/tasks/zip.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/assemblyfileset.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/categoryset.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/credential.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/cvsfileset.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/dirset.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/fileset.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/filterchain.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/index.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/namespaceimports.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/path.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/proxy.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/resourcefileset.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/tarfileset.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/warnaserror.html
+%%PORTDOCS%%%%DOCSDIR%%/help/types/zipfileset.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/releasenotes.html
+@dirrm share/NAnt/bin/lib/net/2.0
+@dirrm share/NAnt/bin/lib/net/1.1
+@dirrm share/NAnt/bin/lib/net/1.0
+@dirrm share/NAnt/bin/lib/net
+@dirrm share/NAnt/bin/lib/mono/2.0
+@dirrm share/NAnt/bin/lib/mono/1.0
+@dirrm share/NAnt/bin/lib/mono
+@dirrm share/NAnt/bin/lib
+@dirrm share/NAnt/bin
+@dirrm share/NAnt
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/UserTask
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/StyleTask/SimpleExtensionObject
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/StyleTask
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Solution/vjs/WinForms
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Solution/vjs
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Solution/vb/WinForms
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Solution/vb
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Solution/cs/WinForms
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Solution/cs
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Solution/cpp/WinForms
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Solution/cpp
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Solution
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Simple
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/ScriptTask
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/HelloWorld
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/HelloWindowsForms
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Filters/ReplaceCharacter
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Filters
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/types
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/tasks
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/introduction
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/fundamentals
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/functions
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/filters
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/enums
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/elements
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help
+%%PORTDOCS%%@dirrm %%DOCSDIR%%