aboutsummaryrefslogtreecommitdiff
path: root/devel/ncnf/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-05-29 14:01:16 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-05-29 14:01:16 +0000
commit19453f9038c66739d2d3d422211d560291b1e6f9 (patch)
tree8706350f262fbfd725d1eb8975da1f89fc6c86c6 /devel/ncnf/Makefile
parentf38f90aa70048deb89c27e5800e8c311a53c75ea (diff)
downloadports-19453f9038c66739d2d3d422211d560291b1e6f9.tar.gz
ports-19453f9038c66739d2d3d422211d560291b1e6f9.zip
Notes
Diffstat (limited to 'devel/ncnf/Makefile')
-rw-r--r--devel/ncnf/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/ncnf/Makefile b/devel/ncnf/Makefile
new file mode 100644
index 000000000000..f7a1d60a5f86
--- /dev/null
+++ b/devel/ncnf/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ncnf
+# Date created: 29 May 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ncnf
+PORTVERSION= 3.0.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Generic configuration management library
+
+LIB_DEPENDS= strfunc.7:${PORTSDIR}/devel/libstrfunc
+
+INSTALLS_SHLIB= YES
+USE_LIBTOOL_VER=15
+USE_REINPLACE= YES
+
+post-patch:
+.ifdef NOPORTDOCS
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s/doc//' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>