aboutsummaryrefslogtreecommitdiff
path: root/devel/ncurses-devel
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-29 04:46:28 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-29 04:46:28 +0000
commit0129a04b176ca65bf3ac81ec08135e3743ff36cd (patch)
treec41990d4d5346247ec9d02aca23475ebb296dcf9 /devel/ncurses-devel
parent88109113b60dbc0ddfec4b42555234cb9fc2d9d0 (diff)
Notes
Diffstat (limited to 'devel/ncurses-devel')
-rw-r--r--devel/ncurses-devel/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/devel/ncurses-devel/Makefile b/devel/ncurses-devel/Makefile
index a5fb96d37f52..297fe6deb25f 100644
--- a/devel/ncurses-devel/Makefile
+++ b/devel/ncurses-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ncurses-devel
-# Date created: Jan 28 2006
-# Whom: Rong-En Fan <rafan@FreeBSD.org>
-#
+# Created by: Rong-En Fan <rafan@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ncurses
PORTVERSION= ${RELEASE}.${PATCHDATE}
@@ -46,7 +42,9 @@ CONFIGURE_ARGS= --datadir=${PREFIX}/share/misc --disable-overwrite \
--with-manpage-format=gzip --srcdir=../
MAKE_JOBS_UNSAFE= yes
-OPTIONS= EXTCOLORS "Enable 256-color support (only for ncursesw)" off
+OPTIONS_DEFINE= EXTCOLORS TRACE
+EXTCOLORS_DESC= 256-color support (only for ncursesw)
+TRACE_DESC= Add trace() function to all models of ncurses
CONFIGURE_ENV= gnat_exists="no"
@@ -98,14 +96,14 @@ EXAMPLES_CPP= Makefile NEWS PROBLEMS README-first cursesapp.cc \
.include "${.CURDIR}/Makefile.man"
CONFIGURE_ARGS_WIDEC=--enable-widec
-.if defined(WITH_EXTCOLORS)
+.if ${PORT_OPTIONS:MEXTCOLORS}
CONFIGURE_ARGS_WIDEC+=--enable-ext-colors
NCURSESW_ABI_VER= 6
NCURSESW_REL_VER= 6.0
.endif
# needed by devel/py-ncurses port
-.if defined(WITH_TRACE)
+.if ${PORT_OPTIONS:MTRACE}
CONFIGURE_ARGS+= --with-trace
.endif
@@ -173,7 +171,7 @@ post-install:
${MAKE} ${.MAKEFLAGS} INSTALL_WRKSRC=${WIDEC_WRKSRC} do-install
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
. for i in ${EXAMPLES_TARGETS}
${MKDIR} ${${i}_EXAMPLESDIR}/c++
. for f in ${EXAMPLES}
@@ -190,7 +188,7 @@ post-install:
${FIND} ${PREFIX}/share/misc -name "*.terminfo" -exec ${PREFIX}/bin/tic {} \;
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/