aboutsummaryrefslogtreecommitdiff
path: root/devel/nemiver/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-04 12:13:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-04 12:13:55 +0000
commit26766b92d23f0b0e574b9e3d0e00df368ccf9dad (patch)
treef88e10366397cf589f124dcfc62a61d0826d66fd /devel/nemiver/Makefile
parent2ba0554cf6723f3035eb846c74014d515bc1e810 (diff)
Notes
Diffstat (limited to 'devel/nemiver/Makefile')
-rw-r--r--devel/nemiver/Makefile54
1 files changed, 27 insertions, 27 deletions
diff --git a/devel/nemiver/Makefile b/devel/nemiver/Makefile
index 9e1981f4305b..d695875b92b6 100644
--- a/devel/nemiver/Makefile
+++ b/devel/nemiver/Makefile
@@ -1,41 +1,41 @@
-# New ports collection makefile for: nemiver
-# Date created: 2008-02-22
-# Whom: Romain Tartiere <romain@blogreen.org>
+# New ports collection makefile for: nemiver
+# Date created: 2008-02-22
+# Whom: Romain Tartiere <romain@blogreen.org>
#
# $FreeBSD$
#
-PORTNAME= nemiver
-PORTVERSION= 0.6.4
-CATEGORIES= devel
-MASTER_SITES= GNOME
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
-DIST_SUBDIR= gnome2
+PORTNAME= nemiver
+PORTVERSION= 0.6.5
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+DIST_SUBDIR= gnome2
-MAINTAINER= romain@blogreen.org
-COMMENT= A C/C++ Debugger for GNOME
+MAINTAINER= romain@blogreen.org
+COMMENT= A C/C++ Debugger for GNOME
-LIB_DEPENDS= boost_unit_test_framework:${PORTSDIR}/devel/boost \
+LIB_DEPENDS= boost_unit_test_framework:${PORTSDIR}/devel/boost \
gtop-2.0:${PORTSDIR}/devel/libgtop \
sqlite3:${PORTSDIR}/databases/sqlite3 \
vte.9:${PORTSDIR}/x11-toolkits/vte \
glademm-2.4:${PORTSDIR}/devel/libglademm24 \
gtksourceviewmm-2:${PORTSDIR}/x11-toolkits/libgtksourceviewmm
-OPTIONS= GHEX "Enable memory view" off
+OPTIONS= GHEX "Enable memory view" off
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intltool gnomedocutils gconf2
-GCONF_SCHEMAS= nemiver-workbench.schemas nemiver-dbgperspective.schemas
-USE_LDCONFIG= yes
-USE_GETTEXT= yes
-INSTALLS_OMF= yes
-INSTALLS_ICONS= yes
-MAN1= nemiver.1
-
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack intltool gnomedocutils gconf2
+GCONF_SCHEMAS= nemiver-workbench.schemas nemiver-dbgperspective.schemas
+USE_LDCONFIG= yes
+USE_GETTEXT= yes
+INSTALLS_OMF= yes
+INSTALLS_ICONS= yes
+MAN1= nemiver.1
+
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
@@ -46,11 +46,11 @@ BROKEN= Does not compile on 6.x
.if defined(WITH_GHEX) && !defined(WITHOUT_GHEX)
CONFIGURE_ARGS+=--enable-memoryview
-PLIST_SUB+= GHEX=""
-LIB_DEPENDS+= gtkhex.0:${PORTSDIR}/editors/ghex
+PLIST_SUB+= GHEX=""
+LIB_DEPENDS+= gtkhex.0:${PORTSDIR}/editors/ghex
.else
CONFIGURE_ARGS+=--disable-memoryview
-PLIST_SUB+= GHEX="@comment "
+PLIST_SUB+= GHEX="@comment "
.endif
.include <bsd.port.post.mk>