aboutsummaryrefslogtreecommitdiff
path: root/devel/newfile/Makefile
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2003-01-30 21:26:10 +0000
committerAlan Eldridge <alane@FreeBSD.org>2003-01-30 21:26:10 +0000
commit9ab5f9df50b04aa1d576a7caac7311fde83c0498 (patch)
treed4f109f755ae06607ffbb66fcd2df0548d6cf725 /devel/newfile/Makefile
parenta19d5cb626604914d5e96de218a444fd035b8dad (diff)
downloadports-9ab5f9df50b04aa1d576a7caac7311fde83c0498.tar.gz
ports-9ab5f9df50b04aa1d576a7caac7311fde83c0498.zip
Notes
Diffstat (limited to 'devel/newfile/Makefile')
-rw-r--r--devel/newfile/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/newfile/Makefile b/devel/newfile/Makefile
new file mode 100644
index 000000000000..68efe0a4bb9d
--- /dev/null
+++ b/devel/newfile/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: newfile
+# Date created: Thu Jan 30 17:34:12 CET 2003
+# Whom: Miguel Mendez <flynn@energyhq.homeip.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= newfile
+PORTVERSION= 1.0.1.b.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= flynn@energyhq.homeip.net
+
+BUILD_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
+BUILD_DEPENDS+= rdoc:${PORTSDIR}/textproc/ruby-rdoc
+
+USE_RUBY= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+.if !defined(NOPORTDOCS)
+MAN1= newfile.1
+.endif
+
+pre-configure:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's@SUBDIRS = src doc data doc-src www@SUBDIRS = src data@g' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>