aboutsummaryrefslogtreecommitdiff
path: root/devel/newtonsoft-json
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-10-06 23:10:28 +0000
committerJohn Marino <marino@FreeBSD.org>2014-10-06 23:10:28 +0000
commit926b6aaebbdb9c32353a8ffc26af324a0e5dd54b (patch)
tree0beba73271379cfa7e80a87a1be7386f7b740e32 /devel/newtonsoft-json
parent6d794e8f03e006af71b4b62d15601209d99ba115 (diff)
downloadports-926b6aaebbdb9c32353a8ffc26af324a0e5dd54b.tar.gz
ports-926b6aaebbdb9c32353a8ffc26af324a0e5dd54b.zip
Notes
Diffstat (limited to 'devel/newtonsoft-json')
-rw-r--r--devel/newtonsoft-json/Makefile46
-rw-r--r--devel/newtonsoft-json/distinfo2
-rw-r--r--devel/newtonsoft-json/files/Newtonsoft.Json.pc.in8
-rw-r--r--devel/newtonsoft-json/pkg-descr13
4 files changed, 69 insertions, 0 deletions
diff --git a/devel/newtonsoft-json/Makefile b/devel/newtonsoft-json/Makefile
new file mode 100644
index 000000000000..2e605c3b010b
--- /dev/null
+++ b/devel/newtonsoft-json/Makefile
@@ -0,0 +1,46 @@
+# Created by: Muhammad Moinur Rahman <5u623l20@gmail.com>
+# $FreeBSD$
+
+PORTNAME= newtonsoft-json
+PORTVERSION= 6.0.5
+CATEGORIES= devel
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= Popular high-performance JSON framework for .NET
+
+LICENSE= MIT
+
+USES= mono
+
+USE_GITHUB= yes
+GH_ACCOUNT= JamesNK
+GH_PROJECT= Newtonsoft.Json
+GH_COMMIT= d463fce
+
+SUB_FILES= Newtonsoft.Json.pc
+
+PLIST_FILES= lib/mono/Newtonsoft.Json/Newtonsoft.Json.dll \
+ lib/mono/gac/Newtonsoft.Json/6.0.0.0__b9a188c8922137c6/Newtonsoft.Json.dll \
+ lib/mono/gac/Newtonsoft.Json/6.0.0.0__b9a188c8922137c6/Newtonsoft.Json.dll.mdb \
+ libdata/pkgconfig/Newtonsoft.Json.pc
+
+do-build:
+ (cd ${WRKSRC}/Src/Newtonsoft.Json && xbuild Newtonsoft.Json.csproj \
+ /property:SignAssembly=true \
+ /property:AssemblyOriginatorKeyFile=Dynamic.snk \
+ /property:Configuration=Release \
+ /property:DefineConstants='SIGNED NET45 TRACE')
+ (cd ${WRKSRC}/Src/Newtonsoft.Json/bin/Release/Net45 && \
+ monodis Newtonsoft.Json.dll --output=Newtonsoft.Json.il)
+ (cd ${WRKSRC}/Src/Newtonsoft.Json/bin/Release/Net45 && \
+ ilasm /dll /key:../../../Dynamic.snk Newtonsoft.Json.il)
+
+do-install:
+ (cd ${WRKSRC}/Src/Newtonsoft.Json/bin/Release/Net45 && \
+ ${SETENV} MONO_SHARED_DIR=${WRKDIR} ${LOCALBASE}/bin/gacutil \
+ /root ${STAGEDIR}${PREFIX}/lib/ \
+ /package Newtonsoft.Json /i Newtonsoft.Json.dll)
+ (cd ${WRKDIR} && ${INSTALL_DATA} Newtonsoft.Json.pc \
+ ${STAGEDIR}${PREFIX}/libdata/pkgconfig)
+
+.include <bsd.port.mk>
diff --git a/devel/newtonsoft-json/distinfo b/devel/newtonsoft-json/distinfo
new file mode 100644
index 000000000000..628485067072
--- /dev/null
+++ b/devel/newtonsoft-json/distinfo
@@ -0,0 +1,2 @@
+SHA256 (newtonsoft-json-6.0.5.tar.gz) = a6efc6dc79f661d163b8d96cc6e4e0f762000d834a54c653907f755e564a1cde
+SIZE (newtonsoft-json-6.0.5.tar.gz) = 2178378
diff --git a/devel/newtonsoft-json/files/Newtonsoft.Json.pc.in b/devel/newtonsoft-json/files/Newtonsoft.Json.pc.in
new file mode 100644
index 000000000000..0482b6a04cff
--- /dev/null
+++ b/devel/newtonsoft-json/files/Newtonsoft.Json.pc.in
@@ -0,0 +1,8 @@
+prefix=%%LOCALBASE%%
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+
+Name: Newtonsoft JSON
+Description: Popular high-performance JSON framework for .NET.
+Version: 6.0.5
+Libs: -r:${libdir}/mono/newtonsoft.json/Newtonsoft.Json.dll
diff --git a/devel/newtonsoft-json/pkg-descr b/devel/newtonsoft-json/pkg-descr
new file mode 100644
index 000000000000..44732d87c14d
--- /dev/null
+++ b/devel/newtonsoft-json/pkg-descr
@@ -0,0 +1,13 @@
+Popular high-performance JSON framework for .NET
+* Flexible JSON serializer for converting between .NET objects and JSON
+* LINQ to JSON for manually reading and writing JSON
+* High performance, faster than .NET's built-in JSON serializers
+* Write indented, easy to read JSON
+* Convert JSON to and from XML
+* Supports .NET 2, .NET 3.5, .NET 4, .NET 4.5, Silverlight, Windows Phone and
+ Windows 8 Store
+
+The JSON serializer in Json.NET is a good choice when the JSON you are reading
+or writing maps closely to a .NET class.
+
+WWW: http://james.newtonking.com/json